OpenWrt for Zyxel WSM20 (Multy M1) development discussion

censored it's censored..
simple example: a timer will be affixed to the post which will never reset in the event of a response and will therefore be closed quickly
*
I use in this moment OpenWrt 22.03.3 with MTK mt7915_20200814-bb4577 drivers
the speed is not perfect & not DFS automatic channels possibility but i am not able to find out why
but it's very stable in STA/AP ( no WDS or relayd ) which the open source mt7915 driver doesn't

I use without any worries or cuts with TV channels
Orange LiveBox 6 <-- WIFI 5 GHZ --> Zyxel WSM20 <-- LAN --> Orange UHD TV box
*
If anyone is interested i can ask the friend who helped me

Where have you found that censorship?

BTW the guys from ZyXEL contacted me recently to tell me that the official DTS will be posponed again. I won't believe that they will deliver anything that may improve what we currently have, but who knows.

Ok, I get you now

You are using the Belkin RT1800 wifi MTK drivers from the Belkin official sources because you believe that the MTK drives that are being currently shipped with OpenWrt are really bad

Interesting... Personally I don't really need AX because this is my secondary network for device that barely use AC and even 2.4Ghz band. In fact, for the price, this device cost me even less than pure AC routers, so I would be fine even with that.

You are running your ZyXEL in bridged mode for your UHD TV Box.

I may try to use that mt7915_20200814-bb4577 version in my testing device.

Which diferences have you found between the mt7915_20200814-bb4577 and the OWrt default?

BTW have you tried mt7915_20201106-34067b? It's slightly newer and maybe it's slightly more performant

Anyway I can't believe that such old driver is better performing compared to the officially MTK supported opensource driver... It makes no sense. I must test it with iperf to prove it right.

for the GPL code
OEM firmware is by nossiac who came to this forum a few years ago and who had to give up given the criticism, the old OpenWrt shutdown, taken over by LEDE and the new OpenWrt
the GPL Belkin version is for compare with what i currently use

I use a firmware 22.03.3 that i compiled myself with the indicated driver
I have at least 400/400 Mbs which is very stable & in STA/AP mode
That's all I ask to have 4K TV channels with 3 * WSM20 boxes working at the same time
I use also a RT1800 Belkin

For the drivers there have been problems for many years
Just search a bit and you will find multitudes of posts on this subject

I have to say that I'm not really concerned about transfer rate, but latency. Anyway, I will be personally running iperf

I've been lately very annoyed with my Asus XT8 devices that cost me almost $200 ea and being doing some network tests because I could not believe they were so shit for that price (and they are).

Now I'm trying to revamp my whole network selling all the shit stuff. I'm going to keep these WSM20 100% because the price was literally blasting, but I will try all those 3 drivers, yours, the newer version (34067b) and the ones that are being currently shipped in the last snapshot.

Anyway, I don't understand your issues. I've checked the latest Linux kernel version, and OpenWrt are basically using the exact same version (in fact one that it's slightly newer). OpenWrt is not using any strange or weird specific driver, but the upstream MTK drivers, that in fact, are being supported by Mediatek. I can understand that some very specific driver was better performant in the past, but still 99% of the OS systems, including both Linux kernel for all main GNU/Linux distros and OpenWrt are using such. It's unlikely that OpenWrt will simply use a very old driver that was simply better performing, basically they are going to stick to the latest driver.

What I cannot understand is why Mediatek has been downgrading the quality of the OS driver. It's their real fault, not OWrt. By the way it's kind of funny that OEM vendors (many using LEDE not OWrt) stick to old drivers, because they found better performance.

For me the biggest problem is that OpenWrt does not work in STA/AP mode with my box - LiveBox 6 used by millions of users of the Orange network

For SFR boxes, Bouyghes, ... it's the same

And that we do not say that their firmware is bad and does not comply with standards or security

These access providers also have boxes in PRO version

With OEM firmwares STA/AP mode works

I have not tried this mode. Personally I don't have any bridged devices, but in case I had, I would probably simply plug another AP and leave the WSM20 only for bridged/STA mode.

Consider you have like 50 WSM20, why don't you simply do this?

About performance, you said you noted some little drops on the wireless connection regularly that did not affect the buffering of your media but they were still there?

1 - I tried with relayd and I have too many cuts with streams for televisions for it to be usable
2 - With 2 * WSM20 in WDS it's the same

With MTK drivers it is stable as a rock

This is not specific with WIFI 6 / AX because with it also concerns my old WR1200JS , Newifi-D2 or XIAOMi R3G which are in AC
In this case i use Azexios firmwares qui ont aussi des pilotes MTK

Exist also Padavan for this routers with MTK drivers

2 Likes

Padavan's firmware for WSM20?

No Padavan is only for Router with WIFI AC ( mt7615 not mt7915 )

I search help for download files chinese site

Use the software that the router came with if you like it that much.
But don't derail every topic you can with those MTK drivers.

4 Likes

znevna ->

I do not use the firmware provided by the manufacturer of the product ...

My build ( not standard because i have replaced the OEM boot partition ) :

Hostname ZYXEL-MTK-166
Model WSM20
Architecture MediaTek MT7621 ver:1 eco:3
Target Platform ramips/mt7621
Firmware Version OpenWrt 22.03.3 r20028-43d71ad93e / LuCI openwrt-22.03 branch git-22.361.69894-438c598
Kernel Version 5.10.161

I just received my WSM20 and did some tests:
Power consumption idle + 2x wifi-AP (idle) 4,5W; +0,3W per connected ethernet port; +3W on WiFi loaded with 100 Mbit/s downstream AP-> device, +2W with 35 Mbit/s Upstream Client -> AP

In comparison to the WAX206, the WiFi signal was about 3 dB weaker on my Google Pixel 6a. Also, throughput via iperf3 (Pixel 6a towards my computer, Phone via WiFi, computer via ethernet) was in most cases 30..50% faster on the WAX206, at one position 10% faster on the WSM20.
I achieved ~750 Mbit/s download (vs. 850 Mbit/s WAX206) 10m with line of sight
... 300 Mbit/s (vs. 500 Mbit/s with WAX206) 10m with obstacles
... 30-50 Mbit/s (vs. 100 Mbit/s with WAX206) 15m with more obstacles (both running on 80 MHz with max. transmit power of 23dBm).
In most cases, the MCS index on the WSM was lower than the one on the WAX, sometimes also the MIMO count dropped to 1.

WSM20 firmware was todays snapshot ad233c6ddd63, WAX206 was on r22565-877ec78e23, so quite a bit older.

Also, I had the "mediatek AX upload problem" with the WAX, not with the WSM20: As soon as I had obstacles on the way, the client device upload was stuck on the lowest MCS level. I did not follow recent patches that might have been on snapshot or not, in any case afaik so far this was only ever reproduced with apple devices? Well, I reproduced it with my Pixel6a.

All in all, the WSM20 is a great device for its price but the WAX206 is superior with range and throughput.
Still, the WSM20 is a far superior device than the well known Archer C5 on ath79, as long as you don't need USB :wink:

5 Likes

Also the WAX206 has 2.5G Ethernet, which future proofs for when connections are that fast.

I’m still pretty happy with my 3 WSM20 (~£85) devices for the cost of of one WAX206 (RRP £145, prime day offer ~£80) device. Also my range is excellent despite being in a city and having ~50 visible SSIDs! :blush:

Looking forward to 23.05.0 RC3 as it should have the fix for AX capable iOS devices, which I think is the last significant bug on this device?

1 Like

May I ask how long it takes from here forwards to a final release version incl. Luci?

And may I flash the latest sysupgrade.bin just over the old one and keep Luci? Or have to install again?

Depends on how many critical issues are found in the RCs.

Yes, RCs and stable come with luci, snapshots don't.

1 Like

Thx! Very appreciated!

Hello everyone,

I guess I made a mistake ... I wanted to go for a WAX206, but availability and price of the WSM20 was much better, and in the end, I chose the latter... and I am stuck in the installation :worried:
So, I have tried to follow the procedure here: https://openwrt.org/toh/zyxel/wsm20#via_web_interface
I downloaded the snapshot files, verified the ha256sum and then started... after connecting the Multy M1 to the internet via cable, I could access the web GUI and upload the file xxxxkernel.bin.
The problem is that the Multy had not rebooted (after many minutes), it was stuck loading something, the message was "Welcome to the web configurator" and then "Warning, we are experiencing some service problems. Refresh the page and try again later". Which I did, but always same results, even after 1 hour.
Last resort, I thought of disconnecting the power supply or resetting the Multy M1 by pressing the reset button on the rear. In the first case, after reconnecting again, it was stuck on the same page, and in the second case, the device did not respond to the button (it did not turn off or reboot), but keep staying on the same page.

Since I am not an expert on flashing OpenWRT, I would appreciate some guidance.

Thank you in advance to those who will take the time to read and reply.

To reset you need to hold the reset button for quite a while then release it.

The first install doesn’t do a full reboot, it just reloads from RAM. There’s no web ui so you will need to log in via ssh and scp the sysupgrade firmware

Since I am not an expert on flashing OpenWRT, I would appreciate some guidance.

I am not an expert either, but I have successfully flashed two of my three WSM20s. I have not tried the last one yet.

As timothyjward says above, the problem probably was that you did not login using SSH after the initramfs image upload was done in the OEM firmware.

I have not tried it myself, but I believe it is possible to use the firmware selector to build an initramfs/"Kernel" image with the LuCI GUI for use with the OEM flash web page. Add "luci" without quotes to the "Customize installed packages and/or first boot script"/"Installed packages" text box and click "Request build".

When OpenWrt boots it should assign an IP in the default 192.168.1.1/24 range to the computer attached to a LAN port. From there you should be able to login at 192.168.1.1 with SSH (putty in Windows) and run the sysupgrade command on a sysupgrade image file (which you can transfer to the router with WinSCP on Windows, chose file protocol SCP). Or if you added luci in the firmware selector, you should get LuCI at http://192.168.1.1 from where you could go to the firmware flash page and flash the sysupgrade image.

When you flash the WSM20 from the OEM firmware, the LED patterns looks like this according to my notes:

  1. initramfs is being written: Red flash
  2. Boot is starting: Green steady
  3. Linux starting: White flash
  4. Linux ready: White steady

It can take a few more seconds before everything is ready. Wait 30 seconds or so with the white steady LED before trying to connect.

1 Like