OpenWrt Firmware for Archer c6 v3.2

Idk what to say,it is sad and bad for community.I was decided to purchase it.Because is cheaper then C6U.

I have instaled the snapshot version from 3 weeks ago, but last week I have tryed to upgrade to the last snapshot, but after that it starts to boot loop. But I can´t have the TFTP working to install a new firmware. Can anyone help me how to unbrick it?

Have you identified the serial port?

It's a known issue due to a Wi-Fi problem in some builds. This has already been resolved in the more recent builds.

To recover from this you must enter in Fail Safe mode by pressing the reset button before boot while power is flashing slowly and flash a more recent build.

1 Like

I have used The same process of the v2 Version. But It not working.
Turn on with The reset button, put my PC with 192.168.0.66 and tftp, But no thing happens.

i think you must use info from git commit https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=d22fb7f4fd833c420bc2ab34384862da0a6688b5

The TFTP Booting I don´t know how to acess this U-boot, I think that is using the serial, but I can´t find the pins on the board.

The second method of restarting 4 time before full boot, don´t work either.

What I discovered now, is the the Led sequence changes when I push the reset pin as son as the power led starts blinking, the it starts blinking fast and do not stops.
I have already tried with wireshar to see if have any attpempt of the board to connect any IP address, but no luck.

TFTP Booting

Setup a TFTP boot server with address 192.168.0.5.
While starting U-boot press '4' key to stop autoboot.
Copy the initramfs-kernel.bin[1] to TFTP server folder, rename as test.bin
From u-boot command prompt run tftpboot followed by bootm.

Recovery

Archer A6 V3 has recovery page activated if SPI booting from flash fails.
Recovery page can be activated by powercycling the router four times
before the boot process is complete.
Note: TFTP boot can be activated only from u-boot serial console.
Device recovery address: 192.168.0.1

This is fail safe mode, and you should be able to access via SSH to IP address 192.168.1.1. See below for more details:

Thanks a lot, I´ve never heard about this fail safe. It worked. Thanks

:slightly_smiling_face:My router Archer C6 v3.2 :slightly_smiling_face:Luci not showing up, wireless enable/disable button not working... what do i do......
Urgent help required..please someone help me otherwise i will be in trouble if my brother gets to know

:slightly_smiling_face:Thanks a lot man.... but can u help me with 5Ghz wifi problem... inbox me if u are available

I suggest either waiting for the stable build for this device to come out, or install the stable version for archer a6 v3, they are identical devices, and will work fine.

Will this work for an Archer A6 V3 US? Thanks!

Follow this tutorial, to bring your Acher c6 v3.20 back, it worked for me right away!

https://www.tp-link.com/br/support/faq/1482/

Were you upgrading to openwrt when brick??? or was it with the tp-link firmware ??? I just wanted to know some details when the event occurred...

Where Can I follow the progress on this Project ?

Thanks.

I am using the Archer A6v3 version on my C6v3.2 and it works fine.

So you just installed it from the firmware upgrade page ? and everything works out of the Box ?

Anything to be aware of before proceeding.

Thanks in advance.

Yes I had initially installed the snapshot version without LUCI so faced some problems, you can directly install the factory.bin with luci and it works flawlessly; only problem is you have to manually set 5ghz network to channel 36 (and never on auto) otherwise it will cause problems.
Which ISP btw?

1 Like

ISP is Act, so some limitations on 5Ghz. Will wait for a stable release.

Where can I track this info ?