Openwrt busybox console fubar

Hi
I have installed Openwrt and it boots into busybox.

But I can't type anything into the console properly.

Eg. if I type ls.. it says /bin/ash: l: not found

It seems to only interpret part of the command line.

I can boot into failsafe fine but what /etc file do I need to fix ?

Thanks,
Andrew

Let's start with the basics:

  • What hardware are you using?
  • What image did you install (a link would be great)
  • How are you connecting to the console? ssh? or serial?
  • What (if anything) did you do after you flashed the router?
    • did you make any configuration changes? If so, what (in broad strokes, we can get into details later)?
    • did you install or upgrade any packages?

Finally, can you show us what is happening and the specific things you are trying to type into the console?

1 Like

Busybox isn’t really a linux terminal.
Does a uci command like

uci show network

work (work=show the network config file contents)?

I can't type anything in.. it doesn't interpret the commands correctly..

ls is a command in busybox..

what my terminal is doing on the console is butchering what is typed..

eg. if i type su.. it returns s.. then if i type su again.. it returns us.
it's weird.. login via ssh works fine.

So, not enough information to continue this discussion.

You might answer the questions @psherman asked you.

1 Like

This implies that you are having trouble with a serial connection. It would be helpful if you did directly answer the questions I asked, but if my assumption here is correct, the problem is likely related to the serial connection/parameters, and not specifically an OpenWrt issue. For example, it could be a physical issue (such as a poor connection or missing ground or the wrong voltage), an issue with the USB-serial adapter you are using (an unreliable chip or bad drivers), or the connection parameters (likely just baud rate, but could be other things).

Thanks for all the help

Bypassed the issue.

For the benefit of future readers who may experience similar things, it would be good if you could elaborate about what you did to solve/bypass the issue.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

2 Likes