OpenWrt 22.03.5 fifth service release


The OpenWrt community is proud to announce the newest stable release of the OpenWrt 22.03 stable version series. It fixes security issues, improves device support, and brings a few bug fixes.

Download firmware images using the OpenWrt Firmware Selector:

Main changes between OpenWrt 22.03.4 and OpenWrt 22.03.5:

Security fixes

  • CVE-2023-0464: openssl: Excessive Resource Usage Verifying X.509 Policy Constraints
  • CVE-2023-0465: openssl: Invalid certificate policies in leaf certificates are silently ignored

Device support

  • Archer AX23 / MR70X: Reduce SPI-frequency
  • Aruba AP-105: Create APBoot compatible image
  • Buffalo WSR-600DHP: Fix boot loop

Various fixes and improvements

  • Fix UBI (Unsorted Block Images) bug which prevented some devices from booting
  • Fix ccache compile with GCC 13

Core components update

  • Update uclient from 2021-05-14 to 2023-04-13

Full release notes and upgrade instructions are available at

In particular, make sure to read the regressions and known issues before upgrading:

For a detailed list of all changes since 22.03.4, refer to

To download the 22.03.5 images, navigate to:
Use OpenWrt Firmware Selector to download:

As always, a big thank you goes to all our active package maintainers, testers, documenters and supporters.

Have fun!

The OpenWrt Community

To stay informed of new OpenWrt releases and security advisories, there are new channels available:


Upgraded WAC104, no issues.

Attended sysupgrade isn't showing 22.03.5 ??


We need to wait for the asu server's builds to catch up...

1 Like

Thanks devs!

Quick note, Netgear R7800 and Buffalo WZR-HP-AG300H sysupgraded (keeping config) from 22.03.4 using local imagebuilder, no regressions. Units' configuration described here.

Upgraded to 22.03.5 on xiaomi 4a gig v1 and successful.

1 Like

ax53u does not work after the update from 22.03.4 to 22.03.5. I will figure out what's going on.

1 Like

2 x Linksys E8450 updated successful.

Thanks devs.


Have been using for a little over 3 days now (yes I was using before official announcement) without issues on EdgeRouterX, Archer C7 v5 and Archer A6 v3.

Thanks for all the effort :+1:

all updates went well on my side, TP-link M4R and Microtik 750GR
I noticed that the M4R v2 is still on v 22.03.3

but since this is a build for v1 anyway. I updated with the latest on for v1 and all works well.

Hello All,
22.03.5 and 22.03.4 and 22.03.3

    DIR-885L A1 no proper working 5GHz wifi out of the box.

Fix: replacement of out of the box firmware /lib/firmware/brcm/brcmfmac4366b-pcie.bin to older one. D-Link 885L/R A2 - OpenWrt 18.06.2 - upgrade - #8 by _Searcher

Standard firmware: connection to radio1 wlan1 5GHz is not stable, most of the clients not even connected really, while connection the route resets all interfaces (lost of all wlan0 and wlan1).
This should be debugged and also even with the older FW it is still not stable and good watchdog for restarting interfaces is required, which is able to catch when exactly interfaces stop working.
It could be as

Or even worse - portion of massive: hostapd: wlan0 OR WLAN1: STA XXXXXX IEEE 802.11: disassociated

some of clients could be "faking" connected, while really not able to do nothing.

The question is - is it only should be found proper revision of firmware for brcmfmac 4366b-pcie or something more?

I also play with iw dev wlan0/wlan1 set power_save off. Looks it makes situation a little bit stable.

This is really frustrating... Good - it is working, even if not so stable but with self written watchdog restarting interfaces, so at least makes Openwrt usable on DIR-885L.

The root cause probably is D-Link DIR885L-A1 brcm Beamforming

PS2: Have checked what is possible if you build Openwrt from scratch, it seems there is
option to use proprietary driver, at the moment not clear whether it will be stable, but may be another build will be also a solution.

  │ Package set compatible with hardware any Broadcom BCM47xx or BCM535x                                                                                                                                                           
  │ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom                                                                                                                                                                   │ wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.       

he doesn't work again with a personal package i 'm waiting

Unsupported version: 22.03.5

you also mentioned your frustration in 22.03.4 thread.

You are in the unlucky position that you own a device that has a Broadcom WiFi chip. Broadcom has no OpenWRT support since the begining of time, Broadcom the company completely refuses to support the OpenWRT project. Some Broadcom devices have a somewhat available Wifi quality, but seems not this one. Someone seem to have tried a quick fix and documented it, but as you already saw, the resulting 5ghz Wifi quality on that one device is not of practical use.

As long as there is no one investing dev time in that one Broadcom device WiFi, this situation will not change. But due to the seamingly low device fan base and Broadcoms complete refusal of support (code, doc…), such attempt have a low chance for a positive outcome. The device will likely be an solid working router but without usable 5Ghz WiFi.

You will maybe go through some more frustration/mourning, before eventually acceptance of the situation and then buying a better supported device for WiFi coverage (go for Mediatek or Qualcom). (Not meant in an arrogant way, but sadly that is how the situation of Broadcom is)

1 Like

MR8300 is now booting! Thanks to the devs for solving the UBI bug.
EDIT : sorry I meant now :innocent: (I had a hard day).


Not booting? Do you mean "now booting" or the issue wasn't solved?


GL.iNet GL-AR150 and GL.iNet GL-AR300M NAND still not in attended upgrade. And
Linksys WRT3200ACM still not available at all? Have to use the snapshot.

Netgear SRR60 and SRS60, slow, no real throughput, VPN connection from pcs and mobile devices fail, back to snapshots and vpns work and throughput increases back to normal speeds.

There's something weird happening with swconfig on ipq4019 and I can't recommend the release build when DSA on the current snapshot just works.

There will be no more 22.03.x releases for Linksys WRT.

There are a few threads in the forum with details and what the alternatives are.
E.g. quickbrowse the 22.03.4 and 22.03.3 release note threads, I think there were several related comments.

Updated 22.03.5 on tp link archer c60 v3 (us) and everything is working fine.