D-Link DIR885L-A1 brcm Beamforming

Hi, so I finally got OpenWrt 19.07.1 running on the DIR885L-A1 with 2,4GHz and 5GHz wireless available :slightly_smiling_face:. WiFi does not work with the Broadcom brcmfmac4366b-pcie.bin driver integrated with 19.07.1 (dating from 2018) but the one from 18.06.07 works [Firmware: BCM4366/3 wl0: Jan 8 2016 12:54:07 version 10.10.69.3309 (r610991)] which I copied to /lib/firmware/brcm overwriting the existing driver.
The 18.06.07 driver has some limitations though, i.e. severely limited list of working channels on 5GHz, so I thought trying out the latest trunk version of OpenWrt. The latest brcm driver looks almost working (all 5GHz channels available and can be activated, too!) but it does not really work :face_with_raised_eyebrow:.
The dealbreaker this time is standard activation of beamforming by the driver which prevents my devices from connecting properly. Activating beamforming in DD-WRT yields same symptoms: prevents my devices from connecting with DD-WRT properly) so I guess all issues would be solved with the brcm trunk driver having beamforming deactivated.

Is there a way to instruct the brcm driver to disable beamforming (at least active beamforming)? I do not see a beamforming option for /etc/config/wireless?

@ChriZ, welcome to the community!

No, especially more so with Broadcom.

You're very lucky that didn't cause a hard crash.

Of course not, especially more so with Broadcom.

The kernel log is clean and the driver works. I even got additional 5 GHz channels working... :star_struck: every channel switch requires a reboot. Simply applying the new config or restarting the radio does not work. Let's see how stable this is in the long term.

I know, but I like 128MB flash and DualCore A9 performance at current bargain-sale prices.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.