OpenWrt 22.03.2 second service release

WRT1900ACSv2 running OpenWrt 22.03.2 r19803. Upgraded from 22.03.0 with retained configuration. 5Ghz set to channel 36. WPA2. I continue to have the following:

  • irqbalance enabled (from '0' to '1' in '/etc/config/irqbalance')
  • SQM QoS enabled
  • tx_amsdu disabled. Luci > startup > local startup (nano /etc/rc.local) the following commands:
echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu

4d uptime.

No issues noted. Excellent performance.

1 Like

I upgraded my BTHH5A from 21.02.1 to 22.03.2 via attended sysupgrade. It was a smooth experience. Thank you developer team!

22.03 uses DSA as opposed to 21.02 using swconfig. So I had to amend and declutter the network config. Had bootloop and long booting issues. But eventually settled out. Fortunately WiFi remained unaffected throughout the transition. Quite impressive.

A big thank you.


Edit : WiFi status

@jow please can we get Modem Manager updated to 1.18.8 and most importantly with this patch:

pulled in to 22.03? It is needed to properly support devices incorporating wwan, since otherwise ISP disconnects result in loss of internet connectivity pending user intervention.

Update November 3, 2022: actually we need to wait for further development on nefifd 'modemmanager' see here or 'qmi' see here protocols in 'master' to properly handle such disconnections.

Email just in from Paul Spooren: [openwrt/openwrt] Release v22.03.2 - 22.03.2

This thread was started twenty days ago, the release notes are dated 17 October 2022, but

aparcar released this 2 days ago

My devices confirm that 22.03.2 has been running for fifteen days and the release was announced on the feed 22 days ago. Hardly a problem, but odd to have such a gap between announcements of the release.

PS. The thread starter still includes

It was simply forgotten to also draft a GitHub release, since it is not the primary source distribution platform.

1 Like

can someone please help resolve this issue?

1 Like

Please fix the problem of not booting this version for BT Home Hub 5 Type A modem.

As far as I know, the cause of the problem has not been found yet, which would be a precondition for a fix.
Apparently the problem was introduced with the switch from linux kernel 5.4 to 5.10:

Narrowing this down further might require bisection on the linux kernel instead of OpenWrt, and porting OpenWrt's patches to each intermediate kernel version.

1 Like

Anyone having the 'opkg failed' problem with the latest firmware?

It's been released 2 months.

Perhaps you should make a thread for help with the issue you're having.

Is this also recommended for the WRT3200ACM (irqbalance and tx_amsdu disabled)?

No, disabling amsdu on WRT3200ACM / WRT32X does nothing the bug only affects the 88W8864 chip in WRT1200 and WRT1900.

Irqbalance is up to you, it barely does anything since there is no multicore-DSA support but feel free to enable it. The only recommendation I have is to enable packet steeering.

In LuCI: Network > Interfaces > Global Network Options > packet steering.


I have seen several recommendations in recent months for enabling packet steering on WRT3200 (or is it more specifically mvebu in general?), but I have not yet tried enabling it yet.

My WRT3200ACM has been outperforming all of my expectations on 22.03.2 so much so that I am cautious lately about changing any settings. I am happier now with my WRT3200 than ever before.

Does enabling packet steering benefit wired connections specifically or is there also some benefit for wireless connections as well?

1 Like

In general I've just always enabled packet steering based on the discusison from the upstream Linux (Google wrote it I think) commit here: []

Mvebu has performance issues with 5.10 kernel where the switch is sorta acting like a hub, it badly needs 5.15 for the apparent bug fix. Nevertheless it's still fast and stable on 22.03.

Other considerations: if you have gigabit internet for our target also enable Software Flow Offloading under firewall. However, if you want to run SQM it'll handle 500Mbit or so no problem, I use SQM Cake on my 300Mbit cable modem for +0ms ul/dl latency with plenty of CPU left over for Adblock, Samba, etc. If you run SQM, don't enable SW flow offloading, they are incompatible features. For gigabit + SQM you would need something newer like a NanoPi R4S.

This is all discussed on the wikis too.


Just updated my Archer C7 V2.
It works fine, but still the WAN LED is missing.

Flashed on Netgaer EX3700 (ramips/mt7620).
I had to go back, because some clients have had WLAN connection problems (very slow connection, and timeouts) after upgrade.

The regression fix to firewall4 now works great for the loadfile command. My device boots correctly.

opkg update
opkg upgrade firewall4

Took me a while to upgrade, but on my Fritzbox 4040 I jumped from 22.03.0 to .2 using AUC (been doing that since 21.07.2) then I ran the commands above to update firewall4:

 * check_data_file_clashes: Package firewall4 wants to install file /etc/hotplug.d/iface/20-firewall
        But that file is already provided by package  * firewall
 * check_data_file_clashes: Package firewall4 wants to install file /etc/init.d/firewall
        But that file is already provided by package  * firewall
 * check_data_file_clashes: Package firewall4 wants to install file /sbin/fw3
        But that file is already provided by package  * firewall

I thought firewall4 was now the default...was it because of AUC?
How do I make the switch to fw4? Should I roll a new image? In that case, which packages should I omit, in addition to "firewall" itself? I have the list of firewall4 dependencies, that shouldn't be a problem.

Hey, personally have no experience with your device although I was interested in this issue you are experiencing and did a little digging.

You probably have more experience with this so please just take this with a grain of salt but hopefully it will provide you some help.

Maybe using the --force-overwrite flag with opkg-install will help.

Flashing a pre-built image with the right packages would probably be easier.

Here is the link for the your devices latest 22.03.2 image with the correct packages.

There is also a dedicated post

Hope this information is helpful!

Thanks, forcing installation isn't really a solution, rolling a new image with the right packages could be... I guess I'll have to work out a diff and get a custom image via AUC. The dedicated post is very old, I've seen it already.

bug: there seems to be an issue of the DHCP service crashing occasionally.
Milage may vary, how often you will experience the issue. In case you notice devices no longer reconnecting:

sec issue: Not may people use ksmbd, but if you use it, ksmbd has a security issue, which is fixed in newer kernel versions: