Unable to install in Checkpoint L50

Greetings to all.

I have been offered this ex corporate L50, and i was planning to use it with openwrt although its a only wired, device. Planning on adding either an AP or an usb wifi card, later.

I have been reading all the posts, searching for a way to install, first, u-boot, then openwrt.

I downloaded the files in openwrt website, tried by usb fat32, by tftp.
The result is always the same, i manage to send to the device, u-boot, but after 99% it gets stuck, freezed, not allowing any other action, except turn off the power to repeat the proccess.

I have followed the procedure in openwrt website, and those that can be found in some posts here in the forum.

I tried different serial cables, usb sticks, even different positions in my chair, and i must be missing some detail.

If i stop the boot with control + c, i am unable to load either the firmware or the u-boot, always giving an error of being unable to load from usb. Tftp, likewise.

To those that might have more knowledge of this platform (Kirkwood), im open to suggestions.

Thanks in advance.

I've converted a few L50's to OpenWrt in the past but it is a while ago. The only thing I can think of is to try the files from the 21.02 release and see if you have more luck with those?

just guessing:
there was a recent issue mentioned, which seems to affect some builds:

since you seem to be able to run a full recover, you could try, if the issue appears with 22.03.[0/1] as well?

Hi konus, thanks for the reply and help.
I tried all the openwrt releases with support for this platform.
Same result in all of them, got stuck/froze after 99%.

It must be something specific to my hardware.

Sure, i will try new releases.
Since i want openwrt on the device, it cant get any worst of not having it.

Tried already 22.03 (0/1), no joy, same issue.

I just hope there is no memory corruption, or something alike.
Thanks Pico.

With 22.03

Same result.

It looks like transferring kwboot and starting the new uboot from RAM has worked based on your image. When you are running uboot from RAM can you ping your tftp server?

I would normally use my main openwrt router as a tftp server. Once you are running uboot from RAM it may be worth to issue the command 'printenv' to show your current uboot environment settings.

If you plan to use tftp to transfer the files the serverip, gatewayip and ipaddress environment need to be set correctly. This can be done using the 'setenv' command. You should not do a 'saveenv' since you want to adjust these settings only temporarily and go back to their defaults on the next reboot. After these environment settings have been adjusted you should be able to ping your gateway and tftp server and check for a response. If that works you can continue with the rest of the install procedure.

If you still get stuck it may be worth posting your whole terminal session? That way anybody on here can check it to see if they can spot any problems / issues.

This is not the new kwboot running from RAM but the original uboot on the device. For the install to work you need to be running uboot from RAM using kwboot as shown in the image of the original post.

Yes, i know.
I just showed this one because i am stuck in the procedure, if i interrupt boot, i cannot load the new kwboot from usb.

If i let boot continue, image fails at 99%.

Im starting to wonder if i have the right new kwboot on the folder from where i run the command in the linux machine.

(The error if i try via usb pen)

Sorry I was writing my reply at the same time as you posted the 2nd image.

The 1st image shows a successful start of kwboot transferring the file and starting the new uboot from RAM. It looks as if the process has been stopped somehow. Try to do the same thing again but let it continue. You should wait until you get a countdown timer which allows you to interupt the process. Press spacebar when you see the countdown timer to interrupt the process and continue with the installation.

If you see the old uboot 1.1.4 2010 start you know the kwboot has failed and you need to try again unfortunately. kwboot can be a bit hit and miss so may take a few tries to get it to work successfully.

I dont interrupt the proccess, in any way.
I always let it go until 99%, then it freezes.

I have tried with serial to eth cable, and usb to eth cable.

It always gets 'stuck' at the dram cursor, not doing anything more.

OK I don't know what to do then except to keep trying. I've done a few from my laptop running Kubuntu and it often takes a few goes but it always succeeded eventually. Good luck.

I will keep trying, and updating the situation.

I've got two more suggestions to try but I don't know if it will make a difference:

kwboot with only the serial cable attached. Only plug in the USB or ethernet once uboot has finished loading successfully from RAM. I don't think having USB or a cable plugged in should make a difference but you may as well give it a try.

Factory reset the device and set it up as a new user on the stock firmware. Run kwboot over serial while you reboot the device from a ssh session / the web interface. Sometimes a 'soft' reboot works better than pulling the plug.

That is all I can think off. I hope you get it working since it is quite a nice wired router with a large number of network ports.

One last option to try is to burn the new uboot from the working stock uboot. It is not something I've tried but the following post describes how someone has done it before. This is slightly more risky since a mistake can leave you with a bricked device.

Hi Konus, thanks again, for your help.

Well, i kept trying to flash the device, and i seem to managed to have it bricked.

In the present situation, i no longer see it booting, u-boot, the original one, doesnt give me the control + c option, goes straight to dram stuck mode.

The leds, are in shown in the photo.

From prompt it does allow to transfer (?) something, but it gets stuck again, if i give the command (-t) to go for terminal.

no stuck: kwboot -B 115200 /dev/ttyUSB0 -b u-boot.kwb -p
stuck : kwboot -B 115200 /dev/ttyUSB0 -b u-boot.kwb -p -t

The way i bricked it, was to change a u-boot.bin to u-boot.ubt, and flashed it like that.

It was accepted, but led to the present status.

It is a great device and platform, specially for low speed connections, and i tried to flash it with openwrt, because the licenses of the firewall were expired, and it would be a waste to send it to the garbage bin.


It is annoying that it doesn't work on your device since in theory kwboot would always allow you to recover from a brick. That is one of the reasons why kirkwood platform has been quite popular for hacking / experimenting. The fact that it gets stuck at the DRAM stage could mean that there possibly is an issue with the hardware?

Anyway I have one more idea for you to try. Inside the enclosure there is a 4 pin header in the corner close to the LEDs which I assume is serial / UART. If you have a 2nd serial cable or a raspberry pi you could run a 2nd session on there. Make sure you leave the 3.3V disconnected and only connect the TX RX and ground pins. With 2 serial connections you can send the kwboot without the -t option in one session and do the rest of the commands via the 2nd session.

As a matter of fact, i was already thinking in buying a usb/UART cable from amazon, for that purpose.
The device booted normally, loaded the os, and gave good perfomance in its previous firewall function.
I wonder if ram is damaged.

I will try, but i get no access to any prompt to give any command.
Only with the previous linux system i could get access to prompt, after login.


I finally received the usb-uart adapter, but the exact same error happened.
Surely it has to do with hardware failure at some point.
I ended up buying an x86 wyse thinclient, and build from there.

It is a shame, as the L50 was a good platform.

Thanks for all the help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.