OpenWrt 22.03.2 second service release

Updated the following devices from 21.02.3 -> 22.03.2, retaining the current configuration settings:
Netgear R7800
Buffalo WZR-HP-AG300H
Both devices work fine after the upgrade. Thank you, devs!

1 Like

I see that the update for firewall4 is showing up in the luci update interface... and a set of ucode updates as well. I looked at the firewall4 dependencies, it does include the ucode update items, but seems to think they are already installed, and I assume won't update them.

So, should the ucode related items be updated as well?

Those updates are not required.

21.02.? -> 22.03.2 (d-Link dir-1960)
when iOS devices search for Airplay speakers (probably via bonjour?) in the local lan, 22.03 reacts a lot snappier within 1 second.
21.02 often had delays of 20-30 seconds, before a speaker would eventually show up in the list of an iOS device.

Same here, just tried .2 hoping to see this fixed, but no, it fails.

x86 router eth0 is 'wan' using DHCP from a cable modem
lan is 'br-lan' covering eth1 and eth2

The Windows app UPnP Wizard is able to add/remove entries and correctly reports the IP of the router and the public wan IP, but the XBox Console Companion App reports Moderate NAT and the UPnP entry never shows up in the Active UPnP Redirects list.

Update (5 minutes after posting): After scrolling up a couple of messages, I saw the note about updating the FW4, so I did and re-ran my tests, and progress, but no solution.
The UPnP redirect is now successfully added and shows up in the redirects list, however, the XBox Console Companion still reports moderate NAT. So the 'forwarding' is still broken.

Solved: I had done attended upgrade. The uas module was part of the image and was unable to read the quirk from etc/modules.d/usb-storage.

So I did a custom image without usb-storage modules and then installed all usb storage modules using opkg. Now it reads the quirk file and works as expected. Is this by design?

BTW The speeds are better than USB 2 but slower than 21.02 on USB3. Exact same hardware.

 Timing cached reads:   418 MB in  2.00 seconds = 208.81 MB/sec
 Timing buffered disk reads: 168 MB in  3.01 seconds =  55.78 MB/sec

Asus RT-AC56U (BCM4708)

USB 3 port does not work with my USB 3.1 HDD enclosure. I applied the same quirk that I used before on version 21.02. I did use my device ID.

What is the difference between /etc/modules.d/usb-storage and /etc/modules-boot.d/usb-storage?

Bus 001 Device 002: ID 0080:0578 JMicron External USB 3.0

It was working fine with version 21.02. Now I have connected it to USB 2 interface and it does work, but there is a marked difference between USB 3.0 port and USB 2.0 port for read speeds.

USB 3 on 21.02

# hdparm -Tt /dev/sda3

 Timing cached reads:   486 MB in  2.00 seconds = 242.61 MB/sec
 Timing buffered disk reads: 236 MB in  3.02 seconds =  78.22 MB/sec

USB 2. on 22.03.2

# hdparm -Tt /dev/sda3

 Timing cached reads:   500 MB in  2.01 seconds = 249.31 MB/sec
 Timing buffered disk reads:  92 MB in  3.02 seconds =  30.49 MB/sec

22.03.2 working well on:

  • NanoPi R2S (gateway, adblock, SQM)
  • Netgear GS308T (switch)
  • Linksys EA8500 (dumb AP and switch)
  • Askey RT4230W (dumb AP and switch)

Handling 5 vlans, several 2.4 and 5 GHz SSID's

1 Like

22.03.2 upgrade went well on a Raspberry Pi 4B. 64-bit, squashfs

WRT1900ACSv2 running OpenWrt 22.03.2 r19803. Upgraded from 22.03.0 with retained configuration. 5Ghz set to channel 36. WPA2. I continue to have the following:

  • irqbalance enabled (from '0' to '1' in '/etc/config/irqbalance')
  • SQM QoS enabled
  • tx_amsdu disabled. Luci > startup > local startup (nano /etc/rc.local) the following commands:
echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu

4d uptime.

No issues noted. Excellent performance.

1 Like

I upgraded my BTHH5A from 21.02.1 to 22.03.2 via attended sysupgrade. It was a smooth experience. Thank you developer team!

22.03 uses DSA as opposed to 21.02 using swconfig. So I had to amend and declutter the network config. Had bootloop and long booting issues. But eventually settled out. Fortunately WiFi remained unaffected throughout the transition. Quite impressive.

A big thank you.


Edit : WiFi status

@jow please can we get Modem Manager updated to 1.18.8 and most importantly with this patch:

pulled in to 22.03? It is needed to properly support devices incorporating wwan, since otherwise ISP disconnects result in loss of internet connectivity pending user intervention.

Update November 3, 2022: actually we need to wait for further development on nefifd 'modemmanager' see here or 'qmi' see here protocols in 'master' to properly handle such disconnections.

Email just in from Paul Spooren: [openwrt/openwrt] Release v22.03.2 - 22.03.2

This thread was started twenty days ago, the release notes are dated 17 October 2022, but

aparcar released this 2 days ago

My devices confirm that 22.03.2 has been running for fifteen days and the release was announced on the feed 22 days ago. Hardly a problem, but odd to have such a gap between announcements of the release.

PS. The thread starter still includes

It was simply forgotten to also draft a GitHub release, since it is not the primary source distribution platform.

1 Like

can someone please help resolve this issue?

1 Like

Please fix the problem of not booting this version for BT Home Hub 5 Type A modem.

As far as I know, the cause of the problem has not been found yet, which would be a precondition for a fix.
Apparently the problem was introduced with the switch from linux kernel 5.4 to 5.10:

Narrowing this down further might require bisection on the linux kernel instead of OpenWrt, and porting OpenWrt's patches to each intermediate kernel version.

1 Like

Anyone having the 'opkg failed' problem with the latest firmware?

It's been released 2 months.

Perhaps you should make a thread for help with the issue you're having.

Is this also recommended for the WRT3200ACM (irqbalance and tx_amsdu disabled)?

No, disabling amsdu on WRT3200ACM / WRT32X does nothing the bug only affects the 88W8864 chip in WRT1200 and WRT1900.

Irqbalance is up to you, it barely does anything since there is no multicore-DSA support but feel free to enable it. The only recommendation I have is to enable packet steeering.

In LuCI: Network > Interfaces > Global Network Options > packet steering.