OpenWrt 21.02.2 Issues - Pre-Release Announcement

@moderators can decide if the topic is appropriate at this time...

Several have already upgraded to 21.02.2 prior to the "official" release announcement.

I'm on day 3 running on an Archer C7 V2, and having no issues so far.

However, some users are.

The 21.02.1 release announcement thread is starting to get posts on 21.02.2, so it's probably easier to consolidate those into one thread.


Infact I first reported the issues regarding TP-Link Archer A6 v3 and second service release 21.02.2, with logs and details, which are linked below.

This weekend I downloaded the 21.02.2 version that the Firmware Selector presented for my Linksys WRT3200ACM. I was (am) still on 19.07.8 due to the earlier problems with this device in 21.02.

Forced factory upgrade without keeping the settings as recommended worked fine. I was able to set a password after the upgrade. However, when I tried to update the Network/Interfaces/LAN settings it refused to Save the adjusted settings, and gave my wired laptop that did the update a 169.254.x.y address.

I rolled back to 19.07.8 for the time being, will try again after the TechData page for my device shows a valid 21.02.2 version as well.

1 Like

Known as an "automatic private address", and usually means the network can't be seen for some reason.

1 Like

Thanks! Like I say, I am overestimating my tech skills... When I force my laptop to a fixed IP-address in the (OpenWRT default) 192.168.1.x range (x > 1 of course) it does see the router, so that probably means that DHCP did not work.

1 Like

You know a problem when you see one.


Just compiled 21.02.2 for wrt1900acs V2, working like a charm, but as always, wpa3 doesnt work.
Apart that, seems working as intended, without the

Patched firmware-88w8864 mwlwifi specific high latencies by disabling tx_amsdu. Essential. Add in luci > startup > local startup (nano /etc/rc.local) the following commands:
# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
#fix wifi bug
echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu
echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu
exit 0

Gotta see if wifi 5 works reliably, since this should have wifi fix.

1 Like

If you need to install packages you should wait as they are still being built.

Updating my R7800 went like a charm. I only performed a sysupgrade (no clean install) and preserved all the settings. I will perform a full reset later this day.

Only issue is that Wifi speedtest (from Ookla) shows that Wifi is a bit slow, definitely slower than earlier builds. Internet via ethernet is fast, really fast. Software flow offloading is obviously off. IPv4 and IPv6 are enabled.

When connecting to Wifi, for the first time, access to internet takes around 20 seconds. I have no idea why.

Might have something to do with this:
Tue Feb 22 08:51:11 2022 daemon.warn dnsmasq-dhcp[10833]: not giving name GSKSGFB.lan to the DHCP lease of because the name exists in /tmp/hosts/dhcp.cfg01411c with address
Tue Feb 22 08:54:14 2022 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 18:47:d:10::*

Starting with Open 21 they are utilizing DSA to manage switches instead of the older swconfig (you will notice on the router that Network->Switch is missing in OpenWRT 21 where its there in 19). Its difficult to migrate the older swconfig settings to the newer configs automatically which means you will have to adjust the Network/Interfaces/Lan settings using DSA yourself for now. I have WRT1900ACS v2 which also contains a marvell soc. Normally if you have a standard network, the default WRT settings will be fine. If you have a bit more complicated network with multiple VLANs, understanding DSA might have a slight learning curve. But once I got it down, it was ok after I migrated from Openwrt 19 to 21.

Thanks @iointerrupt, I realised that and I did read the DSA documentation as well as a number of forum posts on the topic. I did Force Upgrade without keeping the settings, and after that I was manually adjusting the settings for my home network. As I have a number of (home automation) devices with fixed IP addresses I would want to change the default OpenWRT configuration.

And in some cases rebuilt - so if you have upgraded already you may want to check once the announcement comes out to see whether newer packages exist and you want to upgrade again.


What are the best steps to upgrade in your opinion?

  1. reset old device (to a clean openwrt version)
  2. upgrade via luci to new version (using sysupgrade without keeping settings, actually doing a soft-reset)
  3. reset device again with latest openwrt
  4. configure device with latest version

Something like above?

Given that upgrading re-flashes the router, it's not like it leaves anything extraneous lying around except old config - the only bit of the filesystem that survives. So I expect you'd just do 2 (via luci or the cli) unless you had a lot of extra config and wanted to clean things up by configuring everything else from scratch (in which case just 3 and 4 should suffice).

1 Like

i see, thought it was finalized, guess i gotta rebuild once it gets final release

Until it's officially announced there's the possibility of packages/builds being redone.

I have succesfuly upgraded 2 routers from 21.02.1 to 21.02.2 : GL-MV1000 and RB750Gr3.
To be fair, only the Mikrotik RB750Gr3 had a sysupgrade available.

So I made a backup of both, flashed and manually installed the needed packages (banIP, adblock, wireguard, vpn bypass, vnstat2) then restored the backup config. Is that considered as a new installation ?

Then I tried SQM Cake that I did not know before and it is excellent. I did not run these routers for a long time because I realized that FreshTomato has QoS Cake too and wanted to try it in this old RT-AC68U.

Under 21.02.1, the RB750Gr3 had a bug that made traffic counting on the WAN interface almost as double as what it really was (visible in real time display and vnstat graphs). It seemed fixed for the first few hours then started to bug again.

I've been running the Meraki MR33 update to 21.02.2 (successful upgrade from 21.02.01) for some days now and it has been very reliable across multiple modes and frequencies across its 3 antennae. No issues whatsoever. Looks solid!

I had 21.02.1 running on my WRT3200ACM for some time now with no issues. Should I expect problems when upgrading to21.02.2?

Can anyone who had WDS Bridging issues in 21.02.0 and 21.02.1 tell if it's been fixed in 21.02.02?