OpenWrt 21.02.1 First service release

I think it was just a case of not rebooting after doing the installation of whatever packages you use. At least here, those installations take some RAM until the system is rebooted, which if you hadn't could have easily made you think that this build took more RAM when comparing with figures from a rebooted 21.02.0.

On a related note, it's been long enough now where I can make a call on the memory differential between 21.02 and 19.07 with the same configuration. With the earlier build I'd average about 75670 KB free, whereas now it's about 5,000 KB less. So, not bad.

Rebooting wasn't a factor.

As I mentioned, I rolled back to 20.02.0, and it uses about the same amount of memory...after rebooting both.

I think I had written down the 19.07.8 usage, and used that number, but I'm not planning to roll back to find out.

So far, 20.02.1 is working well.

Thanks ... will stay for now with 19.07.8

Yes, same here with WRT3200ACM. Did 19.* to 21.* and had the same concern. Worked fine for me after upgrade, but 5Ghz WiFi has drop-out issues with certain mobile devices (Apple). There's another thread on this issue in the forums.
You must tell it NOT to keep settings, and you must also check the box for the force upgrade so it changes the partition size. Unfortunately I do not believe there is a way to preserve/restore settings with this upgrade because it needs to re-partition the flash rom.
You should also verify you have the correct image file when you do the upgrade so you don't accidentally cause yourself problems by using the wrong image file for your router.

Not to mention the fact that wrt3200acm goes from swconfig to DSA when installing 21.02 so there are simply no settings from any previous system config to restore settings from.

Only the venom and mamba had a size change forced.

Is there any improvement in wifi comparing to 21.02.0? It was much worse than stock or Padavan. I would like very much to return to openwrt...

Disappointing. I had WDS problems, too. I went all the way back to 19.07.8 to avoid them. I guess I'll wait for 21.02.2 before upgrading.

First of all - thanks for all the great work on this release!
We use OpenWRT for more than 15 years now.

There's one thing I I would like to see: some more transparency on the question whether the obvious
software flow offloading issue will be worked on or not in the near future?

We're currently running on 1/3 of possible WAN speed, thus we would like to make a decision soon if we should replace our Archer C2600 by new device only because of this.

To me this looks like a regression introduced by some change in the past - so wouldn't it be possible to identify this regression and revert / change it into a working solution again?

If there's absolutely no light at the end of the tunnel ... what would be a possible replacement for a C2600 to run as Wifi router behind a Gbit WAN connection?
Some device that doesn't suffer from the flow offloading issue, but can deliver higher routing speed without?


I don't know much about the first part of your question, but after reading this forum thread i had a better understanding of everything that is involved from a performance perspective. And i saw some recommendations in the replies that could be of interest.

If you look further up this thread, i had the mamba version Linksys WRT1900AC v1, and i was advised to force upgrade using the factory.img. It worked for me. I don't know if the sysupgrade image would of also worked if i forced it, but I just made good doucmentation and screen caps, then reconfigured everything. The only thing i missed was that i must have had software unloading enabled, and it is disabled by default after the update do to some issues previously mentioned. Hope this helps. See anomeome comment about the only 2 versions that had a partition change. But there is still the DSA change to contend with.

I consistently had problems with my c2600, see post below. I had been running OpenWRT for years and finally just gave up and reverted to the stock, tp-link firmware and haven't had issues. How is this latest service release for you? Any crashes in the logs? Intermittent wifi problems?

None whatsoever, however its early days. My uptime is only 5days 13hrs with 21.02.1.

I've detailed my finding here: OpenWrt 21.02.1 First service release - #24 by otnert

Also adding to that post: I've moved from Samba4 to ksmbd to resolve my free space issue! Now have 12.1MB free space to install extra packages. Had some teething issues with ksmbd, but was Windows related.

Since I only use adguardhome, I can't feel the difference between the two versions.
and the speed is too slow in LAN when i transfer files from mac to iphone.

Does anyone understand the significance of things being grayed out on the new Devices tab? For example, the WAN, which in Interfaces is eth0.2 and most certainly active. Here, eth0.2 is a VLAN (perhaps that's a C7v2 thing), for some reason, and pointing to eth0, but they're both grayed out, which is misleading and possibly a mistake. Yes, you can click Configure, and everything works.


Cudy WR2100 and Archer C7 v2 working well! Thanks!

Speaking of Archer C7 v2, on that router I'm noticing dramatically less free memory after a while than seen consistently on 19.07 and earlier.

It used to be that it had about 70000 free. Now, allowing for the same time to pass (a matter of hours), it drops into the 35000-40000 area. And that is with the same configuration as before! I wonder if what I asked in the preceding post is related.

This memory usage comes as a surprise, since I know someone with another router (not a C7v2 but a comparable one) who only had a 5000 drop relative to before. I expected to see about the same here.

I think it's the newer kernel and features utilized. I noticed consistent freemem drops across hardware platforms when jumping from 18 -> 19 -> 21.

1 Like

I don't recall noticing this from 18 to 19, but when comparing 19 to 21, how can the Archer be so different than the comparable one I mentioned, for example? Shouldn't they both have dropped similarly, relative to what they had each been, instead of what happened? The fact that one was extremely different makes me think something went wrong on the upgrade, despite it working, particularly in light of the weirdness I show in the screenshot.

It would be interesting to know if anyone else with a C7v2 has a Devices tab looking like that.

My C7V2: only Accesspoint, no luci (webservice) running
# uptime
18:20:09 up 9 days, 23:27, load average: 0.00, 0.00, 0.0

# free
total used free shared buff/cache available
Mem: 123400 51248 55136 240 17016 38952