OpenWrt 21.02.0 first release candidate

If you're using any version of WPA-3 that might be the problem. Could be that your phone's software is incompatible/not updated for the standard. Try with WPA2.

1 Like

cheers. got it working. had to use wpa/wpa2. seems like my phone needs wpa

I recall, when I tried the snapshots, that the layout of the flash memory in Zyxel NBG6616 changes, when upgrading to 21.02. That forced me to do some specific changes:

fw_setenv boot_openwrt bootm 0x9F120000
fw_setenv bootcmd run boot_openwrt

before installing 21.02. In the meantime, the old version of openwrt would not boot.
Does anyone know, if it is still nescessary?
Read more about the problem:

LuCI has come a long way with 21.02 and is mostly javascript based now (if I understand it right), has near instant page loading, and most settings have explanations of what they are. My only issue would be how bright the Bootstrap theme is, there could be a dark mode with a dark grey/blue background.

Nevertheless, if you have a problem with the look just install all the theme packages. Try luci-theme-material. Install the package then change to it under System > Language and Style. It's a really nice looking alternative imo.


Thanks for the new release(-candidate) with LXC support. Would it be possible to add IKCONFIG_PROC kernel option please to satisfy lxc-checkconfig? It is not essential to use LXC per se but probably a simple but nice/useful addition to kernel options?

Side note, may others have the same problem: default lxc-common.conf would try to utilize cgroup structure but only cgroup2 exists so need to comment out lxc.cgroup.* lines to lxc-start a container.

Thanks again for the release!

Iirc it's available as installable kmod-ikconfig

Thanks for the good work!
Is it planned to have a working sysupgrade (keeping most configuration) for the final 21.02 release even with DSA targets?
I think it's a pain to have to start over again just because of the switch configuration, given that most people use the default switch settings anyways.
Wouldn't it be possible to keep the configuration except the switch settings?

1 Like

No. User configs might be so complex, and there is so much variation between specific routers, that creating a useful migration would be too complex to be worthwhile

For many routers you only need to remove the network config file (switch) and the system config file (LEDs).
Read e.g.

1 Like

Thanks, I'll do the /etc/config/network and /etc/config/system trick. But would have been even better if it was automated.

There have been a number of people that took a look at writing something to automate the process but threw their respective hands in the air after seeing the complexities involved. When you compound it is a tough nut to crack with throw away after use the reward / effort comes up rather short.


Thank you @phinn , you are the only one who has given importance to my opinion about Luci's interface. There is some reluctance to talk about this topic in the forum, and I don't know why. I understand your position and I have done it on occasion just to change the color, it is even important that the source code of the pages has been changed for the better, ... but the interface remains the same. It would only be necessary to add a button "Quick Setup" on the first page, which will take us to a page where we can quickly configure the device as a router, bridge or repeater, without having to go to another page. For fine settings it can continue as is.



Just gave the RC1 a try on my ipq40xx based Fritzbox-4040.
Some strange things stay for ever :woozy_face:
This is the (most annoying) one of them.

IPQ40xx Switch Config “Strangeness”

I hope someone can come up with a patch for this, like it was available for 19.07.x (x != 4)


yes, indeed it is there. thank you very much for the hint.

I may be wrong, but what seems to be a simple one button addition in reality means several different setups for several different targets, each one with it's particular implementations. Again, I may be wrong, but doesn't seem like an easy task to develop / test/ maintain the logic behind each implementation.

Absolutely agree.
I only ask that if a developer has the necessary knowledge and time and ... wants to do it, it would be good for this community. Maybe the people of Gargoyle who are in this forum want to help.

Works fine after installing qemu-img.

LUCI is designed to be highly configurable and expose most configuration options to the user.
Gargoyle is designed the opposite, exposing most commonly used settings and sometimes macroing those into a single configuration toggle.
They're on completely opposite sides of the spectrum, and both approaches upset people depending on what they're after.

I'm pretty sure there's a setup wizard package that someone wrote. The name escapes me.
@cezary maintains a quick configuration tool for his releases. I don't know if that would be appropriate for wider use or not.
Certainly something that would require a new topic for discussion if you wanted to continue.

1 Like

Thanks @lantis1008. I do not think they are opposite, after all they are web pages with a certain interface, I know that there is a lot of work under that programming, but at some point developers have to consider this change if we want to reach more people. Also I'm not talking about changing everything, no, I'm talking about adding a few pages to the ones that already exist. Something like "Connection > Basic" in Gargoyle, only that, the rest as is.

How's the wifi performance on your device? 2.4GHz and 5GHz. My experience with it on 19.07 is pretty bad on my xiaomi mi r3g. On 2.4GHz I'm seeing ~30-40ms more than wired or 5GHz. I've tried to play around with the available channels but it got me nowhere. My hopes are with 21.02

all good here on my tp-link archer mr200 4G (lte) link.
built my sysupgrade via 21.02-rc1 imagebuilder (just wanted to keep my stubby setup) and upgraded by keeping old 19.07.6 config and after a few minutes (during which I admit I had some doubts and was ready for tftp recovery :slight_smile: ) my laptop successfully reconnected to my previous SSID