OpenWrt 19.07.0 first release candidate

Hmmm... Did that, though with difficulty. Still no wpa3.

Maybe we can jointly do a separate thread on configuring this version to use WPA3? Interested?

(You likely need the encryption suite too.)


Had serious Wifi issues with my TP-Link Archer C2600. Did a Sysupgrade without keeping config. Both Radios started configured for 5 GHz. Could set the second one back to 2,4 GHz via /etc/config/network. However, I had serious stability issues with the 5 GHz radio (wlan0), dropping connections when more than 2-3m away from the AP (nothing special in the log). The 2,4 GHz radio (wlan1) worked stable. Reverted back to 18.06.5 without any issues so far.

I can confirm 19.07-rc0 works on:

  • Cisco/Linksys EA3500, 5Ghz seems more stable now, plus more channels available!
  • Cisco/Linksys WRT610 v2 (aka E3000)

I did notice changing to a different IP address is somewhat odd.

  • add the new, save and apply, login using the new IP address, remove old.
  • replace old with new, quickly login using the new IP and have it confirmed.

Otherwise rollback kicks, which it self is a nice feature!

Congrats with the new release


Run it on target: Netgear X4S R7800
Now for 2 day only one problem found.

I can not use passwd with sha256 (set this to default) or sha512 only md5 and des works, try both implementation from busybox and original.
i wondering if i miss something but this works on 18.06.4

Can anyone confirm this problem?

root@openwrt:~# passwd -a sha256
Changing password for root
New password:
Retype password:
passwd: password encryption failed: Function not implemented
root@openwrt:~# passwd -a md5
Changing password for root
New password:
Retype password:
passwd: password for root changed by root

BUGs found until now:

Wifi range lower than tplink's official firmware.
miniupnp dont support PS4

How to instal 19.07.0 on r7000 someone pls help with install

Not a change in behavior

1 Like

Thank you, jow, for releasing! Booted on Linksys EA4500, Western Digital MyNet N750, Netgear R6100, and Netgear WNDR3800CH, two of each. Use as firewalls, with separate APs. All had 19.07 snapshot(circa 11/02/19), or librecmc 1.51 RC2 loaded previous to upgrade. No flashing issues. Installed at customer's on MyNet N750 with luci-ssl, luci-app-sqm(per-host isolation) all ports shut off per , not pingable from WAN. All great so far!

On both my routers, netgear R6100 and R6220 5ghz wifi isnt working with 19.07-RC1. Btw i must note 18.06.05 is much smoother than 18.06.04.

Is 5ghz working on R6100?

My R6100 scans and transmits on 5ghz. Just checked for you. Don't know about range or if all settings work. not tested with clients

it is so strange because mine works very well on 18.06.05 and doesnt work at all on 19.07 I will investigate, thanks btw

To be sure: did you start from scratch to exclude any compatibility issues coming from 18.06?

Upgraded WDR3600 from 18.06 and running very smoothly.
Thanks to all involved in this new release.
Will test on Netgear R8000 later.

I tried to install the new RC1 on a tp link C20v4 running a month-old snapshot version (which uses the new device ID string). It complained

Device tplink,archer-c20-v4 not supported by this image
Supported devices: tplink,c20-v4

I forced the upgrade to proceed using

sysupgrade -n -F

When was RC branch created?

commit b344ca9ca6
Author: Alexander Couzens <redacted>
Date:   Mon Jun 10 22:16:09 2019 +0200

    OpenWrt v19.07: set branch defaults

("RC1" is a tag, not a branch. While critical fixes have been backported, June 10th is when "active development" on what will become v19.07 ended.)

1 Like

When trying to change network (switch information) I get the rolling back dialog.
The dialog does not go away no matter how long I wait, and so I never have an option to "Apply unchecked".

If I manually refresh to get back to luci, I can see the "UNSAVED CHANGES" button, but clicking on that and then "Save & Apply" just takes me again to the "waiting for rollback" banner.

Admittedly these are work-arounds:

  • Hand-edit
    • Make all needed network-configuration changes directly editing /etc/config/network (or using UCI commands)
    • Run /etc/init.d/network restart (or reboot)
  • LuCI step-by-step
    • Make one set of changes with LuCI while connected to, say, Port 1, without modifying Port 1.
    • Apply
    • Reconfigure host, if needed, move Ethernet to another port
    • Make the remaining changes for Port 1 and apply
  • LuCI over wireless (if not disabled on wireless, which I typically do)
    • Make the changes using wireless access

Any of the above can be simplified by defining a "management VLAN" (or port) that is "stable" throughout your changes

1 Like

I really agree with that when changing the switch or other Ethernet, in case you change it in a way that breaks it you can still log in by wireless.