OpenWrt 19.07.0 first release candidate

The issue with my laptop was a bug in NetworkManager. The 1.20.6 release fixes it and I can connect with WPA3.

I am not seeing any performance problems with 19.07 on my R7800. Getting the same speed I was getting on 18.06.4.

What Linux distribution do you use?

Distribution: Fedora 31

TL-WR1043N v5 previously running 18.06.5 (ar71xx target), now running 19.07.0-rc1 (ath79 target).
Although a simple setup as an Access Point ONLY, no problems were noted with either!

Release Notes specify:

Sysupgrade from ar71xx to ath79 and vice versa is not officially supported, a full manual reinstall is recommended to switch targets for devices supported by both ar71xx and ath79

Question: Once Flashed, how does one determine which which target (ar71xx or ath79) was previously been installed, so that future Sysupgrades remain within the same target (ar71xx or ath79)???

the most simple way to determine is check dmesg:
ath79 will have only cpu clock print: [ 0.000000] CPU clock: 535.000 MHz
while ar71xx will have cpu/ddr/ahb/ref

1 Like

@LHoust Log in through SSH and do

root@OpenWrt:~# grep OPENWRT_BOARD /etc/os-release

In your case, it should show ath79/generic.

1 Like

I was able to eventually install 19.07 ath79 on a Western Digital MyNet n750. The first attempt to upgrade from 18.06.04 ar71xx through LUCI to 19.07 ath79 failed (I was prompted to force the upgrade) and rebooted the device into U-Boot recovery. Installing 19.07 ath79 Factory appeared to work but rebooting the device after making some settings changes resulted in it booting into U-Boot recovery again. I installed 18.06.05 ar71xx and everything worked properly, no issues configuring device and maintaining changes after a reboot. Tried a forced Factory image of 19.07 ath79 through PuTTY, which failed and booted back to U-Boot recovery. Installed 19.07 ath79 Factory image through U-Boot recovery, set a password and rebooted, and it was back to U-Boot recovery. Installed 19.07 ath79 Factory image through U-Boot recovery again, then imaged 19.07 ath79 Sysupgrade through LUCI. No issues configuring device and maintaining settings after multiple reboots with 19.07 ath79 successfully installed..

In order to get anything to install through U-Boot recovery I had to use fresh private browser windows. If I didn't, nothing would happen when I clicked the Install button after browsing for an image to install after the first time.

I don't know if anyone else has run into anything similar but I thought I'd share in case it helps.

1 Like

@zen1932 repots that the ath79 "tiny" builds seem to be underpopulated (squashfs versions missing).

A local build of with LuCI ("standard" collection)

commit 88bff692a5 (HEAD, tag: v19.07.0-rc1)
Author: Jo-Philipp Wich <redacted>
Date:   Wed Nov 6 09:08:44 2019 +0100

    OpenWrt v19.07.0-rc1: adjust config defaults

succeeded locally

openwrt$ ls -l bin/targets/ath79/tiny/
total 11841
-rw-r--r-- 1 jeff jeff     914 Nov 12 19:16 config.buildinfo
-rw-r--r-- 1 jeff jeff     267 Nov 12 19:16 feeds.buildinfo
-rw-r--r-- 1 jeff jeff    3254 Nov 12 19:18 openwrt-ath79-tiny-device-tplink-tl-wr841-v7.manifest
-rw-r--r-- 1 jeff jeff 4804846 Nov 12 19:18 openwrt-ath79-tiny-tplink_tl-wr841-v7-initramfs-kernel.bin
-rw-r--r-- 1 jeff jeff 3932160 Nov 12 19:18 openwrt-ath79-tiny-tplink_tl-wr841-v7-squashfs-factory.bin
-rw-r--r-- 1 jeff jeff 3670813 Nov 12 19:18 openwrt-ath79-tiny-tplink_tl-wr841-v7-squashfs-sysupgrade.bin
drwxr-xr-x 2 jeff jeff      47 Nov 12 19:18 packages
-rw-r--r-- 1 jeff jeff     747 Nov 12 19:18 sha256sums
-rw-r--r-- 1 jeff jeff      18 Nov 12 19:16 version.buildinfo

zip - package missed !!! - just unzip

nfs-kernel-server fixed and work again!!!

No problems on my Edgerouter X (got a "not compatible" warning and the boot took a while) and my Unifi AC Lite. Both were on a nightly build before and my Unifi was already on ath79.

I have a TP Link C7 V2.

What is the difference between the ar71xx download and the ath79 download? They seem to be 300 bytes different in size

ar71xx is deprecated and images won't be available after this release.

It has been replaced with the ath79 target. Most development work over the last many months has been on ath79 and not on ar71xx.

NB: Configuration often changes between ar71xx and ath79.

One should expect that wireless configuration is not compatible between the two and that Ethernet interface numbering may change.


Clear. Thanks!

The release notes say "Sysupgrade from ar71xx to ath79 and vice versa is not officially supported, a full manual reinstall is recommended to switch targets for devices supported by both ar71xx and ath79"

I assume I can not use the command line "sysupgrade -n". So what is meant by a "full manual reinstall"? Do I need to reinstall the tp link software first?

1 Like

With due respect to jow, who will bear the brunt of problems with "known" configuration changes as well as any unforeseen issues with cross-target upgrades (which, for some devices, may repartition the flash), my recollection of initial experience with initial upgrades on the Archer C7v2 from ar71xx to ath79 is that saving the current config to a "desktop", sysupgrade -n, and then editing the resulting configuration "worked for me."

The "safest" would be to flash the "factory" image using TFTP (which does not require the OEM image).


The main obstacle for ar71xx to ath79 upgrade is config migration (eth0/eth1 swap and similar issues).
For certain aspects, like renamed LEDs, there are even migration scripts in place.

So, for a productive device it might make sense what @jeff said, do sysupgrade -n and then implement your old config changes manually. Normal sysupgrade will just work for a lot of devices, but it might be easier to do it with "-n" for this single time instead of cleaning up afterwards.


Installed in Archer C20 v4

MediaTek MT7610E 802.11acn is Working!!! 5Ghz finally !!!

Testing stability now.

1 Like

Is there a list of which routers support WPA3 with this release? I have tried my TP Link C7 and it is not listed in the luci encryption options.

Install full wpad.


I get this too but it only lasts a couple of seconds then dissapears