OpenWrt 19.07.0 first release candidate

wndr3800 runs great, thank you!
I will report any bugs that I discover.
Very exciting release!!

Upgraded my WDR 4300, all seems to be fine!

The jump to hyperspace to ath79 - read and heed this one - a full manual reinstall is strongly recommended :wink:

congrats on the 19.07 - lot of effort has gone into it as noted by the number of commits going in.

I have an Archer C60 v1 and the 5 GHz network makes the router unstable in general after a few hours. It also happens in master. Not so in 18.04.x.

Huawei HG556a "A" - It seems to work properly.
Huawei HG556a "B" - NO. Image flashing does not work. It is necessary "OEM easy installation" to go back to 18.06.5 version.
Huawei HG556a "C" - It seems to work properly.
Huawei HG622 - It seems to work properly.
Alpha Networks ASL-26555 - It seems to work properly.

Has anyone managed to install the new firmware in the "B" version of the HG556a?

hopefully quickly overcome

WARNING: Makefile 'package/feeds/luci/luci-app-cifsd/Makefile' has a dependency on 'cifsd-tools', which does not exist
WARNING: Makefile 'package/feeds/luci/luci-proto-modemmanager/Makefile' has a dependency on 'modemmanager', which does not exist
tmp/ recursive dependency detected!
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection "Kconfig recursive dependency limitations"
tmp/ PACKAGE_nfs-kernel-server depends on NFS_KERNEL_SERVER_V4
For a resolution refer to Documentation/kbuild/kconfig-language.txt
subsection "Kconfig recursive dependency limitations"
feeds/packages/net/nfs-kernel-server/ NFS_KERNEL_SERVER_V4 depends on PACKAGE_nfs-kernel-server

Had to revert back to 18.06 on my R7800. The R7800 is configured as dumb AP for the upper floor and is connected to the main router via copper.

I had two main issues:

  1. The XboxOne of my son refused to make a stable connection to the 5GHz wifi. The R7800 showed it as connected but the Xbox displayed that it couldn't get an IP adress or that it wasn't connected. Under 2.4 (rc) and 18.06 (5GHz) it works as expected.The logs showed nothing special.
    After googling the issue i found one person who suffered from the same issue. Disabling the WMM mode seemed to solve it but at the expense of bandwidth. Apparently, according to my son, this is unacceptable in some games.
  2. I have a wireless security camera (Hikvision, onvif) which stores its images continiously to my NAS. Its connection with the R7800 seemed fragile. In stead of maintaining a constant datastream (like under 18.06), the stream fluctuated a great deal and often stopped. One time the camera had even crashed which never happened under months of 18.06. After going back to 18.06 the datastream seems continious (8192 Kbps) and almost constant.

My $0.02.


Switching wireless driver ath10k-ct / ath10k would be interesting.

You mean to replace the -ct driver with tthe non-ct in the rc or to replace the non-ct with -ct in 18.06?
Is there an easy way to try this? Preferably within Luci.

Quick question on full manual reinstall if switching to ATH79: Which command/image (factory or sysupgrade) should I use? Thanks!

1 Like

The most suitable would be to compile with those drivers. With image builder.

You use sysupgrade to upgrade OpenWrt.

Download the ath79 sysupgrade version for your hardware. Use sysupgrade -n -F to install. Note that -F will force any file into the flash, so be sure you have the right one or it will brick.


Sure, GUI SYSTEM/SOFTWARE preferable from a wired computer ;- )

Just flashed it on my WNDR3700v1 with the upgrade image and now my router is bricked.
Tried to connect to the web UI and now it's coming up as 'connection refused'.

Which image did you flash (ar71xx, ath79)? How did you flash it? Did you use "force"? Did you explicitly disable saving configuration?

I've did the ar71xx image and I flashed it with the web UI. I did choose to save the existing settings though, was that the problem?

None, you flashed the same target. The issues mostly occurs switching from ar71xx to ath79.

I'm going to put 'WNDR3700-V1.0.16.98NA.img' back on via TFTP and use the stock firmware to go to 'openwrt-ar71xx-generic-wndr3700-squashfs-factory-NA.img'. See if that works.

1 Like

Or, perhaps just try "failsafe" mode.