OpenWrt 19.07.0 and OpenWrt 19.07.1 bug

Have you updated your browser? Have you tried other browsers?

1 Like

I use latest version Firefox Quantum. Other Browser I not tested , because in 17.x and 18.x this problem not detected. Also you they say what this problem have and in Chrome 80 , only a little different , but linked with links in OpenWRT 19.0.x.

Why do you keep loading the Overview page quickly???

Because in this and there is error.
In 18.06 and older this error not detected.

I suspect that the issue you are seeing is not a bug in OpenWrt, but rather something related to your browser. Take a look at the release notes for 19.07.0 -- of note:

The client side rendering would likely explain this behavior. You also have a number of FF extensions running, it might be worth turning those off to see any of those are responsible for the problem.

I have not been able to reproduce your experience on Safari on a Mac running Mojave, and it was stated earlier that it doesn't happen in FireFox 73.0 (as an aside, there was a major security vulnerability found in FF72, so you really shouldn't be running anything earlier than 72.0.1, or ideally 73).

It is really important to understand that a bug can only be fixed if it is reproducible by enough people to confirm that is in fact a bug (and not a client/browser issue) and to allow the developers to trace the code through the specific conditions that cause the bug to manifest. This requires eliminating all unnecessary variables (extensions, for example), and trying several different browsers to identify which ones/which versions may cause this bug to occur. So far, there are very few indications that the problem lies within OpenWrt itself, so I am not yet willing to consider this behavior a bug.

Good , but there is one circumstance which indicates what tihs bug.
If I input 192.168.x.1 and input login and password - page will opened normally,
If I input 192.168.x.1 and input login and password , open page and click to make for open next tab and next open - page will opened normaly.
But , If I input 192.168.x.1 and input login and password , next open page and next close page and next If I input 192.168.x.1 without logout before I input 192.168.x.1 - I recive error.
Next , if I open in next tab or refresh current tab - I not recive bug.

If I was recive this error always when open web interface 192.168.x.1 - you was be be right , but i recive this error only if open web interface with autoruzing and next close all tabs wilth 192.168.x.1 and next later short time opening 192.168..x.1

If this error occurred every time, it would be indicative of a potential bug in OpenWrt (or a bug/interaction with the browser). But since it only happens when you have a strange sequence of opening/closing/authorizing tabs, I am led to believe that this is a session management issue within Firefox.

1 Like

Good , I offer to you test your assumption, easy install Firefox 73 and create proffile with need addons which I use for test on this mode.

If you can do so and not recive bug - I will consider thos variant.

Have you tried Firefox 73 on your system? Does the problem still occur (according to @dg_102, it does not happen on 73)?

1 Like

Yes , whth FF 73 this problem still occur

have you disabled all of your extensions and cleared your cache?

1 Like

I work without disk cache , I work only cache in RAM , so that me nothing to clean


1 Like

What would understand , I offer to you install extensions in pure profile and test on side. If you all work - to I not understand what do.

All my extensions

I am asking if you have disabled all of your extensions. Although I am willing to test on FF73 when I have some time, I do not want to install extensions into my system. I am trying to help you identify the root-cause for the issue -- you seem to be one of the few people experiencing it, so it is important for you to do some basic troubleshooting first.

Since you are experiencing the issue, you should start by disabling all of your extensions and running the tests again. If your issue doesn't happen, start re-enabling the extensions one by one to figure out which one(s) are responsible for the problem. If you can identify some specific extensions that cause the issue, it would then be possible to understand if this is a bug with Firefox, the extension(s), or OpenWrt.

1 Like

No , I this not does , because I use very more tabs and if only disable Simple Tab Groups, recive garbage and not opportunity work in browser. Yes , I probably crazy , because use ~350 opened tabs in multiple groups.

I think that you have too many things going on to properly troubleshoot the issue. You must reduce the problem to something that is easily reproducible by other people.

You do not seem to be making a good faith effort to properly troubleshoot this issue, and you are instead telling us to install your extensions and open hundreds of tabs and so on. You must prove to us that this is actually a bug with openwrt and not something caused by your extensions or hundreds of tabs.

Not therefore , if was be IPv6 worked without problems - I maked this expirence , but , in my case this expirience gives problem with IPv6-PD. This another one problem because of which I not want touch hardware.
As can see, me need solve two problems. First for offloading router , second for normally recive Prefix Delegation. In this OpenWRT 18.06.5-18.06.7 and IPv6 I thinked what solved , but learned what problem me yet have.

I still do not believe that this is an OpenWrt bug. I think you may be experiencing the issue as a result of other things you have configured on your computer/browser combined with a very unusual sequence of opening and closing tabs and navigating to the OpenWrt router page. Even if it is a bug, it is such a corner-case that it is extremely unlikely that many other people will experience it and even less likely that it will be fixed.

You cannot expect the community here to perform the testing and debug for you when you have not done the reasonable and logical things that have been asked of you to verify the specific conditions that produce this issue.

There is nothing else I (or likely anyone else here) can do for you until you have tested with all of your extensions disabled and with all of your tabs closed except for the tabs specifically related to reproducing the issue you are seeing with the OpenWrt LuCI pages.

Good , what would I do so as you say , me need help.

I will describe problem in here OpenWRT 18.06.5-18.06.7 and IPv6 and beg help.