OpenWrt 18.06.2 Service Release


#1

The OpenWrt Community is proud to announce the second service release of
the stable OpenWrt 18.06 series.

OpenWrt 18.06.2 incorporates a fair number of bug fixes in the network userland and the build system, as well as updates to the kernel and base packages.


Some selected highlights of the service release are:

  • Linux kernel updated to versions 4.9.152/4.14.95 (from 4.9.120/4.14.63 in v18.06.1)
  • Security fixes for the Linux kernel, GNU patch, Glibc, BZip2, Grub, OpenSSL and MbedTLS
  • Build system bug fixes
  • IPv6 and network service fixes

For a detailed list of changes since 18.06.1 refer to
https://openwrt.org/releases/18.06/changelog-18.06.2


For latest information about the 18.06 series, refer to the wiki at:
https://openwrt.org/releases/18.06/

To download the v18.06.2 images, navigate to:
https://downloads.openwrt.org/releases/18.06.2/

Have fun!

The OpenWrt Community


pinned #2

#3

Great work, many thanks! :+1:


#4

Thank you for your hard work.
Downloaded and installed on TP-Link Archer C7 v2 with no problem seen after 10 hours of uptime on a pretty vanilla configuration.

Model TP-Link Archer C7 v2
Architecture Qualcomm Atheros QCA9558 ver 1 rev 0
Firmware Version OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)
Kernel Version 4.9.152
Uptime 10h 22m 58s


split this topic #5

A post was split to a new topic: 18.06.2 - Upgrading packages


#6

Hello

this release does not work with the D-Link DIR-885L, I can only get the 18.06.1 to work, I tried to flash through emergency mode and also through the openwrt gui (flash image) but it keeps flashing and nothing happens, waited 15 min, but when flashing previous builds it flashes less then 30 seconds. thanks


#7

Are snapshots also broken?


#8

yes snapshot did not work either... :confused:


#10

Thank you very much!
Runs without errors.

Model
TP-Link TL-WDR3600 v1
Architecture
Atheros AR9344 rev 2
Firmware Version
OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)
Kernel Version
4.9.152
Local Time
Wed Feb 6 14:57:42 2019
Uptime
6h 31m 18s


#11

All working as expected, BIG thankyou for the continual work put into these updates!

Model TP-Link Archer C2600 v1.1
Architecture ARMv7 Processor rev 0 (v7l)
Firmware Version
OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)
Kernel Version 4.14.95
Uptime 2d 17h 23m 39s


#12

Thanks

Working well on Netgear dgn3500, more stable than previous 18.06.1


#13

Hallo and thank you for doing the work
The update ran without problems on my Netgear WNDR4500

But now I have to install samba, mc and openvpn


#14

First of all, big thanks to all the developers!!

Just found there's no rt305x folder under targets/ramips in this version (it was in 18.06.1).

Will it appear later on?

I had 18.06.1 version from that folder working OK on ASL26555

Thanks again!


#15

Seconded.

Rebooted, flashed with settings kept. No luci HTTPS when booted and password auth failed, but ssh worked with key auth.
Installed missing packages, rebooted and when booted there was no luci - HTTP or HTTPS. Login in with ssh, enabled and (re)started uhttpd and luci was back with working password auth.
Everything I've checked so far in addition to wired and wireless functions seems to be working fine: HE.net 6in4 tunnel, DDNS, USM drive with btrfs, minidlna, haproxy, ZNC.


#16

Hello,
I was wondering if on Linksys WRT32X there no WiFi issues with Apple devices (iPhone, Airport Express in particular) ?

I am coming from DD-WRT, where there is known WiFi issue with apple devices and there is no fix on the horizon so I decided to try OpenWRT ...


#17

See https://github.com/kaloz/mwlwifi/issues for a list of pending issues with the mwlwifi drivers.


#18

Working flawlessly on my wdr3600. Thanks for the awesome work!


#19

Yup, build system is alot snappier.......

fyi, this has also fixed the issue I was having getting the kernel to build in usb modules. no longer need to slide in overrides....

top work!


#20

Thank you for all your hard work. Running on my WRT32X. Hoping good kernel 4.19 support makes it to the mvebu platform.


split this topic #21

A post was split to a new topic: Archer C7 V2 - No LuCI after update from 18.06.1 to 18.06.2