OpenWrt 18.06.1 Service Release


#1

The OpenWrt Community is proud to announce the first service release of stable OpenWrt 18.06 series, which marks the first major version after the remerger of the LEDE and OpenWrt projects.

OpenWrt 18.06.1 incorporates a number of mostly security oriented fixes backported from the development branch during the last two weeks.


Some selected highlights of the service release are:

  • Linux kernel updated to versions 4.9.120/4.14.63 (from 4.9.111/4.14.52 in v18.06.0)
  • Security fixes for Curl, Mbedtls, OpenSSL and the Linux kernel
  • Binary builds for the at91 and ath25 targets
  • Updated mwlwifi driver
  • Improved input validation for rpcd uci ubus calls
  • Crash fixes in libuci
  • Assorted bug fixes in netifd

For a detailed list of changes since 18.06.0 refer to https://openwrt.org/releases/18.06/changelog-18.06.1


For latest information about the 18.06 series, refer to the wiki at:
https://openwrt.org/releases/18.06/

To download the v18.06.1 images, navigate to:
https://downloads.openwrt.org/releases/18.06.1/

Have fun!

The OpenWrt Community


#2

#3

Can't find this anywhere, 18.06.1 tiny for ar71xx, does it include Luci?
Specifically for wa801nd V2

Thanks a bunch


#4

Config. Seed
Says : CONFIG_PACKAGE_luci=y


#5

Has anyone tried to install 18.06.1 on a "archer c7 v2"?
I wasn't able to upgrade from 18.06.0 via the gui with a sysupgrade-image.


#6

Zero problem here...


#7

Did you try an unofficial ath79 image for your Archer C7 v2 before flashing the official 18.06.1? Then it is expected to fail because the boardname differs between ar71xx and ath79.


#8

No i did not, I will try again to update the archer tomorrow.


#9

Another try would be:
sysupgrade -v /tmp/openwrt-18.06.1-ar71xx-generic-archer-c7-v2-squashfs-sysupgrade.bin


#10

tl-wa801nd V2 TINY image works great! With Luci.


#11

I flashed it NEW to have everything clean again, on my Linksys WRT32X to OpenWRT 18.06.1 , no problems found so far (its up now 2h, so far, so good, all cool, but time will show :wink: ), using DNSMASQFULL, DNSCRPYPT 2.16,MC, NANO, NMAP, ZSH and some more..all cool untill now, I only hope, that SoftetherVPN will be avaible for 18.06.1 soon too.... Bravo and Thank you for all your effort! I love OpenWRT

ONE question I have, when I loginto Luci, it shows:

OpenWrt 18.06.0 r7188
Kernel Version 4.14.54

Is that correct? Wondering, shouldnt say it 18.06.1 ???


#12

It is incorrect. It should read:

OpenWrt 18.06.1 r7258-5eb055306f
Kernel Version 4.14.63

From Changelog:

bfc9a44 kernel: bump kernel 4.14 to version 4.14.63 (+6,-107)


#13

Thank you :slight_smile: dont know why it happened, as I dled it for WRT32X from here:https://downloads.openwrt.org/releases/18.06.1/targets/mvebu/cortexa9/
openwrt-18.06.1-mvebu-cortexa9-linksys-wrt32x-squashfs-sysupgrade.bin

Anways, Thanks fot letting me know, Ill check out again and see why its so =D


#14

For some reason 18.06 requires kmod-usb-storage-uas for some USB hard drives that functioned without it using 17.01 I think I've seen 4 threads with the same problem so far. Is this a bug?


#15

No,
It is a new feature to speed up USB3 storage devices

See Step #8
https://openwrt.org/docs/guide-user/storage/usb-installing


#16

I know, I put it there. I haven't added USB storage support to my own router, but all the questions about it clearly shows that it's now required for people who didn't need it on v17.


#17

Also, that wiki needs re writting since most of those kmods in steps 1,7 are not required anymore. The new release (18.06) for my hardware anyway are using dwc2 or dwc3 (builtin) which seem to be a better unified kmod for usb2/3


#18

There are already quick installation guides for various use cases. The USB installation guide is supposed to be extensive and help those who are still having problems after following those.


#20

Hi lleachii

Now it worked, Problem fixed on my WRT32X, booted up in my other partition, where I still had OpenWRT 17.05, from there, did flash and it worked:

OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)

Kernel Version 4.14.63

Best greetings everybody =D


#21

Do you guys know what the current packages are required to build a full buildbot , I think from https://openwrt.org/docs/guide-developer/build-system/install-buildsystem must be missing some packages. I am building on a Docker Debian Stable.

I have a list eg:

asciidoc bash bc time bcc bin86 binutils build-essential bzip2 cmake curl default-jdk fastjar file flex gawk gcc genisoimage gettext git git-core intltool jikespg libboost-dev libgtk2.0-dev libncurses5-dev libssl-dev libusb-dev libxml-parser-perl make mc mercurial nano ncdu patch perl-modules python python-dev quilt rsync ruby sdcc sharutils software-properties-common sshpass subversion sudo unzip util-linux wget xsltproc xz-utils zlib1g-dev g++-multilib swig python3 python3-dev

For example, I can't build hostpad-utils and give it is not a feed, i have no idea which make I could figure out the error would be.