Openmptcp on raspberry pi4 with ethernet dead

hello there
i ve an issue with my pi4 i m trying to solve, i was using it as a router with openmptcp but i got a power cut wich seems to have damaged my ethernet port ( i ve tried to ssh to it using wifi and raspian and it was working.with the ethernet port it s not working)
so i thought to add an usb to eth converter.but this converter needs a driver i need to install.

So how should i proceed as i don t know how to ssh to the openmptcp with the wifi (how do i activate the wifi) as i ve tried to use an screen (the hdmi converter to vga seems unresponsive) ,so i don t have a screen connected.
the idea is to ssh to the pi and install the driver on it (build it) and then use it again as a router thru the usb/eth converter
If any ideas are welcome

don't know if it's enabled on raspberry pi 4 with your setup by default, but if you have a usb ttl serial adapter you can ssh to the pi with that.

hello jesanor
thank you for your reply
can you point me to some docs on how to do it?


first of all if you have a usb-ttl converter try to ssh to the pi, the serial port might be enabled by default.

pin 8 on pi is TXD pin 10 is RXD pin 6 is GROUND

otherwise add enable_uart=1 to config.txt in the boot partition, then ssh to the pi using com port from your pc/mac. (first google result this is for pi 3 but it's the same for pi 4)

1 Like

have you tested with a clean snapshot as i suspect your ethernet port would not really be fried...

1 Like

hi wulfy
already tested ,same thing ,no ethernet connectivity
i ve been able to ssh on wifi with raspian but wasnt able to do so with the eth.

1 Like

thank you for that

i ll have to wait my usb-ttl to test it, ordered it yesterday ,will get if from monday. i ll post the progress then
btw what are the login and pwd for openwrt?


user root, password the same as luci or none if you didn't set up one.. this for a default openwrt installation.

1 Like

hi jesanor
got the cable today
i m able to ssh using it but now i don t have enough knowledge of the langage for :
-activating the wifi and connecting the pi to the internet so i can download the files of the driver and install it
-or send directly the files thru the serial cable to pi4
any ideas?

easiest thing to do is put the sdcard back into a pc and copy the pre-downloaded ipk's there... ( partition1 /boot is vfat so that should work in windows if mounting partition2-ext4 is difficult )

what is the BUILD_ID? and driver chipset?

grep '^BUILD_ID' /etc/os-release

also, are you intending to use the usb-ethernet as only the lan interface or do you have two?

hi wulfy it s a lention named brand and this is how they describe it
HU404GE SWI Driver for Linux kernel AX88179_178A_LINUX_DRIVER_v1.19.0_SOURCE
can bei download from here

The AX88179 is supported with a pre-built package in OpenWrt, kmod-usb-net-ax88179.

Obtain this kmod from the kmods subdirectory of where you obtain the snapshot OpenWrt image. The kmod must match your kernel build, and new builds are made each day, so you need to download a new image and the kmod on the same day.

I think this single file is all you need, as its dependencies are already installed. If not the opkg will tell you what else is needed.

By default, the serial port automatically logs in as root with no password. As noted, the boot configuration must be changed to enable it. Since the file is in the FAT formatted partition of the card, a Windows PC can access it.

thank you mk24
i will not need this as the ethernet started to work after the serial ssh.
so my pi is back to business without the need of the adaptor

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

i m back to square as my pi4 is not connecting thru ethernet , i ve tried to ssh it using usb ttl but i can only see the start events but can t interact with my pi4 basically i can t type in with the serial usb ttl, anyone has a solution for this?

in the meantime i ve installed an image on an old acer e1-571g but openmptcp is not detecting the wifi wich is an atheros AR5B125 .how do i do to get it recognized and activated?
thanks in advance

No one got any idea about this?

check the usb-ttl cables for good connection..
check your software serial settings..
hit enter to activate serial console in openwrt..
on a different sd card with raspbian/raspberry pi os activate serial and test usb-ttl there..

end of ideas for now :wink:

the cable is reacting with raspbian but not with openmptcp
so i do know for sure the cable is ok .
I ll investigate on software side if there anything i can do