NowTV / OpenWrt

Hi All,

Hoping someone can help - I'm trying to set up my NowTV broadband using my own modem and router (running OpenWrt 19.07).


Openreach HG612 3B Modem (DSL light steady, checked modem stats and show active connection)

Linksys WRT32x running OpenWrt 19.07

I've searched around and found some config to use (from BT Homehub 5A with NowTV fibre) but still unable to connect. I get the error 'Network Device is not present' under the WAN/WAN6 interfaces.

Please help!!


Post the contents of your /etc/config/network file.

fwiw, do NOT change the ifname in WAN section. Leave it as default for your WRT32x and try again.#

for example:

config interface 'wan'
        option ifname ???? #  keep whatever is default for your WRT32x. Do NOT change it to dsl0.101
        option proto 'dhcp'
        option clientid 'anythingYouLike'
        option macaddr 'A2:BB:CC:DD:EE:FF'  # optional, replace with your sky routers wan mac if included (2nd digit must be an 'even' number)

Good luck

ps. Last week, I replaced an older Sky hub with a later Sky Q Hub (aka NOW Hub 2) and I observed it took 'several' minutes for the new hub to eventually get an IP address.

Hi Bill,

Thanks for the suggestion, please see my config file below:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'
	list dns ''
	list dns ''
	option ipv6 'off'

config dsl 'dsl'
	option annex 'b'
	option tone 'a'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'
	option clientid '12345678'
	option macaddr '88:72:15:XX:XX:XX'
	option hostname '12345678'
	option ipv6 'off'
	list dns ''
	list dns ''
	option peerdns '0'

config device 'wan_dev'
	option name 'dsl0'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option ifname 'eth1.2'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

That has helped to get rid of the error seen previously but no IP address i'm afraid. I left it for 20 minutes but no joy.

Interestingly, I took my router and Openreach modem to my brother's place (who has Sky Fibre) and it worked straight away. The only change being the MAC address which was adjusted to set the second digit as a '2'. I tried to test using has MAC back at my place but no success i'm afraid.

Any help is much appreciated! Thank you!

The 'dsl' section is redundent as your router is not a Lantiq DSL modem.

The 'wan_dev' section is also incorrect but it wouldn't explain why you cannot connect to NOW broadband. Is it supposed to read 'eth1' for WRT32x ?

Perhaps remove the 'hostname' line from 'wan' section?

I suspect you wouldn't be able to use your brother's MAC address at your place if his Sky hub is active btw.

I presume you tried a 'random' MAC address too ?

Perhaps do Not connect any modem to the VDSL line for half an hour?

As it works on Sky FTTC connection, then I'm afraid I'm out of ideas to get it working on NOW FTTC.

Hi Bill,

Thanks for the suggestions. I managed to get it working in the end - I made the changes you mentioned and played around with the client id value. I noticed that it had to be a hexadecimal value and looking at previous instructions, I generated one based on the format macaddress@skydsl|12345678 and it picked up an IP instantly. Not sure if this is correct but if it works, i'm not complaining :grinning:

Many thanks for your help, much appreciated!


Pleased to hear it is working. I've updated the owrt wiki page in the light of your discovery.

I wonder if the original value you used, '12345678', was too short ?

Using your later example, macaddress@skydsl|12345678, it generates a 70 digit long hexadecimal number using the converter from post in the skyuser guide:

Changing the subject slightly, does the NOW Broadband Buddy (Parental controls) work with your OpenWrt router?

I suspect the value may have been too short also.

I ran a quick test with the NowTV Broadband buddy, it didnt seem to work. I explicitly blocked a betting website as a test but even after 15 min I was able to access it successfully. I would guess that they filter based on DNS queries and as i'm using Google DNS, it wasn't filtered.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.