Separate Modem and Router with Now (Sky) Broadband?

Hi,
Current setup works:

  • NOW Broadband Hub Two connected to the Internet
  • Netgear R7800 running OpenWRT with WAN interface connected to LAN port on the NOW Broadband Hub Two
  • NOW Broadband Hub Two sees Netgear R7800 as DMZ host
  • On the LAN interface, I have a separate subnet to which devices connect.
  • It's what some call "double NAT". Double NAT per se doesn't bother me, but having 2 routers seems inefficient especially as I have a working Huawei HG612 modem.

What I'm thinking is replacing the NOW Broadband Hub Two with the Huawei HG612 modem and moving the authentication to the R7800.

I've read the ISP configs page https://openwrt.org/docs/guide-user/network/wan/isp-configurations
and I've also noted the NOW Broadband specifics: NowTV / OpenWrt - #5 by Sunny112

But, as far as I can tell, the ISP configs page assumes that Openwrt is running on a combined router / modem, whereas mine will be separate devices.
I don't think that'll matter (in theory) because the modem will still sync and then I just need to log in using MER (i.e. passing the creds via DHCP).
So, I think that it should work. But, I was wondering if anyone has got such a setup working before I spend time fiddling only to roll it all back again. :wink:

Actually, pretty much like this: SkyQ VDSL setup but in that case it was a Billion 8800nl in bridged mode which I think would function the same as my Huawei HG612.

TIA
m

Well, I can answer my own question as I tried it: yes it works. The HG612 modem requires almost no config (it selects the right VLAN automatically but it defaults to 802.1p = 2, which needs to be changed to 0). Although I (apparently) don't need the password, I grabbed it anyway using the Wireshark method and encoded it here http://string-functions.com/string-hex.aspx. I put that encoded user name / password into the Openwrt GUI for the WAN interface (once I'd set it to DHCP) and, well, it just worked first time.

The only comment I would make is that my networks file don't look anything like the one here https://openwrt.org/docs/guide-user/network/wan/isp-configurations but it still works.

Here it is (with specific stuff obfuscated):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fa11:fa11:fa11::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.3.1'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option clientid '1234567890abcdef1234567890abcdef1234567890abcdef123456'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.