Not getting via IPv6 /64 Relaying

I get only /64 IPv6 from my ISP. I want to use the same prefix across multiple VLANs but have different firewall rules.

I setup everything but the problem is I am not receiving any IPv6s, only link local, IPv4 is working fine.

DHCP config:

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ndp 'relay'
	option ra 'relay'
	option dhcpv6 'relay'

config dhcp 'servers'
	option interface 'servers'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ra 'relay'
	option ndp 'relay'
	option dhcpv6 'relay'

config dhcp 'wan6'
	option interface 'wan6'
	option ignore '1'
	option master '1'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

Network config:

config interface 'servers'
	option proto 'static'
	option device 'br-lan.8'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option delegate '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option device '@wan'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2606:4700:4700::1111'
	list dns '2606:4700:4700::1001'

config interface 'lan'
	option device 'br-lan.2'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option delegate '0'

I am also using an router as a dump switch/ap not sure if that matters.

In my fedora pc I get only IPv4:

enp4s0f4u1u4c2: connected to Wired connection 1
        "ASIX AX88179"
        ethernet (cdc_ncm), A0:CE:C8:FF:19:DB, hw, mtu 1500
        ip4 default, ip6 default
        inet4 192.168.2.183/24
        route4 192.168.2.0/24 metric 100
        route4 default via 192.168.2.1 metric 100
        inet6 fe80::d2a5:1c24:4b52:8e8e/64
        route6 fe80::/64 metric 1024
        route6 default via fe80::48c5:bdff:fe46:3da8 metric 100

You'll need more than a single /64 to distribute IPv6 to multiple VLANs. Try directly setting your wan6 to request a prefix of /60 rather than 'auto'.

option reqprefix '60'

1 Like

Doesn't work, in India all residential ISPs give only /64.

Also I don't want to distribute I want to use the same prefix via relaying like this guy:

Is it possible?

It may be possible, but it is not a configuration with which I have had any useful experience. The best I have been able to accomplish with only a /64 is getting it to pass through to a single VLAN. Hopefully another forum member will be able to reply with more details applicable to your situation.

It may be easier to setup masq6 instead. You may be able to further subnet the /64, but that isn't standard.

Anyone? Bump

I see that your ISP provides the following on the WAN6:

  • IPv6: 2401:4900:1c28:9fff::19f:2188/128
  • IPv6-PD: 2401:4900:1cc8:f24a::/64

With IPv6-PD available (great news!), you should be able to assign the delegated IPv6 range "2401:xxxx:xxxx:f24a::" to any LAN interface. Since this isn't working in your current setup, try resetting your OpenWrt router. Check if the delegated IPv6 block is automatically assigned to the LAN interface by default with the standard OpenWrt configurations (it should!). If it is, you can then proceed with VLAN configuration, and it should still be automatically assigned to any available VLAN. Once you confirm automatic assignment, you can manually assign it to the desired VLAN interface.

After that, you can proceed to relay your WAN6 IPv6 range "2401:xxxx:xxxx:9fff::" to the other VLAN interfaces, and I think my setup here is similar to your: Relay a single IPv6 /64 prefix into several VLANs - #10 by alexq

1 Like

I rebooted 100 times not working.
I tried your setup, its not working.

Your setup seems to relay the /128 not the /64?

I'm not sure, but the relay was functioning properly, and I received IPv6 on the relayed VLAN interface.

Could you try resetting instead of rebooting? This will allow you to verify the out-of-the-box IPv6 OpenWrt configuration and the delegated IPv6 address assignment.

I don't want to reset, I already have stuff configured. I can get delegated IPv6 to LAN but not any another interface.

Can you show me your IP ranges again? I can't wrap my head around the setup of yours.

Great! If you can assign the delegated IPv6 "2401:xxxx:xxxx:f24a ::" block to the LAN, it partially solves the issue (you can assign only one IPv6 to your LAN interface because your ISP provides an IPv6-PD /64, leaving no room to divide it into multiple LANs or VLANs).
For the other interfaces, you just need to try relay "2401:xxxx:xxxx:9fff ::" using IPv6 relay mode based on the official documentation: https://openwrt.org/docs/guide-user/network/ipv6/configuration?s=ipv6&s=relay#ipv6_relay

:information_source: By the way, you can check if your ISP provides only one IPv6-PD /64 block or if multiple blocks can be requested, e.g. two or more IPv6-PD /64 blocks .

I do not have this setup anymore because I was able to obtain multiple IPv6-PD blocks and assign them to each VLAN interface, avoiding IPv6 relay mode.

Already tried this, not working.

Won't work my ISP uses PPPoE.

I gave up on this and moved to ULA + NPTv6, I'll create a new thread for the issue I am having. If I solve that I don't need to relay anymore.

1 Like