Not able to install OpenWRT on Linksys EA8500


Just received my brand new Linksys EA8500.
I booted it and it automatically did firmware upgrade to (I didn't even had a choice of saying "no").

The OEM GUI looks nice and it seems to have a nice feature set, but I want the good old OpenWRT!

So, I was following the "OEM Easy installation procedure" (just loading the OpenWRT file in the GUI) and got this error (attached image).

Any idea how to overcome this?


1 Like

The forum search is your friend.


Thanks for getting back.

While at dinner, I had the simplest idea: Flashing an old OEM stock firmware and then trying OpenWRT.

It worked!

I downloaded the OEM stock file from OpenWrt EA8500 page and flashed twice, one after the other. Then, tried the OpenWRT file and got it

Leaving this here for future reference.


1 Like

Hey joaoabs, which OEM version did you download? I have tried that but I get the error message you were originally getting. When I went to the link I saw version FW_EA8500_1.1.4.169978_prod, downloaded that one, but when running it, the error about not being compatible keeps popping up.

Did you do anything before trying to reinstall the OEM on top of the Latest firmware version? I also have currently running on the Router.

Any info would be appreciated.

Does the same happen when you try via TFTP as mentioned on the EA8500 devicepage linked above?

This is why your shouldn't blindly connect things to the Internet, particularly un-configured consumer routers.


Glad you got it working. Please always leave thread postings for others' future reference.

1 Like


I had the version and downloaded this one. It didn't seem to care (after all, a downgrade should be a valid use case, I believe). Anyway, I flashed it twice and managed to reach version In this version, it accepted the latest OpenWRT firmware. Are you sure you are using the factory binary (not the upgrade?).

If it doesn't work, do one reboot and try again. It seems this device has some dual bank and may boot alternatively (not sure how it works exactly).

My device is european, case it matters.

Hope it helps

Hi Joaoabs,

THats the version that I have tried several times. My router came from US, it could be that the firmware from there is not letting me do the downgrade. Lucky you, that didnt have to go through so much trouble hehe.

Unfortunately I got the router yesterday so I dont have a dongle cable for the TFTP process. Also, my router after I opened it does not have the serial pins. So, from what I have found I have to solder cables to connect to the dongle. Do you know what cables I should use to solder? Is there anything special besides the dongle (which I already order)?

I don't know the specific case for this EA8500, but I've done it several times in the past with other routers.

I usually solder "pin headers" and then use a "USB 2.0 to TTL UART Module" with "jumper cables" to have a serial connection to the router. (If you don't know what these are, you can search these terms in ebay).

Have you tried to reboot between tries?

Well, will give it a shot when the cable arrives. I did try rebooting the router several times but no luck. I guess I am in the same position as many others. Unfortunately there is a signature code added to the latest version of the EA8500 that does not allow firmware downgrades pass certain versions (to prevent exploits like installing third party firmware).

Will update once I get the cable and play around soldering the to the none existent serial port haha. Thanks for your response.

Meanwhile I've found a page that shows more info on how to do it:

It's on the device page, but it's easy to go unnoticed.

Anyway, getting slightly off-topic, my suggestion is to go through the forum and decide if you really want OpenWRT on your EA8500.... I'm experiencing some issues that I wasn't expecting.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.