Linksys EA8500 stopped recognizing SSDs, even after reflash

Hi there,

This will be a long post, but bear with me because I'm starting to believe in witchcraft :stuck_out_tongue:

I've purchased a brand new linksys EA8500 and have been trying to get it working with OpenWRT in the last few days, but without full success.
Initially I had an issue with the OpenWRT FW flashing. Solved.
Then, a problem with soft reboots. Problem identified but not solved.

In the last days, one of the first things I did (successfully) was to attach a SSD disk to the USB3 port and with it I was even able to boot from it, although having some errors in the logs that don't seem to be a problem. With several troubleshooting actions to understand the erratic reboot behaviour, I did a few reflashes, but now I can't get any way of making the router to recognize the SSD again.

I have two different SSDs (Sandisk 120GB and Crucial 275GB) and two different USB3-to-SATA adapters (orico and white-branded) and I've tested all the combinations without success. I've tried both the USB3 and USB2 ports in the router.

Also, if I connect any of these disks/adapters to a linux machine, they are all recognized and automatically mounted.

If I connect an USB3 stick to the router, this is recognized and I can mount it normally, so I guess I should have all of the packages/drives for it, right?

All the reflashes were with the "keep configurations" box unchecked.

Whenever I plug the SSD, I just get confirmation about it on a "USB level":

[ 9331.789817] usb 2-1: new SuperSpeed USB device number 3 using xhci-hcd
root@OpenWrt:~# ls /dev/sd*
ls: /dev/sd*: No such file or directory

If I insert a USB pendrive, I get information at filesystem level:

[ 9495.626104] usb 2-1: new SuperSpeed USB device number 5 using xhci-hcd
[ 9495.659155] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 9495.660127] scsi host1: usb-storage 2-1:1.0
[ 9496.721834] scsi 1:0:0:0: Direct-Access     TOSHIBA  TransMemory-Mx   PMAP PQ: 0 ANSI: 6
[ 9496.723159] sd 1:0:0:0: [sda] 121858560 512-byte logical blocks: (62.4 GB/58.1 GiB)
[ 9496.729478] sd 1:0:0:0: [sda] Write Protect is off
[ 9496.736512] sd 1:0:0:0: [sda] Mode Sense: 45 00 00 00
[ 9496.736878] sd 1:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[ 9497.185555]  sda: sda1
[ 9497.188474] sd 1:0:0:0: [sda] Attached SCSI removable disk
root@OpenWrt:~# ls /dev/sd*
/dev/sda   /dev/sda1

Any suggestion?

A shot in the dark: what's the file system of the SSD disks and the USB stick you tried?

Just found the issue. The kmod-usb-storage-uas package is required for this kind of devices.

Maybe we should update the user guide?

The partitions are ext4.

These days have been a struggle, man! :slight_smile:


1 Like

Well, the user guide provides support for regular devices.

kmod-usb-storage-uas is mentioned here

But I agree that this could be at least referenced in the user guide, probably a long with a link to NTFS support page

Maybe after you are done with the victory dance you could edit the user guide to reference both pages. That would make finding the info easier

Please add that only on one page (, not on both.

I was not suggesting to duplicate info. I meant that could list the links to other related pages such as usb-installing and writable NTFS, so that the user know

1 Like