No WPA / EAP is shown in wireless Security to use "Pyur Community"

I'm trying to connect a TP-Link CPE 510 to the WLAN "Pyur Community". As we read in this tread, no PEAP or EAP is displayed under Wireless> Security under WPA. The peculiarity is that you have to log in with your username and password. I use the snapshot firmware I tried both "Join" Network and manually. Does somebody have any idea?

Thanks for help!

Uninstall the small "wpad" and install the biggest/normal one!

Thank you. I tried:

opkg remove wpad > no packages removed
opkg remove wpad-mini > no packages removed

What are the right names to remove and to install?

opkg remove wpad-basic but you can also use opkg remove wpad-*

For full wpad install:
opkg install wpad

1 Like

I figured it out: i had to install "wpad-supplicant" with working internetconnection on the AP.
With the "wpad" - package I saw only "wep" as possible security methode.

Now the access-point is connected with "Pyur Community". The AP works now also as dhcp-server, but my pc in dhcp-client mode can't ping .

Do I have to set any routes or connect the interfaces in any way?

Package wpad includes both wpa-supplicant and hostapd in one package. This should be the only package you need. Some builds ship with wpad-mini and some with wpad-basic. Both of these are limited versions that don't support EAP / Enterprise. When you try to install the full wpad, it should tell you whether it is mini or basic that is conflicting, then remove that one.

Attach the wifi client (link to the ISP) to WAN. Remove any Ethernet ports from WAN. The default configuration is that WAN is a DHCP client, which should obtain a WAN IP and install routes automatically. Some single ethernet port devices won't have a wan network by default, but there is a wan firewall zone already defined, so you should create a new network exactly named 'wan' and it will already be properly set up in the firewall.

1 Like