Connect a TL-WR902ACv3 to EAP/802.1X-enabled network "PYUR Community"

I have these:
-a TP-Link TL-WR902ACv3
-OpenWRT 19.07 RC2
-an EAP/802.1X-enabled network, that I want to connect to (the network does NOT require a certificate)
-user & password for the network "PYUR Community"

What I want to do:
I want to use the Travel-Router, to connect to those "PYUR Community"-APs (or meshes) and share the Internet (solely) to my devices!

Where I am stuck at:
I've got as far, that I found out that I have to uninstall the small wpad and install "wpad"... However... After installing it, I do not have any new options in OpenWRT's LuCi, nor do I have another selection in wireless, if I "Scan" and want to connect to the network.

Am I missing more packages?
Might there have been a fault at the installation, or does it simply not show anything else in LuCi and I have to do it via SSH (or whatever)?

When setting up the wifi client, click the "Wireless Security" tab and choose WPA2-EAP in the first box.

You probably then want EAP-Method: PEAP and Authentication: EAP-MSCHAPv2, as this is the most widely used type, but it depends on the network.

In the first tab of setting up the client, the BSSID box will lock you to one specific AP. You likely don't want that, so leave the box blank and it will connect to any AP with the set ESSID.

1 Like

It does not show me EAP...!

In fact, it doesn't even let me choose the encryption/verification, if I try to connect to a network via "Scan"!

It does show me, that wpad got successfully installed, tho'!

So... I have no clue where to go from here...

Since I can't add 2 pictures, here is proof that it shows me that wpad is successfully installed... (the picture is from System --> Software --> Installed)

I don't use the Join button, instead doing it manually. So I don't know if the join button even supports EAP.

If you want to go that route, you could go ahead and put in something as WPA-Passphrase, then when the join network wizard is done go to Network-Wireless and reconfigure the encryption.


Oh great! It shows me the EAP-Choice now! I don't know, why it didn't before (even after a reboot!)!

All is fine now! I have a stable connection! Let's hope I can share it to multiple devices at once and that it will work "on the go (OTG)" as well!

Thank you VERY much for your help @mk24!!!

Just one note: Previously it blocked me from using a "wrong password" and then I couldn't change the crypto to EAP! I don't know why! Fortunately it works now! I am soooo happy, especially if it works mobile, because these Community-Hotspots are quite wide-spread in Germany and my main-phone has some problems connecting to them, whereas it only takes a short time on the Travel-Router!

THX again!
Is there a like-button (edit: found it)? :slight_smile:

Check that the BSSID under wireless is not set, because that would lock you to one AP rather than being able to use others on the same network.

1 Like

Hm... In the settings, the BSSID-Field is empty...

It also connects to the next "strongest signal" from that kind of mesh/network...

It does not connect to multiple APs at once though... Only one on 2.4GHz and one on 5GHz,...

So... Is there a way to "bind" all APs close to me and use the combined bandwidth and also enhance the "stability" due to it?

Not reasonably, no - and it wouldn't make sense either (as one of them will be more than an order of magnitude slower to begin with, if you're in range for 5 GHz).

Anyway, it doesn't really matter. I am happy with the result! I've got free and fast Internet at home (1080p works on 2 devices simultaneously, or watching YT and surfing or downloading and I don't have to hold my mobile out of the window, lol.) and I don't have to rely on my "Mobile Data", as long as I have either one of the open networks like "Freifunk" around, or if there is a "PYUR Community"-Hotspot (where I can use the login-data).

I ran into a weird problem with setting up a 5Ghz-WiFi/AP, when I am connected to a 5GHz Network though...
I suppose I should create a separate thread for that, but that doesn't matter as well because it even works well, if I connect all my devices via 2.4GHz N-Wifi! :slight_smile:

Can I mark this thread "solved"?