DynDns problem


I'm having problems with dyndns service, it has been working for years with no problems.
That's what I get:

14125 ERROR : cURL Error: '28'
 114125       : curl: (28) Failed to connect to port 443: Operation timed out
 114125  WARN : Transfer failed - retry 4/0 in 60 seconds
 114225       : #> /usr/bin/curl -RsS -o /var/run/ddns/myddns_ipv4.dat --stderr /var/run/ddns/myddns_ipv4.err --interface eth1.6 --capath /etc/ssl/certs --noproxy '*' 'https://elsnyitos:***PW***'

Some info about my device:

root@J1900:~# uname -a
Linux J1900 5.4.86 #0 SMP Sun Jan 3 14:50:55 2021 x86_64 GNU/Linux

Anyone having the same problem?

Many Thanks!!!

Seems that it's not able to talk to the no-ip server. Do you have internet connectivity? Can you do a traceroute to the server?


Hi @Klingon ,

Did you happen to update to the latest snapshot by any chance? I have the same issue if I try to use snapshot (wrt3200acm) with duckdns.

The wrt3200acm has dual boot with one partition on snapshot and the other one on the 19.07.5 and the same config with ddns (I tried different configs as well). If I boot on snapshot it does not work and if I boot in 19.07.5 it works as soon as the router boots up.

Not really helpful for troubleshooting but I thought I'd add it here just in case.

1 Like


My internet is working like a charm.
I can resolve host (IP but no ping.


Hi @kar200

Yes I'm running latest snapshot

 OpenWrt SNAPSHOT, r15409-cbccc2560c

Maybe is a bug affecting ddns service?


I realized there is an option to use curl o not by default, but does nothing, always uses curl.

Maybe the problem is with curl and not with ddns package/service.


After removing curl package, now is working fine:

154609       : sending real IP to ''
 154609       : #> /bin/uclient-fetch -q -O /var/run/ddns/myddns_ipv4.dat -Y off.......
 154610       : '' answered:
good XX.XX.XX.XX
 154610  info : Forced update successful - IP: 'XX.XX.XX.XX' send
 154610       : Waiting 600 seconds (Check Interval)

Thanks everyone for your time and help!!


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

@tmomas the problem is not solved, I did a workaround.

Will be solved when will work with curl again, as always did.

It seems to be related to curl (thanks for the tip). I did not install it and the script worked at the first try.

There are a couple of curl issues related to ddns on github but the last one has been closed. I guess not many people use ddns or were just lucky to not use curl (since it is not part of the base image).

1 Like

The problem (in my opinion) is not only curl, the ddns service has an option to bypass curl and use wget... but doesn't work. If you have curl installed in your system, ddns always will use it (despite of having the option disabled or not).