No Connection to Web-GUI

Hi there,

after some updates my OpenWRT got not accessible anymore by browser (IP I tried to connect is correct, but Error is ERR_CONNECTION_REFUSED).
I already tried some things in ssh:

  • pinging to external ips/FQDNs is running fine, so internet connection is there
root@OpenWrt:~# /etc/init.d/uhttpd status
running
root@OpenWrt:~# service | grep uhttpd
/etc/init.d/uhttpd                 enabled         stopped

netstat shows no port 80, even if it's not accepted directly in iptables (but it's policy ACCEPT).

Restarting uhttpd doesn't resolve the problem.

root@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/releases/21.02.2/targets/mediatek/mt7622/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.2/targets/mediatek/mt7622/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/base/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/base/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/luci/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/luci/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/packages/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/packages/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/routing/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/routing/Packages.gz

Downloading https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/telephony/Packages.gz
*** Failed to download the package list from https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/telephony/Packages.gz

Collected errors:
 * xsystem: wget: Child killed by signal 4.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.2/targets/mediatek/mt7622/packages/Packages.gz, wget returned -1.
 * xsystem: wget: Child killed by signal 4.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/base/Packages.gz, wget returned -1.
 * xsystem: wget: Child killed by signal 4.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/luci/Packages.gz, wget returned -1.
 * xsystem: wget: Child killed by signal 4.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/packages/Packages.gz, wget returned -1.
 * xsystem: wget: Child killed by signal 4.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/routing/Packages.gz, wget returned -1.
 * xsystem: wget: Child killed by signal 4.
 * opkg_download: Failed to download https://downloads.openwrt.org/releases/21.02.2/packages/aarch64_cortex-a53/telephony/Packages.gz, wget returned -1.
root@OpenWrt:~# service
Usage: service <service> [command]
The following services are available:
/etc/init.d/boot                   enabled         stopped
/etc/init.d/cron                   enabled         stopped
/etc/init.d/dnsmasq                enabled         running
/etc/init.d/done                   enabled         stopped
/etc/init.d/dropbear               enabled         running
/etc/init.d/firewall               enabled         stopped
/etc/init.d/gpio_switch            enabled         stopped
/etc/init.d/led                    enabled         stopped
/etc/init.d/log                    enabled         running
/etc/init.d/network                enabled         running
/etc/init.d/odhcpd                 enabled         running
/etc/init.d/rpcd                   enabled         running
/etc/init.d/sysctl                 enabled         stopped
/etc/init.d/sysfixtime             enabled         stopped
/etc/init.d/sysntpd                enabled         running
/etc/init.d/system                 enabled         stopped
/etc/init.d/ucitrack               enabled         stopped
/etc/init.d/uhttpd                 enabled         stopped
/etc/init.d/umount                disabled         stopped
/etc/init.d/urandom_seed           enabled         stopped
/etc/init.d/urngd                  enabled         running
/etc/init.d/wpad                   enabled         running

Any ideas what I can try next?

reset the device, by running firstboot from ssh.

This will reset to default I think? Do I have to set up network and so on again?
Right now, I've got no hardware access to rewrite the network config.

yes it will reset the device.

you could make a backup of the settings, then reUL them after the reset.

Signal 4 is SIGILL (illegal instruction) - it seems various executables on your system utilize machine code instructions not supported by your CPU. This is probably a bug in OpenWrt unless you run the system on a not yet officially supported device.

I'm afraid there's not much you can fix configuration wise, the software probably has to be patched or recompiled for your target.

Did you try the current 22.03.0-rc1 release yet?

No, am just running on 21.02.3, as I am using the UniFi 6 LR.

Which settings are the one that I need to save?

The ones you changes/created - commonly the following files in /etc/config

  • network
  • wireless
  • dhcp

So, these are all the files changed with my configuration via gui? I thought that would be much more...

Again, I noted:

So did you install other apps...etc.?

(We cant guess.)

  • I see GPIO...
  • Have you ran ls /etc/config ?

I installed some translations and so on - but I did all over the gui, nothing directly in the configs.

root@OpenWrt:~# ls /etc/config
dhcp       dropbear   firewall   luci       luci-opkg  network    rpcd       system     ucitrack   uhttpd     wireless

Should I backup all of them?

I ran the following command I found:

/usr/sbin/uhttpd -f -h /www -r AP -c /etc/httpd.conf -x /cgi-bin -u /ubus -t 60 -T 30 -k 20 -A 1 -E /cgi-bin-404.sh -n 3 -N 100 -p 80 -i .sh=/bin/ash -I cgi-bin-404.sh -C /etc/uhttpd.crt -K /etc/uhttpd

After that, the gui was accessible (as long as the command ran).
Now, I did a firmware upgrade over the gui. This has fixed the issue and the gui is accessible by default.