Newifi D2 Terrible WiFi Performance on OpenWrt


I'm experiencing terrible WiFI performance on my Newifi D2 running on open-wrt 19.07.3. The WiFi speed is performing well. It's just the WiFi signal strength is very weak. This applies to both 2.4ghz and 5ghz. I also tried using version 18.06.8. I'm also getting terrible WiFi performance. I've switched to padavan for now. The WiFi works perfectly on it but I would still like to use OpenWrt.

I also read this topic and saw there's no solution yet.


You are contradicting yourself:

Can you please clarify?

Apologies on that. What i meant was that I'm able to get good speeds when connected to WiFi however the range of the WiFi is terrible. When using OpenWrt, The WiFi signal doesn't reach our home downstairs. That's for both 2.4ghz and 5ghz. However, when using padavan the WiFi's range is able to cover the whole house. That's for 2.4ghz. I understand that 5ghz has a shorter range.

I have a Newifi D2 router and the same problem. Very low signal level on all versions of OpenWrt.

Padavan SSID: ASUS. OpenWrt 19.07.3 SSID: OpenWRT

Phone and router did not move relative to each other. The distance between the phone and the router is about 3 meters and a brick wall 30cm.

Adjusting the transmitter power has no effect on the signal level. I can set 0dBm or 27dBm (and any in-between), but I will get the same signal level. Perhaps this has something to do with the low signal strength on OpenWrt.

There have been some updates to MT76 since 19.07.3 was released:;a=commit;h=479f1f2c92f6b7e75f945cfdb2214b609a92b692

The latest MT76 has the same problems with weak signals.

This seems wrong to me.

cat /sys/kernel/debug/ieee80211/phy0/mt76/rate_txpower
       CCK:  0  0  0  0
      OFDM:  0  0  0  0  0  0  0  0
      STBC:  0  0  0  0  0  0  0  0  0  0
        HT:  0  0  0  0  0  0  0  0  0  0  0  0  0  0  0  0
       VHT:  0  0  0  0  0  0  0  0  0  0

I have the same problem. The area of the wifi signal is not so good. Additionally my phone (with Android 10) connects everytime to the 2,4G network and reconnect sometimes. The SSID of the 2,4G and 5G networks is the same. I didn't had these problems with an unifi AP.

there is a new eeprom. Will this change anything?:

From OpenWrt firmware upgrade page dump the EEPROM partition 'factory' to disk
Then edit the following lines using a hex editor
Save the changes to a new file
Replace the factory partition using kmod-mtd-write
Reboot the router

1 Like

Could you provide a more detailed step-by-step on this? Thank you! I saw your github page containing the bin files for the factory firmware.

I'm sorry if this is not the right place to ask, but bought a used newifi d2 but the seller did not include the power adapter. I would want to know the outer and inner diameter of the AC power adapter you guys are using, as I am looking online for a replacement power adapter, but I don't know the correct size of the plug. Thanks!

I have been experiencing a similar issue, more on what my router shows on this thread, if there is a solution, I would be very happy.
Also, if possible, please explain further the problem and solution, I think everyone here wants to learn more, and it's always a good thing to understand what you are doing.

1 Like

on my router it was the standard 12V plug that comes with this sort of devices, 5.5mm outer diameter

has anyone tried this eeprom image? my device still presents problems with the openwrt snapshot.

I followed @gwlim instructions and the wifi range is noticeably better now. And new power levels appeared for 5GHz, up to 23dBm.

Can you elaborate? I did a live dump and the said lines are already there (19.07.4), do I need to delete them or smth?

Left is the dumped EEPROM from my Newifi D2, right is after the modification.

May I ask what tx power values you've got? These are mine:
Zrzut ekranu 2020-12-09 144739


Although I doubt they are real.

Both my 2.4 and 5 ghz go up to 20dBm

interesting, can you run this command iwinfo wlan0 txpowerlist for me please?

also, I will be updating to this eeprom and checking to see what happens

sadly, nothing changed, and I forgot to backup the one that came with my device, so no idea as to the actual difference that would have made.