Newest snapshot killed my EdgerouterX

I know snapshots are for advanced users and what not... but I upgraded from a previous snapshot image from a month ago.

So now my ER-X is a paperweight, I thought it would boot and wait for image? like a typical Uboot device... or atleast like my fleet of WNDR3700/3800/4300s

any way I can flash this through LAN? without having to JTAG it back to life?

Start by reading up the wiki page for your device.

1 Like

I may no post a lot here, but I've been using openwrt a lot over the last 3 years and got this router for the sole purpose of running openwrt since 2018 17s builds, 18 builds 19.07s... always I upgraded saving settings.

So when I post something is that I need genuine help, this petty post of yours is of no help...
and yes I read the page... that's why I'm asking,

ubiquiti tftp to eth0 didn't work, and all the options in that page are JTAG based...

Actually, @slh did provide a helpful page. There is information about serial + tftp recovery and many other things there, including an update from April 2020 (i.e. within the last few 10 days) that links to a blog post and an initramfs image that is accepted by the ER-X and may be useful to get you back up and running.

Beyond that, it is worth noting that you did not provide any detail about the image you were using, the image you flashed (that failed), what the symptoms are now, and what you have done to try to troubleshoot.

The fact that you upgraded while keeping settings may be part of the issue. Failsafe + firstboot may solve this, but again, you didn't say if you had done any troubleshooting or anything else.


I don't have a JTAG/ttl cable

all I see is that it boots up, the switch turns on cause I see my router name popup instead of the openwrt network, and turns off

I tried pressing the reset button, it flashes the eth4 light, then turns solid, after that it reboots...
with this I figured it the flash is fried...

again this is something I can fix on other uboots like the WNDR routers I mentioned...

so I turn it on again, look up the details, ubiquiti mentions to boot it with certain parameters, I punch those parameters in and it blinks, but the soc apparently isn't replying back, cause the tftp does not progressed and the unit reboots in a few seconds... and that's all it does

I've reflashed snapshots without erasing dozens of times during the spans of months and nothing happened... on the wndrs... but this one after I switched to snapshots, all was cool, and on the first upgrade to another snapshot, it died

I will try the LEDE image specified on the page, but I upgraded to 19.07.1 and then 2 nothing weird happened

These are two different things. You mentioned JTAG, you didn't talk about serial. You might want/need to get one -- they are cheap (~$5 US and up) and available on Amazon and likely many other online retailers.

What does this mean? Where do you see it "pop up" and what do you mean it "turns off"

I really don't understand what you mean buy punching the parameters -- how are you doing that? what parameters are you entering?

Do you get a DHCP address when wired directly to the device? If not, have you tried setting an address manually in either subnet or the last known one that you were using?

Have you tried pinging your router, starting from the moment you apply power?

Have you tried entering failsafe mode?

ramips/mt7621 snapshot just updated to the 5.4 kernel - a big change, and not immediately helpful for you I know, but it is information.

Ubiquiti recently provided a boot loader upgrade to support TFTP recovery. No help if you didn't upgrade before loading OpenWrt, but it may help you to understand which boot loader you have on your EdgeRouter X - the old or the new. I installed the new boot loader before changing to OpenWrt on my EdgeRouter X and after bricking it some time ago, I succeeded in recovering it to an old EdgeOS version, then I could flash a working OpenWrt build from there.

See here for the new boot loader:

And if you have it, here for TFTP recovery:

Sorry I can't offer more help.

1 Like

The 5.4 bump is still very fresh and it's been causing issues for multiple people (I myself have a DIR-860L B1 that breaks with it, and the DIR-878 A1 doesn't look much better). Someone reported his R6220 broke as well, but the mailing list is down, so I can't link. You'll find some info in the PR though:

Like you, I have no serial so ATM I'm grasping at straws (but the u-boot on both my devices has a built-in recovery).

1 Like

well, it was still the 1.something.something before flashing to OpenWRT, seems I'm SoL...
2.0 builds weren't even alpha by the time I initially flashed... damn... well, I know now why it probably failed... I already started buying a jtag connector.

yea I've been using the Tftp and I'm here like... why doesn't this work... that's probably why.

Kernel 5.4, wow... wasn't aware of that development.

5.4 brings DSA instead of the old switch layout so you'll definitely brick your device by keeping settings.

If you like to run master, you need to keep an eye on what's going on with the code (mailing list, or the git tree). I hope you manage to recover it, but if this is your main router you should be a bit more careful than blindly flashing master builds.

1 Like

this is what I'm fearing, cause briefly when it boots, I see the modem network name popping throught instead of the Openwrt network name.

You do not need, nor want a JTAG adapter, you need a 3.3V USB2serial adapter for a tad over 1 USD/ EUR if you can wait (4-8 weeks) for shipping from China or around 5 USD/ EUR if you need a local seller, who'll get it to you within a day or two. The two are very different, in functionality, pricing and ease of use (your device seems to have a serial header pre-populated, so all you need to do is opening the hood and connecting the three cables of your 3.3V usb2serial adapter to the board and follow the linked description).

1 Like

Have you tried factory reset with the reset button? Press and hold it for ~5 sec

1 Like

As it seems to do on multiple mt7621 devices, if you read my previous post. That's a mere coincidence, not a correlation.

yes I did, nothing, it's probably bricked

The PL2303 adapters often contain the old version and/or counterfeit chip which does not work with Prolific's Windows driver. So don't buy that one if you use Windows. They are fine with a Linux PC though.

I got a laptop with arch, thanks for the heads up

Tried yesterday's snapshot build. It's still broken, badly. The kernel will not boot from flash due to the bootloader being unable to uncompress it.

3: System Boot system code via Flash.
## Booting image at bfd40000 ...
   Image Name:   MIPS OpenWrt Linux-5.4.31
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    2433965 Bytes =  2.3 MB
   Load Address: 80001000
   Entry Point:  80001000
......................................   Verifying Checksum ... OK
   Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover

This is with the new bootloader. The initramfs image does boot up OK.

I'm using my own snapshot builds - this works fine, e.g.:

Of course, you can't migrate/transfer the network settings ...

1 Like