EdgerouterX with latest Snapshot


I tend to flash the latest snapshot of OpenWRT every month. However, with the snapshot of May 1st names ubnt_edgerouter-x-squashfs-sysupgrade.bin. The router did not come up in its previous state. I thought the flash was bad, so I connected to the serial port and flashed again with TFTP. I got to a working system, but the system state was surprisingly "bare" even for a snapshot. Other snapshots had VLAN and WAN preconfigured. This snapshot just used a single lan interface for all 5 ethernet ports, DHCP seemed to be non-functional. I tried to upload my backup configuration, but that left the router in a state without networking.

I found Newest snapshot killed my EdgerouterX, which might be related. Can someone comment on the current state for EdgerouterX?

PS: For now I am back to 19.07.2. I remember I started the snapshot dance since I had some other problems, but I forgot what those were :smiley:

Since snapshots are nightly builds unfortunately these problems can occur. Stick to 19.07.2 if you can or try again when a new snapshot will be released.

1 Like

I think everything is due to the new DSA architecture, I was on your same boat. No DHCP to get IP from my ISP. Thanks to DSA you will end with the new lan interface for all your ethernet ports.

I ended cloning 19.02-SNAPSHOT and compiling it with some ctinfo patches I needed for DSCP marking. That worked as expected and at least I have some of the new patches in that com with 19.07 "beta" snapshot.