Newbie with GL-AR750S-Ext

Same here. I tried it several times, every time openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin flashed fine but trying to flash openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin the lights stopped flashing a bit too quickly and then I couldn't get ethernet to connect, had to go back to uboot and reflash NOR to get anything working.

When flashing fails, should I expect to be able to recover any error log somehow, or is it more of an "either it works or it doesn't" kind of thing? I hope somebody figures this out eventually. It seems pretty consistent that we're all seeing issues only with NOR-NAND.

If you flash nor nand using the stock firmware advanced settings, does it work? If it doesn't, try what I did

  1. Go to uboot and flash openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-nand-initramfs-kernel.bin (do note that this version of openwrt only saves changes in ram, changes will be lost after reboot)
  2. Go to uboot again and this time flash the stock firmware
  3. After that, go to advanced settings and go to the stock's firmware luci.
  4. Go to system > backup / flash firmware. Under flash new firmware, press the button "flash image" and flash your nor-nand flash copy glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin [NOT KERNEL]

This worked for me, I guess I did it by accident or it was what I was instructed to do by frollic.