Newbie with GL-AR750S-Ext

Keep the AR750s. The Beryl has only a single physical radio (MT7615D). Mediatek has developed a DBDC mode - in theory the radio should serve both bands at the same time. This not only comes with a performance penalty, but the current driver support (even in master) is still a bit shaky.


Agree. The AR750S has the same 2.4Ghz chip as the C7 v5 (?) and is stable on 2.4Ghz on vanilla at this time.

1 Like

No! :wink:
ATM, just a quite good one for traveling. Two (supported) radios, enough FLASH/RAM, nice form factor, sd card support ... and easily powered by a USB power bank. A good choice IMHO.

Edit: I've answered the first rev. of your post!

1 Like

dude wtf. I'm not a Win10 lover either but how is changing the OS on his laptop going to affect anything.

In case a device has a strong dislike for a specific browser or your current browser has cached some garbage and this is a problem is to try with a different one. So if you always used Firefox try using Chrome, or Windows Edge, or Internet Explorer.

Scenario 1:

Have you ever tried using an older WIN10 box? Turn it on. It needs to do 2 days of updates (I have had this happen). Did you need to use it today? This week? Try to open chrome edge. Nothing responds. 2-3 mins later it opens 5 instances.

Would you try using that to flash openWRT on something? Literally useless. Install ubuntu on the same machine in under 20 minutes. Boots up in 10 seconds. Rock solid.

Scenario 2:

You have a newer WIN10 box. So do I. So does user @memilanuk. User @memilanuk has been trying to flash an AR750S for days now, dozens of attempts using 2 different (new) WIN10 machines. Almost all failed. What if WIN10 decides to start updating, sending telemetry or reboot during flashing?

I recommend he try ubuntu. Bet it works on the second try.


If a VM or live usb would work, I might give it a try. Otherwise I'm not reorganizing my life for the sake of flas0a travel router.

I've been using Linux off and on for a fairly long time, including a few stints as my 'daily driver'. I'm familiar with the benefits and trade-offs of running it on my laptop - and the answer is 'no'.

Dude stop, this is not related to his issue. Web browsers and network protocols work in the same way, and that's all that matters for this thread.

I already said, at most it's a "the current browser is screwed up for some reason" and using a different browser works around it.


Can you stop sending me rude messages? How you connect to your router is up to you. Keep openWRT fun.


If a user is sending you inappropriate or off topic messages you can mute them under 'users' in your account.



On topic, how many AR750S do you have again @bobafetthotmail ? I have 4 in a mesh with over 100h testing and configuring. Solid routers.

I too, just purchased a GL-AR750S-EXT (a.k.a. Slate), and am about to undertake the same path to install OpenWRT (well, one from here, as I understand there is a GL.iNet version of OpenWRT already installed on the device). It took a while to wrap my head around this thread and references to other pages from this thread, but I believe I can conclude the following:

Based on this thread (please correct me if I'm wrong), it appears I have a couple different options for installing OpenWRT on the GL-AR750S-EXT.

Option 1: go with the "Current stable series" (19.07+) of OpenWRT


Option 2: live life on the edge, with the "Next stable series" (21.02+)

Among other differences, sounds like 19.07+ only supports running out of NOR flash, but that 21.02+, allows using NOR flash and NAND flash.

Sounds like either path is best accomplished using the uboot method (power down, ensure only 1 network cable is plugged in, hold the reset button, power on, wait until the led blinks 5 times and stays on, then release reset button, etc...), detailed a bit more on the "oem_easy_installation" web page referenced above.

If I go with Option 1, sounds like I will use the "vanilla" (a.k.a. "-generic-") binary image. "16F84" seemed to suggest that to get to the latest build on the AR750S (19.07.8), I should first use the uboot method to install 19.07.7 (to avoid the unsupported format warning message/installation failure), and then upgrade through LuCI to get to 19.07.8.

If I go with Option 2, sounds like I will use the uboot method to first install the "-nor-squashfs" (NOR only, but "NAND aware") binary image, and then use LuCI to upgrade to the "-nor-nand-squashfs" binary image (and any/all subsequent upgrades). Though having said that, "memilanuk" expressed reservations with the 21.02+ path at this time, though I think because package upgrades were applied, that probably shouldn't have been. Installing "-nor-squashfs" followed by LuCI-based upgrading to "-nor-nand-squashfs-" without any further updates found on the 'Software' page, may be ok.

Regardless of which path I take, the "firmware selector" (16f84 provided a link, above) has the various images, based on which release I wish to move forward with.

Pleased to report that I did Option 2 - as "16F84" indicated, went from out of the box to 21.02 in less than 15 minutes, with no issues.

Many thanks to memilanuk and Budoka for blazing the trail, 16F84 for giving me the courage to just go for 21.02+, and bobafetthotmail for keeping us between the lines!


21.02.0 has become "current" in the meantime.

Hello, another new guy here :slight_smile:

I can confirm a successful flash of OpenWrt 21.02.1 on my GL-AR750S (which I purchased Q3 2021) via the two steps described by bobafetthotmail (thanks!) here or here. Or "Option 2" as johngo said it ^^ .

The stock firmware version of the device was OpenWrt 19.07.7 r11306-c4a6851c72 and now I'm running OpenWrt 21.02.1 r16325-88151b8303

I have to say that I was a bit confused after reading the wiki page for the device and looking for the files. I had to do a few searches and then found this thread. Here the steps I followed, summarized for the next newbie :sunglasses: :

  1. Booted the device in uboot recovery mode as described here.

  2. Flashed via the Uboot Web-UI (which was reachable from a "normal" linux machine) the NOR openWRT firmware: openwrt-21.02.1-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin. That took about 2 minutes.

  3. After resetting the network settings I opened in a web browser and was greeted by LuCI.

  4. I flashed via LuCI the NOR-NAND firmware: openwrt-21.02.1-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin. That took about 3-4 minutes.

And it was done! After the 2nd flash I had to clear the cookies as mentioned here, otherwise LuCI wouldn't let me in. The device was acting a bit funny afterwards (like not showing DHCP leases), but following a reboot it's working fine so far :slight_smile: .

So overall it took me 15 min to flash the device, and a couple of hours to find the right info and files :sweat_smile: . So yeah, the wiki device page should probably be updated/revised.

Thanks everyone!


Hi @Air1,
Are you running GLi's web UI and their other packages from the OEM firmware on 21.02.1? Are they stable?
I'm looking at doing this and was wondering if I'd need to install using the kernel image to clear them out first.


Hello @LewisSpring,

no, I'm running vanilla OpenWrt 21.02.1 - apart from the config I didn't modify the installation so far. I used the OEM firmware for a couple of days and OpenWrt now for about 2 weeks, both have been stable.

So if you're trying to run OEM UI + packages on OpenWrt 21.02.1 I am sorry, I can't provide any info on that. I suppose it ain't easy though...

If you still want to try it, you should look/ask on the GL iNet forum for more info, that's probably the better forum for this. Good luck!

Thanks for your reply!

In that case, I'll start from scratch and copy configs - just to minimise risk.
Thanks in advance for your tutorial!

Good Morning @Air1,
Thanks again for your instructions! They worked perfectly, no issues at all.

1 Like

Hey, I am another newbe trying to flash this.
But after flashing the NAND version from lucy, I cannot connect anymore via LAN.
(Resetting to the pure nor image works).
Is there anything I have to take into account to flash from luci?

It's possible to build your own image using the glinet image builder. However, I also use OpenWrt 21.02.1 since a couple of weeks and I noticed it's faster and more stable. I run AdGuard on it without any problems and I had to install some additional packages to make USB tethering possible.

I`m thinking of adding this to GitHub as a package builder source with these base packages in place, so I can easily switch to a newer release of OpenWrt (now f.e. 21.02.2) without having to flash it, install packages, configure some basic stuff.

Anyway, long story short, it would also be possible to build it with the GL-iNet UI in place, but you have to have some knowledge about the image builder process. Luckily there's a lot of info available regarding this topic how to do so.

@benneti no, after flashing the NOR firmware and logging into OpenWrt I flashed directly via LuCI the NOR-NAND firmware and it worked right away. Check if you

  • downloaded the right file (also verify integrity)
  • the device is behaving like expected: is the power LED blinking when booting the device? See entering failsafe mode for more info.
  • have correct network settings on the LAN interface of your client (Automatic / DHCP). Also bringing the interface down and up helps sometimes.

Also: The current available version is 21.02.2, I flashed version 21.02.1, you could try the .1 version to be on the safe side, but I doubt that's the issue.

Thanks for the reply. Thats strange I tried both versions but neither
worked while nor
worked with no problems.
Not working as in dhcp did not assign me a address on the lan port.

Reading the failsafe article it might be that for some reason it booted to failsafe mode.

Anyhow I replaced the device now (with beryl) because I got annoyed and was able to set everything up as I wanted.

@benneti I'm seeing the same issue that you did with the 750s. Sometimes after flashing the nor-nand image it seems to get into a boot loop (ethernet will connect, but no http or ssh) and other times the power LED will just get very dim.