Newbie with GL-AR750S-Ext

So... new guy here :wave:

Picked up a GL.inet AR750S-Ext earlier this year, and it worked well enough... for a while. Now it's getting increasingly unstable (drops wifi entirely, lucky if it lasts a couple hours) and it was suggested to me to give it a new lease on life by using regular OpenWRT, rather than the vendor-provided version.

After a bit of digging around, and a bit of trial-and-error, I've reset the router and brung up the uboot interface, following the directions here. After some more trial (and mostly error), I ended up downloading a 'clean' version of OpenWRT from GL.inet here, and got it flashed to the device.

So now, I have an old-ish release (18.06.0-rc1 r7090-d2aa3a1b62 ) installed. I thought the next step would be to use the LUCI interface to upgrade using a sysupgrade.bin compatible firmware file. I based that off of information here, here, and finally the ToH: FW Download page for the AR750S.

In theory, it seems like I should be able to upgrade to 19.07.8, using this firmware( but I get a warning message that says: The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Pretty sure that's the generic image for a GL AR750S... it literally says so, right in the file name. So what am I missing here? What do I need to do next?


you should probably skip the "clean" version from gl.inet, and go for the proper openwrt release straight away, based on the installation info in the wiki.


It says on the device page that this error is known and that you should use uboot to install

This device has two storage chips, a NAND (bigger) and a NOR (smaller).

OpenWrt in release 19.07 only uses the NOR (smaller) chip so you may only see 16 Mb of space.

If you want to use also the NAND chip you need to upgrade to current OpenWrt release candidate, from the files you find here


see this commit for some more information

1 Like

That'd be great... if I could get any other version to install straight-away. That was a lot of the 'trial and error' I mentioned above :wink:

If you want to use also the NAND chip you need to upgrade to current OpenWrt release candidate, from the files you find here


Yup. Saw that one - it's what I'd really prefer to end up with. But it doesn't want to play nice - kicks back with exactly the same error message.

It says on the device page that this error is known and that you should use uboot to install

Since you can't seem to read the right part, I'm copy-pasting it here

As of OpenWrt 19.07.4, gl-ar750s-squashfs-sysupgrade.bin still gives an unsupported format error on the web UI and sysupgrade command, but works fine through the router's debricking interface: power down, ensure only 1 network cable is plugged in, hold the reset button, power on, wait until the led blinks 5 times and stays on, then release reset button. Change your IP to and connect to, where you can upload and flash the sysupgrade.bin image.

Fair enough. When I came across the error, I carried on to the next method that didn't spit back an error.

Just to be clear... I need to re-do the uboot process, with the nor-nand firmware, and push on past the error message saying that it's not the right image?


The documentation on the wiki is talking only of using 19.07 firmware image, but yes.

You can use OpenWrt firmware upgrade to do the newer image later.

1 Like

Alrighty. Got it up and running the 19.07.8 firmware :+1:

Now for the next step.

but when I try to upload the new release firmware that I downloaded from, I get the following error message:

Device gl-ar750s not supported by this image Supported devices: glinet,gl-ar750s-nor-nand glinet,gl-ar750s-nor Invalid image type. Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

This device is in a bit complex situation because of multiple changes between versions so please bear with me.

From what is said in the commit I linked above, I think the right process in your case should be to install glinet_gl-ar750s-nor-squashfs-sysupgrade.bin first (from the same folder you downloaded the other file), as this is the updated OpenWrt image that uses only NOR chip like the one you have installed, but it knows that the NAND chip exists.

After you have installed the OpenWrt firmware that runs from the NOR chip and also knows that the NAND chip exists, you can install
glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin so you can use NAND chip too.
This should not complain about unknown images and should let you go without errors.

If when installing glinet_gl-ar750s-nor-squashfs-sysupgrade.bin it still complains, it's probably because this device was migrated to a new target (it went from ar71xx to ath79), and the changes are not compatible. All devices from ar71xx were migrated due to technical reasons (much easier to add and maintain the devices in the newer device format) but this causes that error when upgrading.
This is the generic instruction page about this change

So if you got that error with the glinet_gl-ar750s-nor-squashfs-sysupgrade.bin you probably need to install that image from uboot web interface like you just did, and then from OpenWrt you can upgrade the firmware with the glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin

If you confirm the steps you followed, I will update the wiki page with a "migration to 21.02 release" installation tutorial with this information so next guy will not need to come here and ask again


Okay... that was kind of what I thought from the github page (the broad strokes, not the details!). Wasn't sure if I could get away with installing the 'nor' version from LUCI, or if I needed to go through the uboot shuffle again.

Alrighty... think I got it. Loaded the 'nor' firmware directly from LUCI - figured why not, if it breaks I'll just use the debrick / uboot procedure :rofl: and then upgraded from there to the nand-nor version, with no complaints / warnings either time.

I may go through the whole process again tonight, just for the sake of documenting the steps.

that's what (I think) I said.
install glinet_gl-ar750s-nor-squashfs-sysupgrade.bin and then glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin after it using normal Luci firmware upgrade page.

I added more stuff about how to react to potential errors because I was not sure it would "just work", but that was the procedure stated in the commit I linked above.

Anyway thanks for confirming, I'll have to add this to the wiki then

1 Like

I wish I had seen this thread yesterday!

I purchased the same device this week and not realizing that it was so complicated to reflash the OpenWRT firmware went ahead and did the following (Please note this was before finding this thread):

The glinet stock firmware prompted me to update. Which I did successfully. Sorry, I can't remember which version it updated to but it wasn't 21.02.0-rc4. After this was completed I noticed that the updated firmware gave me the option to install Luci which I did successfully.

Then I downloaded glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin. I selected that in the update firmware option in Luci. It did not generate any of the errors noted in this thread and appeared to upload safely. Then I got the do not power off your device flashing firmware message. Then nothing. The router was bricked.

I've had it replaced with a new one and I really would prefer to have the most recent vanilla OpenWRT installed vs the glinet version. I see you referenced a WIki page but the only page I can locate on the site is the general GL-AR750S, gl-ar750s, which is "under construction". Is there a Wiki that outlines step by step for newbies how to flash the firmware to this particular model? The order of flashes you outline, (glinet_gl-ar750s-nor-squashfs-sysupgrade.bin--> glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin), is this through the Luci flash update menu item? This is my first use of OpenWrt. I am not sure glinet will be so willing to replace it again if I brick another one. The only reason they replaced the previous one was that I was trying to update through their menu items. Thanks

Did you use the uboot recovery to debrick it? All GL.inet devices have integrated web recovery so you can debrick them, see their own documentation

Given what you did (flashed wrong firmware image), the device should have been recoverable with that.

No. It seems the people that added firmware to OpenWrt did not write the wiki page with the documentation for users.
I have read the descriptions that developers left in the commits when they added this device, to give help to the other guy.
I will have to add the install instructions to the wiki when I have some time.

For now I am the instructions. :rofl:

That is the order for the other guy that had already installed OpenWrt 19.07 from the uboot recovery.

You have stock firmware. If you do that from Luci you probably see an error like
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.
when trying to flash glinet_gl-ar750s-nor-squashfs-sysupgrade.bin.
as the other guy in first post.

Since you are starting from stock firmware I think you should

  1. install OpenWrt from the uboot recovery (see instructions from link above) and give it the glinet_gl-ar750s-nor-squashfs-sysupgrade.bin file, if the recovery page asks NOR or NAND firmware you choose NOR firmware.

  2. Then after that is installed you can connect to OpenWrt and use Luci to install glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin.

After this first install, when you want to upgrade firmware again in the future you should still use firmware like glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin that have nor-nand in the name

1 Like

Yeah... I'd stay away from the 21.02rc stuff for now.

Applied the updates listed on the 'Software' page, and things went down hill from there.

Now I can't even get thru the debricking procedure to put it back to a stable firmware :confused:

That is not a thing you should do even with OpenWrt releases. Although with a proper stable release there should be less upgrades than in a Release Candidate stage.
Please read this

Packages on OpenWrt exist mostly to let you add functionality to your device, not to upgrade the whole system.
You should update specific packages if you know you need it, otherwise the best way to do system upgrades is to download an image and do a firmware upgrade.

I'm not saying it's "a good thing" or that "you are using it wrong". I would prefer OpenWrt package management was more advanced and didn't just blow up like this, but this is what we have.

Some other threads about it

That's what someone else told me (albeit after the fact).

Seems kind of weird that you go into the Software page, and hey, there's a tab for Updates. Keeping software up to date is Very Important, right? Especially security-sensitive stuff like routers and firewalls... :roll_eyes:

Apparently everywhere else but OpenWRT...

Anywho... now I've got this lovely paperweight, shaped kinda like an AR750S, that I can't even get to the debrick page. Any suggestions?

Did you already try a factory reset?

Otherwise you can only try connecting to serial debug pins and see if the bootloader is at least still alive and you can recover from that

Although it's a bit strange that uboot recovery does not work. even if OpenWrt kills itself it should not overwrite that partition.

Stressing the if you know you need it part.

You need to upgrade packages if there is a security issue.
In this case, a security advisory should exist in the wiki, e.g., with instructions how to upgrade affected packages.

If there is no security advisory, or any other instructions to upgrade a package, then there is probably no real need for it, and you should not blindly upgrade all packages, just because you do this everywhere else.

1 Like