Newbie trying to make raspberry pi 400 into a router

I have the hardware now with UE300. I created the SD card as described at the pi page, the terminal method. The boot is successful but I have no luci, is this how it supposed to be? I thought that the 21.02 has luci with pi since it’s not snapshot.
If this is how it’s supposed to be then I proceed setting it up but I guess that’s when I’ll be really stuck unless I will have Internet over the Ethernet to get that losetup to expand the storage and to get the thing for the UE300 :grinning_face_with_smiling_eyes:

OpenWrt doesn't have a web browser or built-in GUI -- it has a web server that you connect to from another device that does have a browser (i.e. a computer, phone, tablet, etc.). LuCI is the browser based interface that you will see when you point your computer to http://<openwrt_device_ip_address> (this is for the default installation).

1 Like

I see, thanks, changed its IP and now I can access via browser. Currently struggling to get internet on this thing to install the kernel module for the UE300. The pi is directly connected to the ISP modem via its own Ethernet port. I thought that this’ll be enough but the pi network tab only shows LAN and adding a new interface with eth0 makes no difference or I would say I’m doing it wrong :smiley:
Still searching for the the solution,I’m sure I’m not the only retarded who can’t do such an easy task :crazy_face:

You're connecting LAN to LAN, unless the modem's bridged.

You could set the built in port to WAN, then use console to install the required packages, or DHCP client.

1 Like

Yes, apparently I set it up correctly it just needed a reboot to work. I installed the kmod-usb-net-rtl8152 since but if I connect via the UE300 I can’t access the pi with luci. On the pi boot log it’s there as eth1 though. Do I need to do something else? I guess I have to find the commands to setup interface
I’m sorry that I can’t copy logs here to show enough to get help

If the usb ethernet adapter is detected to late, the web server might not bind to the new interface, since it starts to early.

Try restarting the uhttpd from ssh, after the pi booted.

Now it’s even worse :sweat_smile: I can’t access luci even via the pi Ethernet port. I can’t believe that I’m this lame

If you connected lan to lan and didn't disable the DHCP server there will be problems through the whole network.

Now that you have two Ethernet ports, set the new one to be the wan network

config interface 'wan'
    option device eth1
    option proto dhcp

and connect the USB adapter to your home network. This will be used for Internet access. Connect the built in port (eth0, lan) only to your PC.

1 Like

It says permission denied, I tried this before. Just found the command list about half an hour ago

Can I save this or reset?

I'd reset.

Edit the /etc/config/network file and add those lines.

Ok I’m after reset, luci is back after the IP change obviously and changed the lan at the interface and added wan to have internet to install the kmod-usb-net-rtl8152. But still no permission, how to edit what you are saying? Sorry I don’t know how to screenshot the pi screen so here’s a camera pic

You are just calling the file alone (which is not executable). You need to call an editor like vi or nano if you want to do your edits directly.

vi /etc/config/network

Or use the uci system to make your changes.

I see you deleted your post about editing the file directly. Check out tutorials / guides on the vi editor if you are directly editing the files. That said, uci might be the easier way for you to do this.

Thanks! However I can’t get out of it, I edited the line and pressed esc and wq but it says q is not implemented

So many guides are open in my browser but I typed probably wrong the commands because it didn’t do nothing that’s why I thought that the editor might be better . Unbelievable that I can’t do such a simple setup correctly

Make sure you follow the syntax - the colon ( : ) is very important.

You also need to change the network.lan.device to br-lan instead of eth0. In the screenshot eth0 is connected to three things (br-lan, lan, and wan)-- it needs to be exactly in one.

1 Like

Ok guys I can’t thank enough for your patience, I edited like this but still don’t know how to save and exit even though the guide is front of me. I started this 10 hours ago, it’s a 10 mins task for normal people….

Did you read the vi guide?