Newbie trying to make raspberry pi 400 into a router

Yes, I’m finally out! I wasn’t using the : because I repeatedly mistyped…let’s just say I’m tired not retarded :crazy_face:

Now I’m going to plug into the UE300

Ok this is how it looks like now, I can’t access it via luci though so I don’t know if it’s normal or not

You need to access luci from another computer that is connected to the openwrt lan network. You cannot use luci on the pi directly.

Yeah I learned that earlier. I typed the IP on my iPad when it was connected to the pi’s Ethernet port and worked but now it’s not but if I understand right I need to connect to the pi’s Ethernet port the WAP to access luci. Which is not even prepped, it’s still my router with 19.07 version but now the pi is ready to be a router with UE300 as wan and the pi’s Ethernet port as lan?

I am finding it hard to follow how you are physically setting things up. Maybe a diagram would be useful.

I’d like to use my old 1043nd router as dumb AP/switch that’s why I needed the UE300 to have 2 Ethernet on the pi 400. So the ISP modem will connect via the UE300 to the pi and the pi’s now lan to the 1043nd so I can have more Ethernet ports and WiFi. That was a recommendation here back in summer but I just managed to jump on this now, and reading this thread I indeed look mentally retarded , when I’m nervous and tired I’m dumber than normally. If it was Reddit people would ignore posts like this or burry me alive. I can’t thank enough the patience here. Here in Europe it’s evening and I’ll continue the AP part tomorrow but at least now apparently I managed to get the pi right, tomorrow we’ll see if there is internet on it :sweat_smile:

I’m still not really clear on what you are doing. Can you draw a diagram (on paper), then upload that here using the little picture icon at the bottom of the text box field.

For a new person I would humbly suggest you ditch vi. it's got a learning curve to use. instead try nano. "opkg install nano" then to edit a file do "nano /path/to/the/file" nano is simple and works like how you would imagine a text editor should. vi is more advanced but it has weird cryptic things to enter in order to save and quit and do other things. with nano if you want to save the file then do "ctrl o" and to quit nano it is "ctrl x" and that's It! no extra weird commands to remember. In fact nano even tells you the commands at the bottom in case you forget. IMO I don't know why nano isn't included with every OpenWRT install because of this reason. A lot of other router firmwares include it. I guess the linux gurus prefer vi out of habit, but it causes a lot of problems for first time users and linux noobs in general and 99% of the time it's all you will ever need. In fact I have been using Linux since around 2000 or 1999 and never ran into a situation with OpenWRT or Linux in that I said to my self "hmm I bet vi would do this better."

@MakeWiFiGreatAgain is not wrong about the oddities of vi. It isn’t particularly user friendly for beginners, especially in a modern context.

That said, I think that there are other issues like the network topology that need to be sorted out and understood.

@phisherman is correct about the other issues to sort out.

BTW I forgot to mention that you should not have to install kmod rtl8153 drivers for the Ue300 they are included. you can install them manually as you have found out and this does not hurt anything, but it also does not have any usefulness. Just trying to help.

It is not that hard, I was just lame :smiley: Wanted to do with the nano but like you said it's not included, once I have luci access again I'll add nano or maybe in the terminal. But I'm glad that at least the ports are now properly setup

Quicky I draw now the diagram for @psherman

@MakeWiFiGreatAgain really? I just followed the rpi guide without checking anything. but can you also confirm that now the setup is correct?

But vi is the only editor included with the base system, until you can connect to the Internet and install nano.

I don't know what else the OP has done to the configuration so I'd suggest starting over.

  • Reset to defaults, which is done by running firstboot if it's a squashfs image; if it's an ext4 image re-flash the SD card with the distribution image.
  • On the local keyboard and screen, edit /etc/config/network to create a wan network and move eth0 out of br-lan to the wan network. (This leaves the lan network empty, but you're using the local keyboard and screen which doesn't require any network.)
  • Connect the built in port to existing home network. It should dhcp an IP and establish Internet access. (Note if the home network is 192.168.1.X, you have to change the LAN IP to something else.)
  • opkg update and install kmod-usb-net-rtl8153 and nano.
  • nano /etc/config/wireless and start up an AP on lan. Connect iPad to this AP, should be able to log into LuCI. (The built in wifi is not very good-- don't try to serve a whole house with it-- but it is OK for this purpose of having some sort of wireless access to the LAN side for an iPad to GUI configure. Suggest changing the htmode to HT20 instead of VHT80 if wifi does not come up.)
  • Using LuCI or nano move eth0 back to lan and eth1 to wan. Connect UE300 adapter to home network. LAN devices such as a switch and AP can be connected to the built-in port.

This is basically the final configuration as a router. You can then move the wan connection directly to the modem and start using the Pi as the main router.

1 Like

It's quite simple as @mk24 just replied, few minutes to setup but somehow I managed to do this all day, only the router part....

But vi is the only editor included with the base system, until you can connect to the Internet and install nano.<

Alas you are correct. I wish they would include nano it would help a lot of people new to OpenWRt or linux as it is intuitive enough to use without help or a guide. I think I will bring this up to devs actually.

So is it working now, or are you still having issues?

BTW, I find the choice of a Pi400 a bit strange for a router. The Pi is a great option, but the 400 (with the built-in keyboard) seems to be an odd device for this purpose because you don't need a keyboard for your router 99% of the time. If you use a regular pi, you can always plug in monitor and keyboard if/when you need direct console access. Otherwise, everything can normally be done with LuCI or ssh from another machine on the network.

The RPi400 is supposed to sport a slightly more recent version of the SoC that runs a bit cooler (giving some thermal headroom for mild over-clocking) so not a terrible choice...

There is that. But apparently some of the newer pi4 model b units (as in a recent manufacturing run) are now sporting that same soc.

I just wanted to add nano but it failed to download the package list so there’s no internet. Did I miss something?

I barely found stock in my country, lots of things are out of stock specially the the pi 4 and power adapters and luckily found the pi 400 kit so I went with it. It will be on a shelf in a different room so the size is not a big deal :slightly_smiling_face:

Hard to know... did you edit your network configuration such that the built-in ethernet is WAN (and likely with a proto of either DHCP or PPPoE -- whatever matches your current router's settings, assuming you're plugging this directly into the modem)?

The built in is set to br-lan and proto static

But now I was dumb enough brick my 1043nd v2…wanted to update to 21.01 and I wasn’t thinking and did on Wi-Fi not via cable and stuck on the flashing pop up message. It’s the proper sysupgrade file and checksum is a match too so the Wi-Fi upgrade that killed it. Now I’m searching if I can get it back , still I have a v1 spare too. Now I’m definitely not tired so I’m just retarded
Edit: Heh, weird I have internet on the 1043nd,even WiFi I just can’t access luci. I tried unplugging the wan to see if it’s ip conflict but the default is not working neither. But if I have Wi-Fi then settings are not gone so the IP should be the same as before but I can’t access it
Edit2 I can log in via ssh and the version is 21.02 so it updated “successfully”, I installed luci there again but still can’t access in web browser. It says warning: potential security risk ahead
Edit 3
I managed to get luci back but can’t finish the above
I got stuck at the end, can’t do neither win or Linux options , none of the commands work. I even added the certiful to fedora

It was fun at beginning but now I’m frustrated and close to hurt myself, I can’t believe that I’m such a looser