New 22.03.5 on DIR-505 D-Link works for a few seconds


Via the steps described on the wiki-page, I installed the 22.03.5 (also the 21.02.7 release) version of openwrt on a d-link DIR-505.
When the DIR-505 boots-up, it response for a few seconds (2 or so) to ping (possibly telnet as well) and then becomes silent.
Is this a known problem? How can I resolve this?

You're probably seeing the bootloader responding to the pings, not OpenWrt.

What address are you trying to ping? Do you have your computer set to a static IP or DHCP?

PC is on static ip. I set it to Then I'm pinging

that is the correct address to ping.

Does DHCP work? Set your computer to DHCP and see if it gets an address.

Do you mean that openwrt has default a dhcp-server enabled on the ethernetports?

In general dhcp works fine for my laptop when connected via ethernet (I usually connect it via lan as wifi is flaky with it).

If you've got a fresh/default install of OpenWrt, yes, there is a DHCP server on the lan interface. Wifi will be disabled by default, too... so you must connect with ethernet.

During startup (flashing green) the interface of my laptop looks like this:

11: enx00e04c534458: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:e0:4c:53:44:58 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::e726:56b4:96:21fd/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

When the flashing stops, my laptop interface looks like this:

11: enx00e04c534458: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:e0:4c:53:44:58 brd ff:ff:ff:ff:ff:ff

Note that it says "NO-CARRIER" - link is down (my laptop has no leds for its network interface). So I think openwrt brings the interface down.

Just to be sure, I forced a dhclient-refresh on that interface but that timesout after a while.

root@peak-it:~# dhclient enx00e04c534458

Ok... it seems like the firmware is not booting. What you are getting is the bootloader at the beginning, and then it just stalls out when it tries to boot.

What firmware file did you use (what was the exact filename)? What was on the device when you started (was it the vendor/stock firmware or something else)? How did you perform the upgrade to OpenWrt?

I started with the original firmware, then:

  • openwrt-19.07.8-ar71xx-generic-dir-505-a1-squashfs-factory.bin
  • openwrt-22.03.5-ath79-generic-dlink_dir-505-squashfs-sysupgrade.bin
  • openwrt-19.07.0-ar71xx-generic-dir-505-a1-squashfs-factory.bin
  • openwrt-18.06.9-ar71xx-generic-dir-505-a1-squashfs-factory.bin
  • openwrt-19.07.0-ar71xx-generic-dir-505-a1-squashfs-factory.bin
  • openwrt-22.03.5-ath79-generic-dlink_dir-505-squashfs-sysupgrade.bin

Only 19.07.* worked fine.

The first installation was via the web-interface of the dir-505 itself. After that I used sysupgrade to go from e.g. 19 to 22. And when the system became unresponsive, I went back to 19 using the rescue-bootloader from d-link itself.

Ok... are you now running properly on 19.07?

When you upgraded to 22.03, did you uncheck "keep settings" (i.e. do not keep settings)?

1 Like

Oh indeed, I forgot the -n switch for sysupgrade.
Now it boots and works!
Thanks for the support

Yup. That wa probably the problem. Settings must not be kept across the upgrade you are running because of the ar71xx to ath79 target transition.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.