Network Topology - Creating Interfaces for 2 Separate Private Networks While Cascading Routers

Hi everyone,

I need help with setting up 2 networks with different SSID's, namely how to configure the interfaces in OpenWrt. I did a lot of reading and research as well as watching videos on YouTube. So far I believe to understand what generally needs to happen to make those 2 networks work and communicate with each other but I hit the wall when trying to configure OpenWrt as I am absolutely not experienced with it.

This is the idea:

Huawei Echolife HG 8145V5 is the router/ modem connected to the internet through my ISP. The ZTE MF283+ is an 4G LTE router/ modem from the same ISP that I used before switching to fibre optic. So far I have managed to install OpenWrt 21.02.4 on it and I can log into it and configure it.

So what I would like is to connect the ZTE MF283+ to the main network with HG 8145V5 router by connecting it's WAN/LAN1 (factory enabled) port with an Ethernet cable to LAN1 port of the fibre optic router. When I do that without any configuring, the ZTE MF283+ router acts as an extender to HG 8145V5 router and I can not access LuCI in the web browser.

I would like to install OpenVPN on the ZTE MF283+ router (Green Network) so that I can connect some devices through it (tablet, 2 PC's & a phone). As the devices are in a different room, they would all be connected through Wi-Fi.

The devices already connected to the main router HG 8145V5 (Pink Network) (PC-Ethernet, Phone-Wi-Fi, Printer-Wi-Fi & TV-Ethernet(YouTube)) would stay connected to the main router.

I am NOT after creating an FTP server and devices from the Green Network do NOT have to communicate with the devices from the Pink Network.

Devices in the Green Network need to be able to access internet for downloading purposes and the only game I intend playing is Clash of Clans. This all of course while using OpenVPN installed on the ZTE MF283+ router.

This is the address pool on the main HG8154V5 router:

From that I have deduced that I can keep the 192.168.1.1 address for the Green Network ZTE MF283+ router. I have tried to configure that IP address in OpenWrt interface as a static IP address. Or should I have changed it to for example a 192.168.200.1 address?

I am also confused with the fact that my initial configuration of the ZTE MF283+ router shows up in bridged mode interface.

General settings secondary ZTE MF283+ router:

What I have done is:
Turned the LAN1 port into a WAN port (which should be WAN/ LAN1 coming from the factory but now of course the stock firmware is removed)

Created a new WAN interface:


Then I changed the IP address on the WAN side into a static one (192.168.100.2):


After adding the new WAN interface and connecting to the primary router through Ethernet cable, there is no internet on the secondary ZTE MF283+ router.

So this is the Frankenstein I have created but it is not alive yet:


In the Routes section I have found this but not sure how to interpret it:

While in the Static IPv4 Routes there is nothing (not sure if there's supposed to be):

I have read the User Guide on the OpenWrt web site but did not get any wiser on how to set up a working interface in my particular situation. Also after researching on the internet and watching countless YouTube videos I do not feel like I am close to getting home.

I have checked if I am dealing with a double NAT issue on my ISP's side and after checking "whatismyipaddress.com" it seems that my IP address is the same as in my stock firmware WAN configuration on the HG 8145V5 main router:

All in all it would be most helpful to me if someone could guide me through setting up the needed interface(s) and pointing out what things I need to take into account (e.g. disabling the DHCP, configuring firewall, circumventing double NAT or anything similar) or otherwise directing me to a website/ YouTube video where I can see how it needs to be done in my case. I feel very lost and helpless at this point.

If the following two things are true:

  1. the devices on each network do not need to be able to connect to devices on the other network
  2. you plan to use a VPN to tunnel the traffic on the OpenVPN router through a VPN provider

then the solution is really very simple: run the router in a standard routing mode by taking one of the physical ports and setting it up as a wan port (on the OpenWrt router). Once that is done, the upstream network will not be able to connect to the devices behind the OpenWrt router, but those devices behind OpenWrt will be able to reach the upstream network (this can optionally be prevented by the firewall, but will be moot once the VPN is running). Of course, the devices connecting to the OpenWrt network will also have normal access to the internet.

The next step is to install and configure your VPN. Once that is done, all traffic will be encrypted as it leaves the WAN port of the OpenWrt router (until it reaches your VPN provider) and vice versa.

Thank you Peter for the swift reply.

That's what I was trying to do but somewhere along the way I failed. The steps I took are all posted in the screenshots above. I fail to turn the LAN1 port on the secondary OpenWrt router into a WAN port, well into a working WAN port.
I need someone to show me how to set it up.

Is it okay to keep the network LAN side at the static 192.168.1.1 IP address while designating a static IP address to the WAN side which is the same subnet like the primary router, e.g. 192.168.100.2?
The primary router's IP is 192.168.100.1 (also posted above in the screenshot).

Also I recon that the OpenWrt router should have the DHCP switched on for the devices or do each of the devices need a static IP address?
When I do what I did in the screenshots above I got no internet on the OpenWrt router.
So somewhere along the way. I screwed up.

I wish someone could show me what I am doing wrong.

Thank you for taking time to reply Peter.

For a start, set the WAN port to untagged.

image

Then log into the router using SSH and try to ping 192.168.100.1.
If the ping is successful, set a DNS server and assign the WAN interface to the wan firewall zone.

LuCI->Network->Interfaces->Edit(WAN)

image

image

If it still doesn't work, you'll need to post the configuration in text format.

1 Like

@pavelgl covered the things that need to be corrected (based on what we can see in the screenshots). Give it a shot and let us know what happens.

1 Like

Thank you Pavel and Peter.

Going to try the settings out after which I will post the feedback.

Your support is very much appreciated.