Netgear r7800, can't get tftp initial flash to work (wrong router)

I'm gonna c&p my netgear forum post, it just doesn't mention that firmware.img was openwrt not stock:

I have been trying to tftp new firmware to my r7800, and I simply cannot get it to do anything but connect request failed on me. I am plugged in via Ethernet, I have a static up set on the uploading computer. I started with the exact advice per the KB article, set my pc to 192.168.1.10, waited for the power light to flash 10 times, hit enter on the command line (tftp -i 192.168.1.1 put firmware.img). Beyond that I have tried basically every combination of:

  • Lan ports 1 or 4
  • forced IP as 192.168.1.2, 192.168.1.3, 192.168.1.10
  • starting the tftp command as soon as the orange power light goes on, or as soon as it starts blinking white, or after several blinks, or after half an hour of sitting there blinking.
    -windows 10 built in tftp, windows 7 built in tftp, tftpd32 and 64

As long as the power light is blinking it seems to be in recovery mode. Pings timeout, but I am connected to it as my gateway, and get whatever IP I've set.

So what am I missing? What am I doing wrong. I have tried this on two different r7800s at this point, same problem. The GUI firmware updater also errors out, and the auto-updater is not an option in this case. I would really love someone to tell me the obvious thing I'm missing here, lol. Any help appreciated.

At the first glance nothing wrong.
To my knowledge also the OEM GUI firmware updater should work, so I wonder why that fails, too.

Failing on two routers is even more strange.

Are you sure that you have R7800? And not e.g. D7800?

Ps.
Easier advice than in the Netgear KB article can be found in OpenWrt wiki or the r7800 exploration thread here.

  1. Turn off the power, push and hold the reset button with a pin
  2. Turn on the power and wait till power led starts flashing white (after it first flashes orange for a while)
  3. Release the pin and use tftp in binary mode

Below are my recovery steps (MacBook) when I used to run an R7800:

R7800 tftp recovery

Set static IP to 192.168.1.2 (no router/dns) on the client
Turn the router off
Press and hold the reset button
Turn on the router and wait until the power light starts blinking white
Release the reset button

cd {location of the image}
	tftp
	connect 192.168.1.1
	mode binary
	put {image file}
	quit

Are you sure that you have R7800? And not e.g. D7800?

I was until you asked. I just looked and the r7800 is supposed to have 4 antennas. I only have 3. Its sold as an AC2600, which I thought was the right one, but evidently its not.

what I have is (two) https://www.amazon.ca/gp/product/B07LGG5YRS/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1 this, which I can't even figure out what the actual rXXXX number is for it. This is what comes up when you search r7800 on amazon.ca. I can't believe that was the problem the whole time. What even is this thing?

It should be spelled out explicitly on the model plate on the bottom of your device.

1 Like

Apparently Netgear just straight up recycled the AC2600 branding for the r7800 into an actual model # for whatever this is. I really should have noticed sooner, but also that's a pretty BS way to name your products. The r7800 seems to be discontinued.

This may is probably totally unrelated but I could not flash some of my NetGear routers directly with openwrt. I had to flash an intermediate firmware such as freshtomato first. Then I was able to flash the openwrt. There are a few posts about this.

Well, the AC2600 is just a WiFi speed classification, which many OEMs use and also use in device names or in addition to them. But R7800 was actually nighthawk X4S (R7800) if I remember right.

Ps. On your router's page it is said that your model exists since 2018, while R7800 has been there since 2016...

"Date First Available Oct. 20 2018"

What does the label in device bottom say????
You might have R7400?