Netgear Nighthawk R7800 confusing issues

I'm having some confusing issues with the R7800. There seems to be other issues with stability, but the main issue I'm facing right now is that after a brief few configurations on Luci, the router stops being accessible on Luci or SSH. There's no valid reason I can come up with that those settings would break access, and besides they should rollback if they were. Are there known issues with the firmware on r7800? I couldn't see anything on the device page to solve my issues.

What settings?


Can you give us more specifics? Your post is currently quite vague.

  • What settings are you changing?
  • how are you changing them?
  • what version of OpenWrt are you running?
  • what is your goal?

And what does your current config look like?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Hi, sorry if it's fairly vague, I'll try to answer any questions best I can.

What settings are you changing?

The settings I've been changing to encounter this are extremely mundane- Such as the system name (From Openwrt to my chosen name), the theme (Light to Dark), and the startup options. (I intend to use the device as a dumb AP, so I disable dnsmasq and firewall and then reboot.)
Since the loss of access doesn't seem to happen upon any specific change or reliably at any time I can discern, I don't believe the settings changed are the issue.

how are you changing them?

I'm changing them through the Luci interface, from the stock configuration of the default factory image.

what version of OpenWrt are you running?

Default factory image 22.03.2 for this device.

what is your goal?

To configure this device to serve as a dumb WiFi AP and also a managed switch.

And what does your current config look like?

My current config on this device is the stock factory config for this device. (The rest of my network should not be at issue as I encounter this problem before I get to place it in my network)
I'm making t he assumption that these are fairly standard defaults across models, but if I'm wrong and listing these outputs would indeed be helpful in this case please let me know again and I'll post them as soon as with apologies.

This shouldn't cause you problems (unless you haven't configured the lan config to be part of your main subnet yet, or there is a conflict). But it is actually not recommended to disable in this way.

Instead, set the dhcp server to ignore on the lan interface. This way, an upgrade won't come along and re-enable the dhcp server without you knowing it.

The firewall doesn't need to be disabled. It will never see any traffic, so it doesn't matter. Just leave it as is.


Did you set the lan address to an unused address within your main lan's subnet (typically set as a static IP that is both unused and not within the DHCP pool)? And are you connecting LAN-LAN?

Thanks for the advice on dhcp and firewall- I'll configure that way in future. I should probably put checking that on my other devices on to-do list also.

As for the LAN address, uh- yes, and no... :smile:

So at one point I was able to get this device connected to my network, and even access it fine, through a static IP, and later one assigned by the main router. Everything was proceeding okay and I was following the same basic principles of setting up a dumb AP I've done multiple times before, at least by memory.
Until out of nowhere, my whole home network seemed to go down, and I could not even access my main router. After resetting it twice, out of frustration, I decided to reset my whole house by flicking the master breaker switch, which worked! Temporarily, until I assume the Netgear finished booting and started sending out traffic.
When I looked at my unmanaged switch all the traffic LEDs were flashing as fast as they could, and upon disconnecting the NetGear, everything returned to normal. The only thing I can speculate is something in the way I tagged the dual CPUs on VLANs, or having both the eth0 and eth1 (LAN and WAN port devices) on the same bridge device was causing infinite loops of traffic through my whole network and grinding it to a halt.

Anyways, this led to me pressing the reset button on the Netgear to restore factory settings, hoping to try again from default. That's where I find myself now, encountering this problem with apparent arbitrary loss of access to the device after a brief period.

That might give more context on why I was questioning first if there were any known issues for this device- something that might explain both problems , because I've never encountered them before.

You may have had a switching loop or some misconfiguration that was causing your problem. Resetting to defaults and then following the dumb ap guide is the best bet. You don't need to change anything on the lan or ethernet port mappings except for the IP address.

1 Like

I’ve hit another snag, and quite a frustrating one. Somehow, when changing from an untagged connection to the main network to a tagged one, Luci connected for a brief moment on the same connection.. I think? I’m not sure how that is possible, but before I was able to unplug from an untagged port and plug into a tagged one, Luci confirmed the changes and prevented rollback.

Even more annoyingly, I can see it as an ipv4 neighbour when I plug it into the tagged port- but cannot access it by either ssh or Luci.

Why are you making this change? Does your router support VLANs and is it configured to have the LAN tagged on the appropriate port? You need to get rid of the unmanaged switch if it is between the router and the AP so that the VLANs can be properly configured on the other end of the cable.

I don't really know... I would think it was a cached page, but if it was confirmed based on the normal auto-rollback mechanism, clearly it loaded. But I'd have to understand more about what specifically you changed.

Apologies, as usual, it's user error rather than a problem with the software that caused this.

I was finishing it in the AM hours, and managed to forget that I was connected to the NetGear through Wi-Fi also.

And then I changed the WiFi networks over from the main lan interface to my desired one, effectively locking me out of admin for the device.

Again, thanks to all for the help with troubleshooting it. Even if it was my own basic mistakes that caused the issues, it's valuable to have somewhere to hash out the process and assist.

No problem. User errors are common and happen to all of us. Sometimes we can be so deep into our own work that we fail to see the problems until we hash it out with other people (just think of identifying typos in a paper or presentation or whatever -- glaringly obvious to others, but we gloss over our own mistakes).

Glad you found the problem.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.