Need New DavidC502 Thread

Pefect! You got it!

@ davidc502 -
thank you for your firmware for wrt32x. i've done some inittal testing this morning. i have a wrt32xB hardware wchih uses spansion rom. i flashed your firmware over the webif.

the 'advanced reboot' feature shows 'Warning: This system does not have two partitions! Warning: This system does not have two partitions!'

what is interesting is that your build flashed to the first boot image. lede fw_printenv reveals boot_part =1.
if i fw_setenv boot_part 2, then i can reboot to the factory image.

is this a buggy advanced_reboot module, do I need to use the uboot serial mothod, or is this a result of having the 'wrt32xB' version of hardware?

thanks for the alert on this.

1 Like

As @ghoffman stated, thank you for the WRT32X Firmware. I am very grateful to be off the stock Venom Firmware.
I flashed via Serial and run update_both_images
I can also confirm that the lede-mvebu-cortexa9-linksys-wrt32x-squashfs-factory.img does not recognize the dual-partitions.
If I use SSH and fw_setenv boot_part to switch to alternate partition, LuCI comes up as a new install and must be reconfigured. My SSH-RSA Key is also not recognized.
I have a WRT32X v1

@ghoffman and @spuriousoffspring

Have you both tried putting a lede image on both partitions to see if Advanced reboot then sees them both?

yes. it makes no differerence.
my steps:
by analysis of mtd dumps:
mtd5->kernel1 factory
mtd7->kernel2 factory

factory gui -> davidc lede--mvebu-cortexa9-linksys-wt32x-squashfs-factory.img on partition 1

mtd5->kernel1 factory
mtd7->kernel2 davidc lede

advanced reboot gives 'only one partition'

sysupgrade:davidc ssh davidc lede-----sysupgrade.bin -> davidc lede on partition 1

mtd5->kernel1 davidc lede
mtd7->kernel2 davidc lede

booting to either partition -> advanced reboot does not recognize a second partition.

luci-app-advanced-reboot by itself doesn't detect anything, that would be extremely dangerous, it needs to get to know about the pecularities of your system beforehand. The good news, it's probably trivial to add support for it, please try it yourself and then contact @stangri about it, from your description this should be everything:

From cab6cc5ec5bc9fea12a2e78633462cb90485534f Mon Sep 17 00:00:00 2001
From: Stefan Lippers-Hollmann <>
Date: Mon, 21 May 2018 20:57:05 +0200
Subject: [PATCH] add support for the Linksys WRT32X (venom)

According to

This is basically a WRT3200ACM (rango) in disguise.

Signed-off-by: Stefan Lippers-Hollmann <>
 luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua | 1 +
 1 file changed, 1 insertion(+)

diff --git a/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua b/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
index b5dd4fe..8318c00 100644
--- a/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
+++ b/luci-app-advanced-reboot/luasrc/controller/advanced_reboot.lua
@@ -14,6 +14,7 @@ devices = {
   {"Linksys WRT1900ACv2", "linksys-cobra", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"Linksys WRT1900ACS", "linksys-shelby", "mtd4", "mtd6", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"Linksys WRT3200ACM", "linksys-rango", "mtd5", "mtd7", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
+  {"Linksys WRT32X", "linksys-venom", "mtd5", "mtd7", 32, "boot_part", 1, 2, "bootcmd", "run nandboot", "run altnandboot"},
   {"ZyXEL NBG6817","nbg6817","mmcblk0p4","mmcblk0p7",32,nil,255,1}

You can also edit the file in place on your router via "/usr/lib/lua/luci/controller/advanced_reboot.lua".

Sounds like a bug report should be filed. After all WRT32X was just added to OpenWrt a week ago probably needs work.

Seriously thinking about selling my WRT3200ACM and getting WRT32X once support is nailed down. Just love how it looks and now with davidc502 builds out...

Thank you Stefan, I've added the fix to the code and pushed revision 28 to my repo.

@ghoffman -- please confirm the patch submitted by @slh works and let me know so I can submit PR to the OpenWrt repo.

@stangri - your patch worked. !!!!
i downloaded your file from

after loading it into the appropriate path on my wrt32xb and rebooting, i luci's advanced_reboot is showing two parttitions.
thansk you!!

Stan – your patch works. Thankk you!!

Hi I tried the fix on a snapshot build no davidc502 builds,it works partially it do not display the kernel version, on my case lede in in part 1 and original in part 2

Used the same method (WinSCP) as @m4r with the same result.
Maybe Firmware/OS (Kernel) version will be displayed after a reboot cycle?

As soon as I get my USB NAS (Samba) working and then a backup, I'll give it a try.

Thank you for the quick fix!

yes, i can confirm - the kernel content is not identified. thank you.

The offset of 32 is not correct for zImage firmware. The patch is not right.

Somebody with WRT32X please analyse the needed offset (of an mtdblock), where the Linux version is written. (how many characters need to be skipped) @stangri needs that info for updating the app.

See e.g. discussion about the work done for the other routers, starting at:

Or alternatively you may try "hexdump -C /dev/mtd5"


@antonsamoziv Can you please change the topic to something more meaningful, in order to better reflect what is being discussed here?

i've looked at wrt32x dumps of mtd5 and mtd7 saved from factory firmware and after booting into davidc lede.
there is no free-text linux version string.
check out the ..factory.img files:
for wrt3200acm: ascii "ARM linux ......" at offset 32
for wrt32x: hex with nothing decipherable

So, been running htop for 2 days now, today I look at it and memory usage is at 270MB whereas the past day it was 170MB, however nothing in the list, or in ps avxf shows anything using that much memory: See

Right now it's increasing by 1MB every few minutes or so as far as I can see at a short glance, so it will run out of memory within a few hours, but I have no idea why

What does free output?

root@LEDE-3200ACM:~# free
total used free shared buffers cached
Mem: 510920 313076 197844 1196 6488 19132
-/+ buffers/cache: 287456 223464
Swap: 0 0 0

277M/499M now

edit: 1:35PM (290/499M used)
root@LEDE-3200ACM:~# free
total used free shared buffers cached
Mem: 510920 325952 184968 1196 6488 19136
-/+ buffers/cache: 300328 210592
Swap: 0 0 0

So it's memory usage going up, but no processes actually reflect this memory usage for some reason