Need help with VPN setup after changing ISP

I recently received help to set up my Gl-ar750 modem with vpn, at the time it worked brilliantly but I have recently changed my isp provider and the vpn will no longer work I have already contacted my vpn server for help but I could not change the isp modem the way they suggested can anyone here give me some advice please

I've changed your topic title to reflect your actual issue (a generic title like your original one doesn't help you nor people wanting to help you).

It doesn't hurt to be specific in your request for help either, you are saying it's broken, but are not sharing any errors, configurations, or what you tried so far.

The gl-ar750 is connected to my main modem before I changed my isp there was no problems
the gl-ar750 worked fine with or without the vpn on but since changing my isp the vpn will not allow any traffic through no errors just wont work.

What type of VPN (OpenVPN, Wireguard, etc)? VPN clients are usually rather insensitive to the type of Internet connection.

However, for proper routing of anything it is important that the various IPv4 networks do not overlap and conflict. This could be an issue if your new ISP modem is running a private IP to your router, and that network now matches one used by your LAN or VPN-- but it didn't with the old ISP.

1 Like

I am using the open vpn client which is surfshark dont know if I am allowed to say who my isp is, is there a way to check for these issues

Can you share any type of config or information?

sorry I dont know what your asking for I just know if the vpn is on it wont allow internet access

You're just providing the information that the vpn is online but not allowing any internet access. Not much I can do with this information.
Can you ping the VPN Server with a client in your subnet?
Can you ping the VPN Server with your router?
Can you ping or any other IP address in the internet?

managed to ping but nothing else they all came back unreachable or timed out does this help at all

OpenVPN prints a large amount of useful debugging information to the log as it starts up and connects.

would it be useful if i put the whole log on here for someone to look at if its allowed

Of course it is. Just make sure to redact any sensitive information (e.g. usernames and passwords). If the log's too big to post here you can always use a pastebin service and link to it here.

it is quite big have not used paste bin how do i do that please

Have contacted your new ISP and told them to allow the VPN traffic?

did not know I could or even should contact them just expected it to work as it did with previous isp

okay hoping this works here is link fingers crossed

If you can ping through the VPN you should also have access to the rest of the internet.
Can you ping,,, and post the results
Could you also make a traceroute for and

okay pinged and did traceroute they worked fine don't think you need to see results the vpn has let the computer through today but nothing else will work when it is switched on, did you or anyone else manage to see the log with the link I posted please

I went through the log file. The only things that caught my eye were the following lines.

DNS service limited to local subnets

If the DNS is only limited to local subnets that would be a problem, but there are a few more dns relevant entries

using nameserver

This is your local dns I suppose.
I would check if the dns works correct, even though you said that you can ping hostnames (

Tue Apr 13 14:17:45 2021 daemon.notice openvpn[4207]: TLS: tls_process: killed expiring key

That is one problem.

Tue Apr 13 12:17:45 2021 user.notice firewall: Reloading firewall due to ifup of wan (eth0)

But it feels you have a much bigger problem because your firewall restarts also! You actually have like a trillion of errors on the system itself!?

Tue Apr 13 12:17:44 2021 daemon.notice openvpn[4141]: OpenVPN 2.5.0 mips-openwrt-linux-gnu [SSL (OpenSSL)] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD]

And the log you linked to say that the system starts openvpn 2.5.0.

That is also a problem because OpenWRT 19.07.7 use openVPN version 2.4.7-2.

Tue Apr 13 12:17:44 2021 daemon.notice procd: /etc/rc.d/S99startvpn: ifconfig: tun0: error fetching interface information: Device not found

Did you make a tun0 device for the LAN?

So we need to look into two things first.

  1. Do you run a snapshot install of OpenWRT on the router?
  2. Have you run OPKG upgrade the packages on the router?
1 Like