Need help installing OpenWrt on Xiaomi Redmi AX6

Hi there, I am trying to install OpenWRT on my Xiaomi Redmi AX6.
I've gained SSH access, copied over the firmware, ran ubiformat with the firmware, set flag_last_success and flag_boot_rootfs, committed nvram and rebooted.
After reboot however, the router is stuck with a orange "system" light.
I've done the unbrick listed on the wiki which worked to unbrick, but OpenWRT still doesn't boot.

In case it's just a problem with the LEDs, I connected my computer to a LAN port of the router and ran dhcpcd, but it just set my IP to an APIPA address
Thanks in advance.

Hello, just got the same problem and was able to get more infos, its not an LED problem, the router refuses to work due to Xiaomi's OEM Firmware.
I just created a post with everything I could find.


Just found a solution that worked for me, maybe you could try it too.
I simply decided to flash redmi_ax6-initramfs-factory.ubi instead of redmi_ax6-squashfs-factory.ubifrom latest snapshot and that seems to do the trick.
As flashing the redmi_ax6-initramfs-factory.ubi will still trigger warnings I think it's a good idea to perform a sysupgrade after the firstboot just in case.

1 Like

thank you for telling me!! I will try this soon

yes, this worked! after flashing the initramfs I ran sysupgrade to the squashfs which works perfectly. the initramfs seems like an intermmediate stage, since wifi and installing packages did not work. I will try edit the wiki now so no one gets stuck like we did. I can't thank you enough!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.