Need confirmation on wifi vlan with switch on 22.03.3

I just installed OpenWRT on GL-B1300 and I needed vlan.
My device still has 'Network->Switch' configuration, but it also has the distinction between interface and device under 'Network->Interfaces'

For Ethernet it worked fine: I defined the vlans then tagged/untagged the ports and all was working as expected.
But I encountered issues when trying to have WIFI on vlan 10:
To create the SSID, I needed an interface that was connected to vlan 10. As eth0.10 was already created I created an interface with device 'eth0.10'. This set-up was not working as there was no connectivity between wifi and ethernet.

A bridge was missing between ethenet and wifi, but although both eth0.10 and wlan1 were present, I was not able to select a bridge that connects the 2 of them nor in 'interfaces' nor in 'device'.

As a desperate try, I created a device type 'bridge' but with only port 'eth0.10'... Then I created an interface based on this bridge and then connected it to wifi. Connection seems now established and interface automatically showed link between eth0.10 and wifi.

It seems to work, but is it the correct way to go (feels so weird)?

Title was indeed promising but unfortunately thread was containing not much useful information.

I've read that DSA and Swconfig are mutually exclusive. In my case swconfig being enabled, DSA seemed irrelevant, and indeed, I was not able to create vlans using the device configuration.

The confusing part is that in the current state of OpenWRT, not all networks are created equal, like the asymmetry between wired and wireless:

  • if you want to bridge 2 LAN ports, you just create a bridge and select the 2 devices you want to bridge
  • if you want to bridge a LAN port with a wireless radio you need to apply a different procedure and change tabs...
  • etc.

Can you show your switch config?

Setting a VLAN on a swconfig device is as simple as changing a dropdown box.

This sounds like DSA. That's not how it usually works on swconfig devices. Usually with swconfog, you set the VLAN and tag/untagged per port.

The non switch part (i.e. the WiFi) is done on the wireless page, yes that's correct.

You'll have to be specific.

It appears to me you’re making this more complicated than it really is if this OWRT device is using swconfig.

You want wifi on an interface that’s using eth0.10, correct? In your devices tab, add a device, make it a bridge, and add eth0.10 to the bridge port.

Then, in the interfaces tab, create your interface (either DHCP or Static address, whichever you want) and add the newly created bridge as the device for the interface.

Finally, in your wireless tab, click add on the radio you want to use and select the new interface you created as the network.

Yes, this is the correct way to do it for swconfig devices.

1 Like

Thanks for the confirmation! :grinning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.