NanoPi_R1S-H5 - Can anyone get into this device?

I have the h5 device.
This is probably very low level for most of you but I'm not sure where else to ask and the vendor is pretty useless in helping.

I bought one of these and just wanted to see it running. I found this link and have been trying to follow along.

I've loaded an SD card with first
nanopi-r1s-h5_sd_friendlywrt_4.14_arm64_20191230.img and then

Neither seems to work or at least, neither gives me a DHCP or even a static IP. Nothing and I cannot find any documentation on what a default IP might be, DHCP or a static.

I downloaded their openwrt specific build and am trying it with no custom changes at all but it fails to find the needed packages. I manually went to the url and it does not even exist. No idea how to find this devices openwrt packages.

The package is
Nanopi R1S\openwrt-imagebuilder-SNAPSHOT-allwinner-h5.Linux-x86_64.tar.xz

You'll notice it seems to go from one path to another for the packages and I cannot find anything that helps me to acquire the correct image generator package. Can anyone help me in the right direction.

root@buntsrv:/clients/nanopi-rs1-h5# make image
Building images for allwinner-h5 - FriendlyELEC NanoPi/NanoPC
Packages: base-files busybox dnsmasq dropbear firewall fstools ip6tables iptables kernel kmod-ipt-offload libc libgcc logd mtd netifd odhcp6c odhcpd-ipv6only opkg ppp ppp-mod-pppoe uci uclient-fetch urandom-seed urngd

*** Failed to download the package list from

Updated list of available packages in /clients/nanopi-rs1-h5/build_dir/target-aarch64_cortex-a53_musl/root-allwinner-h5/../../../../../clients/nanopi-rs1-h5/dl/openwrt_base
Updated list of available packages in /clients/nanopi-rs1-h5/build_dir/target-aarch64_cortex-a53_musl/root-allwinner-h5/../../../../../clients/nanopi-rs1-h5/dl/openwrt_luci
Updated list of available packages in /clients/nanopi-rs1-h5/build_dir/target-aarch64_cortex-a53_musl/root-allwinner-h5/../../../../../clients/nanopi-rs1-h5/dl/openwrt_packages
Updated list of available packages in /clients/nanopi-rs1-h5/build_dir/target-aarch64_cortex-a53_musl/root-allwinner-h5/../../../../../clients/nanopi-rs1-h5/dl/openwrt_routing
Updated list of available packages in /clients/nanopi-rs1-h5/build_dir/target-aarch64_cortex-a53_musl/root-allwinner-h5/../../../../../clients/nanopi-rs1-h5/dl/openwrt_telephony
Downloading file:packages/Packages
Updated list of available packages in /clients/nanopi-rs1-h5/build_dir/target-aarch64_cortex-a53_musl/root-allwinner-h5/../../../../../clients/nanopi-rs1-h5/dl/imagebuilder
Collected errors:
 * opkg_download: Failed to download, wget returned 8.

Installing packages...
Installing libc (1.1.24-2) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for libc:
 *      libgcc1

You haven't actually installed OpenWrt (which isn't surprising, as OpenWrt doesn't support this particular device, yet; although it should be trivial to add support for it), but a modified vendor fork of OpenWrt - accordingly binary compatibility isn't provided. Please contact friendlyarm about your issues, we can't help you with their firmware.

I'm not asking or looking for openwrt support specifically because as you say, it's not supporting this device yet.

I do find it interesting that they are using the repo however which is one reason I'm asking here.
What I'm hoping for is to find others who are playing around with this device since openwrt if often where we all learn about new devices, hardware etc that might eventually get supported.

i have an image compiled from their github earlier this year that works for most of my needs - you can try it out

Sure, I'd love to. It is set to DHCP or with a static IP and for which port, LAN or WAN?

dhcp on wan and for lan (also dhcp for hosts)

I must have a bad unit then. Yours is the third image I tried, it doesn't pick up a DHCP IP from LAN or WAN no matter the image and never has network connectivity on the WAN side so cannot even test this image.
I'll send it back and get another one then try again and report back. Thanks very much.

1 Like

Well, I'm totally confused at this point. I've sent back two units and this is my third. Using your image and the two offered by the company, nothing happens.

I've tried DHCP on both ports, nothing. I've scanned the entire network range to know what IP the device is set with, nothing.

The LAN port LED's are bright and normal looking while the WAN port lights never come on.
I can't imagine I've gotten three bad units in a row. What am I missing?

try with tcpdump listening on the wan port

Using all three images, the WAN port never comes up at all. Only the LAN port does and it never picks up a DHCP IP nor has its own static.

have you tried contacting friendlyarm for support ?
just had an idea (similar thing happened in my setup) - what about disabling WAN autonegotiation and set a static speed like

ethtool -s eth1 speed 100 duplex full autoneg off

I posted something in their forums last month and they have not responded. The only responses I get are exactly all the same stuff they have posted on the net. Mostly marketing stuff and repeating the same things.

I've followed those instructions to the letter. I keep thinking I must be doing something wrong, it has to be me since reviews from others say they are happy. I tried to leave a negative review and it was removed.

The command you mention above, that's assuming being logged into the device which is not something I've done yet. Guess I have to try that next and see what's going on with these things.

I'm connected via serial but don't see anything yet from the terminal either.
I decided to try again to build my own version and cannot get past this. I set up a build env on both centos and ubutu and both give the same error. Looking online leads to a lot of unrelated post so I'm a bit version about trying most of the input I'm seeing. It's not completely clear to me if something is missing in the build env or the OS.

Installing packages...
Installing libc (1.1.24-2) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for libc:
 *      libgcc1
 * opkg_install_cmd: Cannot install package libc.
make[2]: *** [Makefile:155: package_install] Error 255
make[1]: *** [Makefile:118: _call_image] Error 2
make: *** [Makefile:197: image] Error 2

LOL, I'm stumped on this. Others say it works just fine for them. Two returns and the third one later and I'm still not able to get anything out of this device. I've tried their images and the one shared here and get nothing.

have you tried with a different SD card? it looks to me like something basic like SD, cables, power supply...

Have you tried this one?

one member reported this:

Posted November 27, 2019

Thanks, I just went with the Nano Pi 2 Black image, and it just works, dual ethernet and wifi.

Hi, yes, I've been trying using two different SD cards but I'll try yet another one shortly.

I just checked that link and no one is offering an image download. At this point, I'd like to try even more images since the three I have don't work.

Found a link by looking online and now trying

You can choose Armbian Focal or Armbian Buster.

This is the image I am writing to the SD card using the windows utility that the company provides.


Using the utility, I write the image to the SD card.
I then connect the SD Card into the router then power it up.
The WAN interface is never up. Connecting an Ethernet cable never lights up the LED's.
The LAN side is always up, never picks up a DHCP IP and never has a static based on scanning the entire 192.168.x.x network after giving it a couple of minutes being up.

Stumped is an understatement. This should have worked by now and this is my third one. I'm still missing something, a step, something.

Try to write the image with dd in linux.

sudo dd if=Image.bin of=/dev/sdx

replace /dev/sdx with the actual device you are using. Use whole disk, not only a partition e.g. /dev/sdb instead of /dev/sdb1

BTW: Can you get serial connection from the board?