Mysterious Sofware VLAN interface

Hi folks,
I stumbled upon weird problem. After every reboot "Software VLAN" interface appeares :
eth11
vlan

I can delete this interface by specifying it as an interface in Luci and then delete it. But after reboot it's back... Also it automaticaly gets IP adddress whitch is reachable from local LAN.
I am not using VLAN functionality. I have no idea when this started and why.
/etc/config/network doesn't specify any VLAN interfaces (except default ones).


My router is Zyxel NBG6817 and I'm using stable 19.07.7 r11306-c4a6851c72.
Do you have any idea why is this happening ?
Thanks :slight_smile:

Apart from the untagged CPU interface, I don't see anything else wrong.
Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; 
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru
1 Like

Thanks. So untagget CPU interface is wrong ? I didn't alter VLAN configuration in any way. It was like this since clean install. This device is clasic router. Should I change VLAN configuration ?
Output from your commands :

{
        "kernel": "4.14.221",
        "hostname": "xxxxx",
        "system": "ARMv7 Processor rev 0 (v7l)",
        "model": "ZyXEL NBG6817",
        "board_name": "zyxel,nbg6817",
        "release": {
                "distribution": "OpenWrt",
                "version": "19.07.7",
                "revision": "r11306-c4a6851c72",
                "target": "ipq806x/generic",
                "description": "OpenWrt 19.07.7 r11306-c4a6851c72"
        }
}

package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdcf:xxxx:xxxx::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '10.9.8.1'
        option _orig_ifname 'eth1 wlan0 wlan1'
        option _orig_bridge 'true'
        option ifname 'eth1'

config device 'lan_dev'
        option name 'eth1'
        option macaddr '60:31:97:xx:xx:xx'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option delegate '0'
        option peerdns '0'
        option hostname '*'

config device 'wan_dev'
        option name 'eth0'
        option macaddr '60:31:97:xx:xx:xx'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 6'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5'
        option vid '2'

config interface 'AirVPN'
        option ifname 'tun0'
        option _orig_ifname 'tun0'
        option _orig_bridge 'false'
        option proto 'none'
        option delegate '0'

config interface 'hostia'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '10.10.10.1'
        option type 'bridge'
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    inet x.x.x.x/22 brd x.x.x.255 scope global eth0
       valid_lft forever preferred_lft forever
4: eth1.1@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global eth1.1
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 10.9.8.1/24 brd 10.9.8.255 scope global br-lan
       valid_lft forever preferred_lft forever
8: br-hostia: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 10.10.10.1/24 brd 10.10.10.255 scope global br-hostia
       valid_lft forever preferred_lft forever
12: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1549 qdisc fq_codel state UNKNOWN group default qlen 100
    inet 10.33.3.23/24 brd 10.33.3.255 scope global tun0
       valid_lft forever preferred_lft forever
default via x.x.x.1 dev eth0 table 201
10.9.8.0/24 dev br-lan table 201 proto kernel scope link src 10.9.8.1
10.10.10.0/24 dev br-hostia table 201 proto kernel scope link src 10.10.10.1
192.168.1.0/24 dev eth1.1 table 201 proto kernel scope link src 192.168.1.1
default via 10.33.3.23 dev tun0 table AirVPN
10.9.8.0/24 dev br-lan table AirVPN proto kernel scope link src 10.9.8.1
10.10.10.0/24 dev br-hostia table AirVPN proto kernel scope link src 10.10.10.1
192.168.1.0/24 dev eth1.1 table AirVPN proto kernel scope link src 192.168.1.1
default via x.x.x.1 dev eth0 proto static src x.x.x.x
10.9.8.0/24 dev br-lan proto kernel scope link src 10.9.8.1
10.10.10.0/24 dev br-hostia proto kernel scope link src 10.10.10.1
10.33.3.0/24 dev tun0 proto kernel scope link src 10.33.3.23
x.x.x.0/22 dev eth0 proto kernel scope link src x.x.x.x
192.168.1.0/24 dev eth1.1 proto kernel scope link src 192.168.1.1
broadcast 10.9.8.0 dev br-lan table local proto kernel scope link src 10.9.8.1
local 10.9.8.1 dev br-lan table local proto kernel scope host src 10.9.8.1
broadcast 10.9.8.255 dev br-lan table local proto kernel scope link src 10.9.8.1
broadcast 10.10.10.0 dev br-hostia table local proto kernel scope link src 10.10.10.1
local 10.10.10.1 dev br-hostia table local proto kernel scope host src 10.10.10.1
broadcast 10.10.10.255 dev br-hostia table local proto kernel scope link src 10.10.10.1
broadcast 10.33.3.0 dev tun0 table local proto kernel scope link src 10.33.3.23
local 10.33.3.23 dev tun0 table local proto kernel scope host src 10.33.3.23
broadcast 10.33.3.255 dev tun0 table local proto kernel scope link src 10.33.3.23
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast x.x.x.0 dev eth0 table local proto kernel scope link src x.x.x.x
local x.x.x.x dev eth0 table local proto kernel scope host src x.x.x.x
broadcast x.x.x.255 dev eth0 table local proto kernel scope link src x.x.x.x
broadcast 192.168.1.0 dev eth1.1 table local proto kernel scope link src 192.168.1.1
local 192.168.1.1 dev eth1.1 table local proto kernel scope host src 192.168.1.1
broadcast 192.168.1.255 dev eth1.1 table local proto kernel scope link src 192.168.1.1
0:      from all lookup local
32762:  from all fwmark 0x20000/0xff0000 lookup AirVPN
32763:  from all fwmark 0x10000/0xff0000 lookup 201
32766:  from all lookup main
32767:  from all lookup default

It's unusual, but if you didn't touch that I might as well be wrong.

Remove this from wan interface.
Also fix the redacted addresses, you have masked private IPs.
Finally, did you keep settings when upgrading from major releases, like 17.01 or 18.06?

done. Also only public IPs and MACs are now redacted.

This could be true. To be honest, I don't remember as I make changes quite often and save configuration regularly. I keep separate configs only between snapshot and stable branches.

There is one way to find out, backup/reset/reconfigure.
However if you are not too concerned you can leave it as it is. Anytime soon the 21.02 will be released and you can see how it will be after a clean upgrade.

2 Likes

Thank you very much. I will wait for 21.02 and than reconfigure from scratch.
Will post results :slight_smile:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

The "software VLANs" are created one for each VLAN in the switch on the assumption you have tagged CPU ports and need them to connect to networks. If you're not tagging the CPU ports you can ignore them.

However, tagged CPU ports are necessary to expand to more than two networks on Ethernet, so many router's default configuration is to have them.

Once your platform is migrated to DSA then all of this becomes moot.

1 Like

Yes those _orig_ lines are a clue to that. That is no longer used. You can delete all such lines from your config files, they are not affecting anything.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.