Mwan3 help, iptables-restore: line 12 failed

Hi everyone!

Just trying to get mwan3 to work on my AX6s running 22.03.2, and I'm running into a brick wall.

I have two subnets, both .21.x and 69.x respectively, and I need to assign the .69 a wwan connection due to better latency and throughput (but limited data)

However, when trying to apply rules in mwan in LuCi, nothing seems to change with routing.

When trying to narrow down the problem, I noticed these two iptable issues, which may be the root cause.

If anyone could point me in the right direction, I would immensely appreciate it..

Here's the error log below:

user.err mwan3-init[15989]: set_user_rules (ipv4): iptables-restore: line 12 failed
user.err mwan3-init[15989]: set_user_rules (ipv6): ip6tables-restore: line 10 failed

Here's the pastebin of the mwan3 troubleshooting log:

I've also made a little diagram below to illustrate what I'm trying to achieve (I'm very tired lol)

21.x ------> wan

69.x ------> wwan

Thanks - DigitalLabs

22.03 has moved from iptables to nftables.
Which version of mwan3 are you running? opkg status mwan3

Why are you using iptables-restore?

All you need is done by the mwan3 config.

Also mwan3 has a dependency on iptables but there is a bug in the iptables package that will install iptables-zz-legacy instead of iptables-nft.

The workaround is to use opkg to remove iptables-zz-legacy (if present) and install iptables-nft.

Now install and correctly configure mwan3.

Restoring some previous iptables rules will certainly break something....

1 Like

Hello @trendy and @bluewavenet,

Thanks for the advice. I'll get back to you on what I find.

Regarding your question @trendy, the mwan3 version is 2.11.1-1

1 Like

Hi, sorry about the delay in writing (Christmas was a very busy month).

It turns out that the pre-exisitng rules that are included in mwan3 were causing some form of error on my Redmi AX6S, which resulted in my custom rule not working.

Afer removing all rules, and then adding my custom rule again, it worked well.

Appreciate the help @trendy and @bluewavenet


1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.