MT76x2e MCU time out and WiFi fail with 23.05.2

I upgraded a couple of devices using MediaTek MT7621 and MT76x2E to 23.05.2.

After a few minutes I noticed:

Sun Nov 19 23:15:21 2023 kern.err kernel: [   36.534395] mt76x2e 0000:02:00.0: MCU message 02 (seq 9) timed out
Sun Nov 19 23:15:21 2023 kern.info kernel: [   36.686113] mt76x2e 0000:02:00.0: Firmware Version: 0.0.00
Sun Nov 19 23:15:21 2023 kern.info kernel: [   36.686182] mt76x2e 0000:02:00.0: Build: 1
Sun Nov 19 23:15:21 2023 kern.info kernel: [   36.686199] mt76x2e 0000:02:00.0: Build Time: 201607111443____
Sun Nov 19 23:15:21 2023 kern.info kernel: [   36.704512] mt76x2e 0000:02:00.0: Firmware running!
Sun Nov 19 23:15:21 2023 kern.info kernel: [   36.706109] ieee80211 phy1: Hardware restart was requested

Never seen those messages before, but it causes the 2.4 Wifi to stop working.

Anyone with the same issue?

1 Like

I have the same problem, xiaomi mi 3g 23.05.0

[27635.739960] mt76x2e 0000:02:00.0: Firmware Version: 0.0.00
[27635.745559] mt76x2e 0000:02:00.0: Build: 1
[27635.749689] mt76x2e 0000:02:00.0: Build Time: 201607111443____
[27635.773840] mt76x2e 0000:02:00.0: Firmware running!
[27635.781852] ieee80211 phy1: Hardware restart was requested

Same identical error, upgrade from 22.03.x to 23.05.2.
I also tried flashing-rewriting the same 23.05.2 upgrade but it wasn't effective.

Hello @jordipalet , did you solve it?

I'm sorry I have to join the #meeToo party ... I got these errors with my Xiaomi Mi R3G v1

166570.899970] mt7530-mdio mdio-bus:1f wan: Link is Down
[166575.345395] mt7530-mdio mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control off
[166588.940331] mt7530-mdio mdio-bus:1f wan: Link is Down
[166624.063994] mt7530-mdio mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx/tx
[167618.439362] mt7530-mdio mdio-bus:1f wan: Link is Down
[167620.840549] mt7530-mdio mdio-bus:1f wan: Link is Up - 1Gbps/Full - flow control rx/tx
[221024.339511] mt76x2e 0000:02:00.0: MAC error detected
[221024.630702] mt76x2e 0000:02:00.0: Firmware Version: 0.0.00
[221024.636309] mt76x2e 0000:02:00.0: Build: 1
[221024.640604] mt76x2e 0000:02:00.0: Build Time: 201607111443____
[221024.669484] mt76x2e 0000:02:00.0: Firmware running!
[221024.675557] ieee80211 phy1: Hardware restart was requested
[221026.079536] mt76x2e 0000:02:00.0: MAC error detected
[221027.019519] mt76x2e 0000:02:00.0: MAC error detected
[221027.969565] mt76x2e 0000:02:00.0: MAC error detected
[221028.979468] mt76x2e 0000:02:00.0: MAC error detected
[221029.989501] mt76x2e 0000:02:00.0: MAC error detected
[221030.929458] mt76x2e 0000:02:00.0: MAC error detected
[221031.949484] mt76x2e 0000:02:00.0: MAC error detected
[221032.959436] mt76x2e 0000:02:00.0: MAC error detected
[221033.979444] mt76x2e 0000:02:00.0: MAC error detected
[221034.989416] mt76x2e 0000:02:00.0: MAC error detected
[221035.999428] mt76x2e 0000:02:00.0: MAC error detected
[221037.009421] mt76x2e 0000:02:00.0: MAC error detected
[221038.029475] mt76x2e 0000:02:00.0: MAC error detected
[221039.049431] mt76x2e 0000:02:00.0: MAC error detected
[221040.059436] mt76x2e 0000:02:00.0: MAC error detected
[221041.069398] mt76x2e 0000:02:00.0: MAC error detected
[221042.079405] mt76x2e 0000:02:00.0: MAC error detected
[221043.089379] mt76x2e 0000:02:00.0: MAC error detected
[221044.099601] mt76x2e 0000:02:00.0: MAC error detected
[221045.119527] mt76x2e 0000:02:00.0: MAC error detected
[221046.129447] mt76x2e 0000:02:00.0: MAC error detected
[221046.820658] mt76x2e 0000:02:00.0: Firmware Version: 0.0.00
[221046.826261] mt76x2e 0000:02:00.0: Build: 1
[221046.830496] mt76x2e 0000:02:00.0: Build Time: 201607111443____
[221046.859371] mt76x2e 0000:02:00.0: Firmware running!
[221046.865442] ieee80211 phy1: Hardware restart was requested
[221048.329363] mt76x2e 0000:02:00.0: MAC error detected
[221049.559388] mt76x2e 0000:02:00.0: MAC error detected

Maybe firmware is buggy and needs an update? No idea. Maybe some MediaTek guy can chime in ...