MT7621 on 22.03.0: SSH drops over Wifi

I've recently installed 22.03.0 on my Netgear R6220 and immediately after installation I noticed that I can't use SSH over Wifi.

The issue is the same as this: [SOLVED] SSH over wifi stops working on RT3200/E8450 with 22.03.0-rc6 and fixed here: https://github.com/openwrt/mt76/commit/5ec78e1ec43d1e39edfea1efb9fd4541fa004af0

In my case, drops start so soon after connecting, I can barely run a single command.

I'm posting this because I'm not sure the above fix made it to MT7621 / other devices. I've tried understanding where the commit from the second link went, but I wasn't successful. Could someone shed some light?

It made it to 22.03.0, and works just fine. It might be something different in our case.

You mean in my case? Or do you also experience this issue?

Is there any information I can supply that help tracking this down? Syslog unfortunately only says "Connection reset by peer". Rolling back to 21.02.3 immediately solves it and SSH works reliably again.

Try with:

And over 2.4ghz

5ghz still buggy

I had that option enabled already. 5 GHz is still buggy in general you mean? Because in 21.02 it's super stable and I have no problems at all. I've been using this RT6220 with OpenWRT for years, haven't even restarted it in 2022 I think :wink: