MT7621 incompatibility with mesh

I have a Netgear R7800 with 22.3.3 and a few Asus Lyra as nodes (snapshot because it has DSA and it’s seems stable enough and didnt want to redo configs in the future). They are in a 802.11a mesh running batman-adv, with a few different ssids/vlans. I can’t express how stable and how non fuzzy this runs: it just works with zero problems whatsoever.

But I can’t for the love of god make MT7621(a) devices like my Xiaomi Mir3G and TP-Link Re-650v1, work in the same mesh as my R7800 and Lyra. The wireless mesh connection will show excellent connection. The Re-650v1 will even connect at 160mhz to my R7800 (but for some reason my R7800 doesnt work in AP mode with 160mhz, but for some reason it works in 802.11s mode). I can get an IP from the R7800 gateway, if I connect via a MT7621 node (both wireless and wired) albeit it’s kinda “shaky”, but that’s about it. I am maybe able to load a simple webpage as if I am lucky. Once I even managed to initiate and it showed 0.2mbs. You get the picture.

It goes also the same the other way: If I am connected to my R7800 or Lyra I can just about access Luci on my MT7621 devices..but it’s slow and it’ll hang up etc.

But if I create a mesh only with Mir3G and RE-650v1, then they work perfectly together. I don’t care that much for the Mir3G (although it’s actually usable now compared to a few years ago) but the RE-650 would make a great mesh node, but it seems it’s not meant to be.

Does anyone know what’s the root cause of this incompaitbility?

1 Like

Yeah, there is/was a incompatibility between atheros/mt76 drivers (, which could be gone.
There were many fixes lately.

This one is most relevant, I think:;a=commit;h=ec33a6ca2cd16e92d2a544f38704405c043c822d

1 Like

It works as it should with snapshot. lol..
I guess I thought it can't be down to the drivers cos 22.3 is relatively new, and mt7621 has been around like ages so there's gotta be zero chance that a serious bug affecting all MT chipsets hasn't been fixed already.

Fair enough. Been bugging me since before Openwrt 19.7. I'm just happy that it's fixed.

Adding this for reference, in case it can help anyone else:

Just upgraded from 22.03.3 to todays snapshot on my 2 R7800. Went without a hitch, but with the result that my Lyra nodes wouldn’t pass traffic, although I got an ip address on my pc. Didn’t test with my MT7621 devices. So it’s back to 22.03.3 on my R7800 and then run snapshot on my other devices. Hopefully the next major Openwrt version will unite them all🙂

1 Like

I recently built firmware from source for my R7800 using latest snapshot. (upgraded from imagebuilder image from november 2023). They continue to work better than ever before.

However it seems my RE-650 running 23.05.3 can't mesh with them anymore. Everything else works fine.

At my folks place I have a R7800 running the same imagebilder firmware from november 2023 and it meshes just fine with a RE-500 (same hardware as RE-650) running 23.05.2, again imagebuilder.

Maybe the answer lies here somewhere:

Anyways, I'm gonna try building from snapshot for my RE-650 and see if that solves the problem. Just putting this out there in the meantime.

EDIT: I tried building firmware of another MT76 based router, and it worked fine meshing with the RE-650.