Mt7621 and mtk ax drivers

I see rai0 and: br-lan, eth0, lan1 lan2, lan3, lo and wan.

I can only edit/enable the configs at the bottom of the screenshot. Sometimes when saving/applying, the router hangs, sometimes it crashes, sometimes I have to pull the power and it boots with no Ethernet. I am only setting the country and enabling.

When I am able to configure and enable the bottom config, I never see any device on-air.

root@OpenWrt:~# lsmod | grep mt
mt_wifi              6788270  1
usbcore               154946  5 ledtrig_usbport,xhci_plat_hcd,xhci_pci,xhci_mtk,xhci_hcd
xhci_hcd              120605  3 xhci_plat_hcd,xhci_pci,xhci_mtk
xhci_mtk                4978  0
Wed Jan 25 23:28:15 2023 daemon.err uhttpd[992]: ra0       No such device
Wed Jan 25 23:28:15 2023 daemon.err uhttpd[992]:
Wed Jan 25 23:28:15 2023 kern.warn kernel: [  326.889085] HTC_ICV_Err_TH=5

ok i need sleep to tired and to much wine, domani รจ un altro giorno e si vedra
we will make it

1 Like

In case you missed it.

hi @lleachii i found some info, and alot things are missing, i'll try to make it together, and we can start again. rai0 is wrong, the two radio should be ra0 and rax0

1 Like

with last i have only rai0 without macaddress
no rax0


rai0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:23

yes i know, is all wrong, i'm trying to make things right

1 Like

This post was flagged by the community and is temporarily hidden.

listen, you're starting to be very offensive now, try to be a man and not a corporal
if you do not understand that, seach for

Toto' siamo uomini o caporali

If users want MTK drivers they should use the OEM firmware and report bugs to the OEM.
You could do something better with your time than trying to make this work, which will never work properly because it can't, in the best case scenario you'll only provide builds at request, or provide updates once every few weeks or months or years, or none at all, builds on which users can't install a lot of packages, builds which will be hard to keep up to date by you.
And you're not helping OpenWrt in any way by wasting time on this.
So yeah, a bottle of wine sounds better :wink:
And keep it in english.
Cheers.

are you sure?
we will see

1 Like

You missed:

This worked with the normal repositories (i.e. I can install everything). Perhaps you should inquire what the OP is doing if you don't know, instead of assume.

Vorrei avere una frase che suona davvero mafiosa da dire qui.

:rofl:

i hate this kind of people, they ruined italy

Apologies. I'm from the USA, and I have recently read/researched a lot of the history (especially with the arrest of one of them a few weeks ago). No offence meant - apologies. They tend to be seen with movie-like appeal as a opposed to serious criminals that ruined the communities of the law-abiding society/neighborhoods of Italy.

I will continue to be a man [cordial person] and not become a corporal here.

Let me know when you have a new image to test. :+1:

i just sented

1 Like
  • No wireless menu
  • rai0 has no MAC

(Also, your image is ~1.5 MB larger than official.)

i know i forget to include the wireless menu can you show ifconfig -a

rai0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:22

do you have ra0 rax0 apcli0 apclix0 ?

No, no, no, no.

Just rai0.

no good, i need buy a device.